Problem: Smart SDR Flex Control Problem

  • 3
  • Problem
  • Updated 3 years ago
I am running a Flex 6300 with Smart SDR V 1.5.1.152

Having two problems.  

The first is that Aux 3 button on the Flex control turns itself on every so often.  It Happens even when the Radio is on but I am not doing anything with it.  I have changed the functions of the three buttons but that doesn't seem to make a difference.  Regardless of what function I have assigned, only the Aux 3 button turns it self on at random intervals.  I can turn it of my clicking the tuning knob but it always comes back on in 5 minutes or less.

The second problem is that one of the settings on the Radio Steup - transmit panel does not stay on.  I use the RCA TX1 output to key my amp.  Whenever I turn the radio off, this function gets disabled.  When I restart the radio I have to go in each time to enable it.  How can I make that enabled choice remain enabled?

73...   Bill K3WA
Photo of Bill Axelrod

Bill Axelrod

  • 33 Posts
  • 12 Reply Likes
  • Very happy with the 6300 despite these minor issues

Posted 3 years ago

  • 3
Photo of Bob G   W1GLV

Bob G W1GLV

  • 652 Posts
  • 109 Reply Likes
This happens with the middle button. Every once in a while it will turn off and come back on without intervention from me. I changed the assigned port but it still does it. My rig is a 6500. Win7, 8Gb of memory, ASUS motherboard. By the way this condition never existed before 1.5.0..
(Edited)
Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1706 Posts
  • 580 Reply Likes
Hi Bill,
RE: the TX1 issue.

I noticed the same thing.   I can re-enable TX1 by either going to the radio settings screen or selecting a TX profile that has it enabled.  

In my case I set up a profile for Amp ON and one for Amp OFF.   More details about the setup and and a potentially better solution are discussed here:

https://community.flexradio.com/flexradio/topics/a-third-profile-category-for-hardware-settings

Regards, Al / NN4ZZ  
al (at) nn4zz (dot) com
6700 - HW......... V 1.5.1.70
SSDR / DAX...... V 1.5.1.152
CAT................... V 1.5.1.0
Win10 
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
Bill - this may be an intermittent failure of the button where it closes without being pressed.  I recommend opening a HelpDesk ticket so we can investigate further.
Photo of Simon Lewis

Simon Lewis

  • 495 Posts
  • 117 Reply Likes
its not Tim ... its a bug from what I can see not a HW issue

I can confirm today in 1.5.1

Set Button 3 to XIT

hit Aux 3 and XIT activated

Turn it off on XIT SSDR button and touch the VFO and the XIT activates again

Turned the XIT off in the SSDR flex control settings and the FC is no longer tunes the radio

you can switch slices and send CWX messages if assigned but Aux 3 stays lit and the VFO control is inhibited

I tried disable and reenable from the radio control panel worked once but I had to ditch SSDR and restart the PC to clear it

def a fault

Cheers

Simon ZL4PLM
Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1706 Posts
  • 580 Reply Likes
Hi Simon,
I think my FlexControl does the same thing as you are describing.  And I assume it is by design.

Once you enable XIT by pressing AUX3 it remains in effect until you select another function for the FC by pressing a different button.

So even if you clear the offset or turn it off from the SSDR panel it will re-engage if you move the knob but haven't selected a new function on the FC.  

I'm not sure they could just reassign the FC knob function to something else.  (what would it switch to doing? and wouldn't that be confusing also? )   The other option would be to disable the FC knob completely but that would probably cause confusion too.  

Is this what you are seeing or is it something else?

Regards, Al / NN4ZZ  
al (at) nn4zz (dot) com
6700 - HW......... V 1.5.1.70
SSDR / DAX...... V 1.5.1.152
CAT................... V 1.5.1.0
Win10
Photo of Simon Lewis

Simon Lewis

  • 495 Posts
  • 117 Reply Likes
Hi Al

the behaviour I have is different

if I press Aux 3 that's fine .. XIT comes on .. I can use the FC vfo knob to move it

turning off the xit from SSDR button (not FC) it turns off ..

Moving the VFO knob now reinitiates XIT

and if you don't touch the FC VFO knob at some random point XIT will just appear on again

I am not that worried .. Maestro will be here soon and I won't be using it

But its behaviour is bizzare


surely not by design?
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
This is by design as I described previously.  You have to push the VFO knob to reassigned the knob to the control assigned to the knob (tuning a slice).  If you turn off XIT on SmartSDR and then change XIT frequency using the FC, it will do what you have instructed it to do - tune XIT so it turns it back on.
(Edited)
Photo of Cal Spreitzer

Cal Spreitzer

  • 346 Posts
  • 61 Reply Likes
Bill I have the same problem with RCA TX1!  I haven't figured out how to get the darn thing to stay on! 

Cal/N3CAL