Problem deleting old 1.3.8

  • 1
  • Problem
  • Updated 4 years ago
  • Acknowledged
As I was about to install 1.4 I paused and debated deleting 1.3.8 first. Given what happened with 1.3.8 over 1.3 I decided to test 1.4 and then delete 1.3.8. After 1.3.8 was installed I successfully uninstalled 1.3.0 so I didn't see the harm in that approach. I uninstalled 1.3.8 and rebooted. I received an error on reboot that the DAX drivers are missing or the install was bad or words to that effect. CAT did successfully start the DAX applet successfully started and shows DAX ch 1 receiving audio. DAX IQ shows 4 channels and under slice a->DAX it shows all eight channels. I paid special attention when the dax code was being removed (cmd line uninstall) and it was running in the 1.3.8 subdir so I felt pretty comfortable I wasn't hosing anything.

The error message is "An error has occurred while trying to open a DAX sound device, The following fault conditions may apply".

What precipitated this is I went to Programs and Features and deleted Flex 1.3.8 (not touching Flex 1.4.0.

While I am not convinced that has anything to do with the 1.4.0 install I wanted to document this just in case there is some documentation you want to make on this. I don't understand why deleting the 1.3.8 system corrupted 1.4.0.

Upon reinstall of 1.4 I received the same error message again. However, after a reboot and re configuring DM-780 Everything appeared normal. The error message did not return upon that final reboot.

Walt - kz1f
Photo of Walt - KZ1F

Walt - KZ1F

  • 3040 Posts
  • 643 Reply Likes

Posted 4 years ago

  • 1
Photo of Steve - N5AC

Steve - N5AC, VP Engineering / CTO

  • 1030 Posts
  • 999 Reply Likes
The drivers for DAX and CAT are common across versions of SmartSDR, generally.  If you remove an old version of SmartSDR and tell SmartSDR to remove the drivers, it will remove the drivers and then they will be gone for v1.4 also.  If you accidentally do this, just reinstall v1.4.  Sometimes if you've used them when you're doing the uninstall a reboot may be required to get everything back in the proper place.
Photo of MH_Flexer

MH_Flexer

  • 65 Posts
  • 13 Reply Likes

This is mentioned in the Release Notes as well.  I faced the same decision, but I uninstalled  1.38 first then ran 1.4.  All you have to do is just run the install for Version 1.4 and all should work again.


dmr

This conversation is no longer open for comments or replies.