Preparing for 2.x - More Data

  • 1
  • Praise
  • Updated 1 year ago
  • (Edited)
So I have not been super happy with my home net setup.  Add to that the fact that I am a tinkerer that loves to try new stuff and update things.

I don't operate much remote as it hasn't been the best.  I am excited about 2.x and followed closely the setup on the other prepare for 2.x thread.

Here is some info that might help others:

1) I had a netgear nighthawk 7000.  In general the router worked pretty well but at times would just lose its mind.  A reboot generally fixed it.  What I liked about this router was the very easy OpenVPN built in.  This has worked pretty much flawlessly.

2) My ISP is comcast who at times can be great, other times horrible but since I don't work from home much anymore I am on the residential feed so probably the worst night is Saturday night when everyone on the block streams a movie.

3) I followed the testing in the other prep for 2.x thread and I was interested in the IQ router mentioned.  The issue I would face was to replace my nighthawk router I'd lose the built in VPN.  So Raspberry pi to the rescue.   Here is my short story:

I used raspberries for other projects and I have a linux / unix background.  I'm no networking expert but I can find my way around the box.

I got a new pi and tried the softether approach mentioned on the forums here.  I couldn't get many things to work but after much fiddling I got the server loaded and working.   Ria, if you read this I did try a direct copy of your wonderful script but it bombed for me during the tar extraction.  No idea why.

Anyway with softether and I know many of you are successful I could get connected from the outside world to my pi vpn but once connected I had no routes and no IP on my LAN.  IE I could not access anything.  I tried a number of different configurations and had the same result.  I even posted a message over on softether but got no responses as least as of yesterday.

With the nighthawk the built in VPN was openvpn.  I don't know whose is better.  I'm not hosting the fort knox balance sheet and while a hacker might be able to have a little fun on my network nothing is mission critical and I have some other safe guards I'll not mention here.

Anyway after a few frustrating days with softether I was ready to just stick with my nighthawk and openvpn.  I figured I'd find a use for the pi.  Then I stumbled upon:

http://www.pivpn.io/

I figured I had nothing to lose so I typed in their recommended command into my freshly reformatted pi.  It took quite a while but in the end it said it was complete.

My vpn pi has a static IP.  I already have no-ip dynamic dns setup.  The script asked for all of those.  When it was done I had a command:   pivpn   that allows you to add connections.  So I added a remote connection.

I emailed it to my phone and drove to the gas station.  I hit connect on the openvpn client after loading the config.  About 3 seconds later I was connected!!!  I thought awesome!  This will be great!

I then ran the iOS Smart SDR.  Could not find the radio.  Damn...  Ok drive home.  Play around.  Then I realized the issue was in the location of the radio using UDP.  I gave the radio a static IP on my LAN and headed to the gas station again.

Connect,  Almost instant connect.  iOS SmartSDR, change the settings to FIXED and put in the IP and there it was.  I was watching the Pan on my phone.  It was working very well.

Being greedy I knew the static IP of my home laptop so I downloaded Jump Desktop (probably the BEST RDP/VNC viewer on the mac there is).  Typed in the IP of the laptop and in seconds had the desktop.

I fired up SmartSDR on the Windows desktop forced a disconnect of my iPhone client and ran SmartSDR for windows over RDP.  I even got sound!  Now I know that RDP does a number with sound drivers and is not how it should be used most likely but I just wanted to see if it worked.

I then tried accessing my remote web power switch.  That worked too.  So my Memorial day was a success.

I put in the brand new IQ router.  It is happily optimizing my network as I type this.  I setup the PI and installed the OpenVPN server.  It is working well.  Last thing I did was to configure my nighthawk router in access point mode and put it in a section of the house where the WiFi is poor.  It came online nicely.  

So this is an alternative to the softether.  Not going to try and argue better or worse but in fiddling with softether for several days without success, I even tried setting up a windows server when I was having problems with the pi.  This was like a breath of fresh air.

It works and it works very well so far.  I'll update this message in time as I learn more.

Now I know that 2.x is supposed to remove the need for a VPN.  But I have other needs for it such as my ability to remote run my laptop (I hate TeamViewer... i have to use it at work but I despise it).   I have certain controls on my LAN I like to get to.  Now I can again with VPN like I did with my nighthawk router.

Already my new IQ router has made some changes.  My wife noted that her streaming of videos from CNN was significantly better than it was before the switch over this morning.

Also one last point.  I wouldn't say the IQ router was a breeze to setup.  Mine could not seem to establish a network connection when plugged into the cable modem.  I've done this enough times that I went to advanced mode and figured it out but that left a few steps in the process undone (like the optimizations).

So I sent evenroute a support request and here it is a holiday and they got back to me within the hour!   Pretty darned cool.

Mark - WS7M
Photo of Mark WS7M

Mark WS7M

  • 311 Posts
  • 85 Reply Likes

Posted 1 year ago

  • 1

Be the first to post a reply!