PowerSDR Crash After Transmitter Carrier Surpression Test

  • 1
  • Problem
  • Updated 2 years ago

Hi @ all


I have an Flex-5000A, running PowerSDR v2.7.2 on Windows 10 pro 64bit

After a TRX I/O Test all works fine except the transmitter carrier test.


In the Carrier test form, all tests from 160 to 6m are passed, but then a window pops up "PowerSDR is not working anymore, a problem prevented the program from running properly." Close the program.


Then PowerSDR crashes.


I thought it was Win10Pro 64bit, so I reinstalled Windows 7, but there I have the same problem.


Then I flashed the firmware from v1.4.7 back to v1.3.9, again the same problem. Then the firmware back to 1.4.7 flashed and tried with PowerSDR Again the same mistake.


I also started PowerSDR as an administrator, and tried the compatibility mode of Windows ... unsuccessful


I saw that PowerSDR wrote a file named tx_carrier.csv to the folder \ Appdata \ Roaming \ FlexRadio Systems \ PowerSDR v2.7.2 \ Tests \ after the Transmitter Carrier Test, but this file has 0 bytes and is empty.


When I run the TX Filter and TX Image Test, folders named TX filter and TX Image will be written after the test has finished, but the TX Carrier Test will not show a folder named TX Carrier in the above directory.


Of course, the data of the TX Carier test will not be written to the eeprom.


So again briefly summarized:


The TX Carrier Surpression Test is running.

All bands pass the test

After that, nothing is written to the EEprom.

No TX Carrier folder is created.

An empty tx_carrier.csv file is written to disk.

A Windows error message appears

PowerSDR crashes.


What can I do? Any suggestions?

I have a bad feeling when the TX carrier suppression is not working properly.


73 de Walter, DD8JJ


This is a google translation, if anything is wrong it's up to google :)

Photo of DD8JJ


  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1

Be the first to post a reply!