Power set via Profiles

  • 1
  • Question
  • Updated 8 months ago
  • Answered
I have created profiles for all HF bands when operating barefoot and with a linear amplifier that requires <10w drive for full output using the radio alone and with SSDR on my external monitor.
If, I use the radio screen alone (6600M) I cannot adjust the power out once its set in the profile.
However, if I use my external monitor with SSDR, the power originally set is there but it can be adjusted to any value.
I cannot afford that power level to change when using the external linear amp.
Thoughts?
Photo of Tom W3FRG

Tom W3FRG

  • 98 Posts
  • 17 Reply Likes

Posted 1 year ago

  • 1
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3972 Posts
  • 967 Reply Likes
In setup, you can set the max power out...under setup  then TX
Photo of Tom W3FRG

Tom W3FRG

  • 98 Posts
  • 17 Reply Likes
I believe your referring to "Radio Setup" when you mention "Setup"?
That's nice, but it doesn't apply to all of the bands that need a different Pout setting.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3972 Posts
  • 967 Reply Likes
Then I think it is best to create a profile per band? and use profiles to switch bands and everything is saved the way you want it
Photo of Tom W3FRG

Tom W3FRG

  • 98 Posts
  • 17 Reply Likes
I have set each band individually to its unique Profile with the required Pin for the amp. I have generated both Amp and Barefoot Profiles. 
What this appears to say, is that the "Radio Setup" does not report back correctly the power setting for the individual Profile selected, but 100w unless also set to the power level desired and then also saved in Radio Setup?
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3972 Posts
  • 967 Reply Likes
I guess I am not understanding your problem. If you set power in a profile it should never change, so if it is set to 10W  then it stays there. Each band can be saved and should not change your setting.
Photo of Tom W3FRG

Tom W3FRG

  • 98 Posts
  • 17 Reply Likes
To help you understand my problem, I just newly created a Linear Amp profile named "RF 2K". 
Pout is set to 10w on the Power output slider on my external monitor running SSDR.
I then went to "Radio Status" and set the power level max to 10w.

I went back to my "Barefoot" Profile and instead of being set at 100w it also was set to 10w, both on the RF Power Out slider on SSDR and the Radio Profile power level.

That help?
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3972 Posts
  • 967 Reply Likes
The radio max out, I think that is what your talking about,,will over ride your barefoot profile. Set it to 100W,,,then when you select your bare foot profile it should set to 100W and all your other profiles should respond correctly
Photo of Tom W3FRG

Tom W3FRG

  • 98 Posts
  • 17 Reply Likes
That's where the problem lies, they don't.

BUT, my original issue was that I can change power levels when using the SSDR on a remote monitor where I cannot change power levels when using the 6600M monitor.
Regardless of what the "Radio Status" power setting is.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3972 Posts
  • 967 Reply Likes
Profiles are not working as they should
It is possible that things are mixed up a little, you can do a factory reset to set all settings to default, then download your profiles back. This will reset all the radio data.
(Edited)
Photo of Wayne

Wayne

  • 614 Posts
  • 89 Reply Likes

Why cant you just reach to the right of the touch screen and turn the outter ring  on the same knob as you use the inner ring for to adjust the mic gain? It always works for me, that way the new power level wont be saved in the profile and the profile level will return when reloading the profile.

That's how I do it when I want to tune the amp I lower the power with the knob and when done tuning I just turn it back to where I want.


Photo of Tom W3FRG

Tom W3FRG

  • 98 Posts
  • 17 Reply Likes
And what happens when you get side tracked and forget?
Photo of Wayne

Wayne

  • 614 Posts
  • 89 Reply Likes
My KPA500 faults out I reset it turn the power down and off I go only takes about 8 more seconds.
Photo of Tom W3FRG

Tom W3FRG

  • 98 Posts
  • 17 Reply Likes
The main issue I see is that using the radio in stand alone, touch screen, you can create a profile with the RF Pwr set to a required level.
When you recall this profile, you can go to the RF Power slider and move the RF Level, and it will snap back to the original profile setting.

However, if you do this using SSDR on a remote monitor, it will not snap back to the required setting, but stay to wherever you just set it to.

That's my concern that the RF level will be to high, or maybe even to low?
They should both react the same, regardless.

Tom
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9197 Posts
  • 3557 Reply Likes
Official Response
I cannot reproduce the behavior you are describing.  I created a global profile (along with a TX and Mic) on the 6600M for 20m with the RF power set @ 30W.

I tested the profile on the 6600M multiple times and the profile loaded the correct settings.  After the settings were restored by the global profile, I was able to change the RF power on the 660M to any setting and there was no "snap back" to 30W.

I disconnected the user and rand SmartSDR for Windows.  I loaded the global profile and it behaved exactly the same as when I was using the 6600M Front Panel.

The only control that will produce the "snap back" behavior is if the MAX POWER value is set in the radio to something less than 100W.  This is set in SSDR-Win in the  Settings->Radio Setup->TX tab or Menu->TX on the 6600M Front Panel.

Once that value is set for the radio, it is recognized and used with both clients (SSDR-W or the 6600M Front Panel)

So I set the Max Power to 10W and if I load the global profile I made earlier for 20m with the wattage set for 30W, the profile loads, but the wattage on the radio is set for 10W.

Max wattage is not saved is not saved in the TX profile, only setting the initial power level.
Photo of Tom W3FRG

Tom W3FRG

  • 98 Posts
  • 17 Reply Likes
Tnx for the input Tim,
Unfortunately, I was incorrect in my description.
In the "Radio Setup" in order for SNAP BACK to occur, the Max Power must be set to the required level.

Unfortunately, and this is where I have issue, is that once the Max Power is set for a profile, it stays there regardless of what profile is loaded.
I would like to have profiles with different value Max Power settings.

ADDENDUM:

I just retried this power setting, and if I set the MAX Power under Radio Setup to the desired level for each band in question, it stays with the chosen "Select Tx Profile" and Snap Back occurs.

Tom
(Edited)
Photo of Richard Zalewski

Richard Zalewski

  • 87 Posts
  • 9 Reply Likes
I quite agree.  Setting max power to 100 and then "remembering" to turn it down when driving an amp is crazy.  The max power should be part of the profile by band.
Photo of Don - kx9q

Don - kx9q

  • 465 Posts
  • 22 Reply Likes
I am trying to create two TX flex profiles.  One will be set to 100 watts or full power without the amp.  The other one I want to set to 60 watts so I don't overdrive the amp.  I created one profile on all the bands for 100 watts and saved the profile.  I then created a second profile with 60 watts being the max output and save that profile with a different name. Now when I try to load the profile that sets power to max or 100 watts it will not load and the power is stuck at 60 watts on all the bands and under Settings/Radio Setup/TX it shows 60 for max power and I cannot change it.  In fact even if I delete the two TX profiles I still cannot change the RF power setting from 60.  Any thoughts?


Don - kx9q
Photo of Andy - KU7T

Andy - KU7T

  • 257 Posts
  • 25 Reply Likes
I believe you need to set your drive level to either 100 or 60 for the appropriate profiles and keep the max power at 100.

This output power thing for amp vs no amp is very cumbersome. I agree with you. I have overrun my amp too. The way the profiles work for RF level is not intuitive. I wish power level would persist per ANT/band and not fall back to the profile. This is even a bigger issue for SO2R when you switch fast between different slices. You basically cannot adjust the power level at all, except by saving the profile. 

Because its been bugging me a lot too, I am trying myself in writing a little program with the I will give it 3 buttons (low, mid, high) that allows me to set and remember the power level and program will store the levels for each ANT/band and power level. My goal is to run the amp always but with very little drive if I want 100 or say 500W. I will share it with you if you are interested and when I am done.

73
Andy
KU7T
Photo of Don - kx9q

Don - kx9q

  • 465 Posts
  • 22 Reply Likes
HI Andy

I am interested so please keep me in mind.

When you say drive level are you referring to the RF Power slider?

Don - kx9q
Photo of Andy - KU7T

Andy - KU7T

  • 257 Posts
  • 25 Reply Likes
Yes, with drive level I am referring to RF power. 

Andy
KU7T
Photo of Don - kx9q

Don - kx9q

  • 465 Posts
  • 22 Reply Likes
If I attempt to set the RF power to anything above 60 it snaps back to 60.  I am not sure how to get beyond this point.  Perhaps a power off and power on for the flex might help.

Don - kx9q
Photo of Andy - KU7T

Andy - KU7T

  • 257 Posts
  • 25 Reply Likes
Seems like your max power is set to 60. You need to set that to 100. Note the max power setting is NOT part of your TX profile, its is part of the Global profile I think.

Andy
KU7T
Photo of Don - kx9q

Don - kx9q

  • 465 Posts
  • 22 Reply Likes
when I set the max power to 100 then try to change the RF Power to 100 the RF Power snaps back to 60 and the max power also snaps back to 60.  Weird!

Don - kx9q