Port Forwarding issue in v. 2.2.8

  • 2
  • Question
  • Updated 7 months ago
I'm having a problem with SmartLink. Automatic port forwarding comes back red. The test on port forwarding comes back showing UPnP port PASS, but Forwarded ports FAIL. I've tried all sorts of different port numbers in manual forwarding with the same result.

If I'm not mistaken, the message that UPnP port PASS indicates that the issue is not with my router, but with something on the radio side. Or am I misinterpreting that???
Photo of Mark K0JM

Mark K0JM

  • 22 Posts
  • 1 Reply Like
  • frustrated

Posted 7 months ago

  • 2
Photo of Steve Moore

Steve Moore

  • 5 Posts
  • 1 Reply Like
Same problem at my QTH.  I port forward Fusion, echolink, etc., no problem.   With Smartlink no luck.  I determined it has to do with the AC wifi side of the router.  When I jack into the router it works.   When I go wifi it fails.   Solution here at this QTH is to pull CAT6 to the radio room --> switch --> rig and PC.   
Photo of Mark K0JM

Mark K0JM

  • 22 Posts
  • 1 Reply Like
My rig and PC are already hardwired to the router, so don't believe wi-fi is the issue here. I had SmartLink working fine a few months ago. Got home from a trip and didn't use it for awhile. Now that summer has come, thought I'd test it out and no go. Nothing has changed other than the software version.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
Unless your router, if it is provided by your ISP received a software update you are not aware of, that could be the change that is causing the connect issue.
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
If your router supports UPnP, it is configured for UPnP (the default may be off) and you click the test button, if it turns green you are good to go.  Only one of the three options will work,  Not all three will pass.
Photo of Mark K0JM

Mark K0JM

  • 22 Posts
  • 1 Reply Like
Yeah, I get that red means it won't go. But I'm not getting a straight answer to my question. Here is the complete text I get in the pop-up box when I hover the mouse over the Test:

Radio cannot be accessed using SmartLink
UPnP Ports:
     TCP=PASS
     UDP=PASS
Forwarded Ports:
     TCP=FAIL
     UCP=FAIL
Hole Punch Supported: No

My question is simply, "WHAT DOES THIS MEAN?" What and where are these failed forwarded ports? If I know that, maybe I can trouble-shoot in the right place.

The log on the router shows the port forwarding happening.

But the circle for SmartLink on my screen is still red.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
When you click the Test button, the radio tries to initiate a proxy connection to the SmartLink server (in the cloud).  It will first send a UPnP message to the routers and if it responds, they exchange information that allows the router to set up port forwarding automatically.  Now the radio knows it has a UPnP connection to the router.  Once that is established, it does not try the other two methods (manual port forwarding) and Hole punching.

Now you run the test.  The radio sends SmartLink commends that will emulate a client connection and if that passes, then the dot is green.  If it fails, as it has in your case, the dot turns red.

The information provided indicates the radio believes it has a valid UPnP connection established with the router, but data did not pass through it correctly.  I an suspect of the UPnP configuration or operation on your firewall/router.

If you can get to your router management interface, and if it has a UPnP status, it should show the radio, the outside ports it selected for the TCP and UDP data streams and the internal ports.  If you can get this information, that will help to debug the process.

Also if UPnP is enabled, you should not set up manual port forwarding, as that can confuse the router if the endpoint IP (the radio) is the same.  
Photo of Mark K0JM

Mark K0JM

  • 22 Posts
  • 1 Reply Like
By setting the radio to a static IP address, and designating that address in the router as a DMZ, I am able to get the green light on SmartLink.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
Great. Your making progress. The challenge is not all routers setup port forwarding and UPnP similarly. I suspect your router only allows thei type of access through a DMZ
Photo of N8SDR

N8SDR

  • 120 Posts
  • 22 Reply Likes
While DMZ will pass the info (because it is OPEN) it is not a desired means to allow communication between the device to the outside world(internet) this is leaving you wide open. Have you tried resetting your router and then turning on UPnP. its possible some other application may have tried setting its self up using the ports needed and the router is more or less confused. I'd only suggest you keep it in DMZ mode if all else has failed, and even at that point I switch out routers myself before leaving t open like that.