Port Audio Device Not Available

  • 1
  • Question
  • Updated 4 months ago
Getting this error when clicking the portaudio box in Fldigi configuration for audio.  DAX is running and I can see the gain bar moving back and forth so I know it is working.  any ideas?
Windows 10, latest update for 6500, all drivers updated.
Photo of Nick

Nick

  • 46 Posts
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of Neal - K3NC

Neal - K3NC

  • 48 Posts
  • 15 Reply Likes
Nicjk

Could you take a screen snapshot of your FLDigi audio settings window? Also take a snapshot of the DAX control panel. My suspicion is that your DAX setup is messed up by the WIndows 10 Spring Update and you are seeing a symptom of it when activating the portaudio checkbox in fldigi.
Photo of Nick

Nick

  • 46 Posts
  • 0 Reply Likes
Hi Neal,  I think the problem is with the PC.  The PC Audio button on the top of the UI shows a fault  (!) and is blue.  The tool tip says an invalid playback device is selected.  I've gone through every possible selection on the sound window and the only setting that clears the error is the PC speakers, when that is selected raw audio is output through the speakers (No volume control via the UI) and the button does not turn the audio on or off.  This is a standard HP computer with no mods or additional h/w so I'm thinking it might just be a compatibility issue with this version of SmartSDR. I may try dropping down to the previous version to see if it clears the problem when I have time.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
The default sound card device has to be your PC sound card and not a DAX sound device.  This is why you have the "!" indicating an error.

I would make sure you sound card drivers are up to date.

And we control the PC sound card through the Windows audio API and not all sound cards are 100% compliant.

I can tell you that changing the version of SmartSDR will most likely not solve the problem.
Photo of Nick

Nick

  • 46 Posts
  • 0 Reply Likes
One of the symptoms is that the audio is sent out through the PC speakers when the PC Audio is selected and when it is not.  so there is a problem with the button not switching the audio stream on and off.  Fldigi is saying there is no streaming device present so I can't even see the list of AF sources to select on.  something is crossed somewhere.
 
Photo of Nick

Nick

  • 46 Posts
  • 0 Reply Likes
does these look correct you? 
Photo of Nick

Nick

  • 46 Posts
  • 0 Reply Likes
Photo of Neal - K3NC

Neal - K3NC

  • 48 Posts
  • 15 Reply Likes
Nick
There is definite name mangling in your system. Whether this is the root cause of your fldigi problem I have no idea. If you create a trouble ticket for the DAX driver issues, I will be happy to solve those.73
Photo of N5LB - Lionel B

N5LB - Lionel B

  • 139 Posts
  • 24 Reply Likes
This is the closest to my problem that I've found.  I have opened a ticket, but here it goes anyway.

FLdigi no longer receives any audio from DAX.  DAX is working though I did uninstall and re-install per the Flex instructions using cmd.exe.   The list looks okay. 

I can't recall ever seeing port audio device not available.  My suspicion is some MS nonsense - maybe an update they slipped in over the last week or two.  FLdigi was working several weeks ago.

This started early this afternoon trying to set up WSJT-X and FT8.  WSJT could not open the audio device.  It went downhill from there.

I have attached a screen shot.

https://www.dropbox.com/s/dwu6s85isxjbpbp/screen%20shot%203.docx?dl=0

Any ideas appreciated.  I've given up on digital for now - too much time wasted today and headache from hitting the wall..   Still, any ideas. 

Photo of N5LB - Lionel B

N5LB - Lionel B

  • 139 Posts
  • 24 Reply Likes
FIXED -

"The fix for the loss of audio I/O for the Windows Update 1803 appears to be fairly easy to fix.

Go to Settings and select Privacy. Then select Microphone from the menu on the left side.

Check the box titled "Allow apps to access your microphone.

You will then have to decide which other, if any, apps need to be turned off or on (Camera, Cortana, etc.).

This was posted by Joe Subich, W4TV, earlier. Wanted to share it here."

Working on privacy concerns - and who shouldn't be worried - I turned off mic access and that as it turns out seems to kill Port Audio and probably other things.  Followed the info above and FLdigi and WSJT-X working fine.  Who knew??

You can still turn off individually the other "junk/trash/nonsense" access to the mic.

Paint me moron! I need a lessons learned list; starting now.