PC Audio Button on upgrade only clears when PC setting is set to internal speakers

  • 1
  • Problem
  • Updated 7 months ago
While trying to get a sound channel to fldigi I noticed a warring (!) indicator on the PC button in SmartSDR.  Going through all of the possible settings in Windows, the Output device has to be set to the internal speakers for the warning on the button to clear.  This dumps raw audio to the speakers.  Fldigi can't see the audio and indicates that there are no port audio devices available.  Is this the expected behavior?  Prior to the upgrade,  DAX audio and the speaker audio were not related.  (I didn't have to change the sound settings in Windows to use fldigi or the internal speakers on the PC.
Photo of Nick

Nick

  • 46 Posts
  • 0 Reply Likes
  • confused

Posted 7 months ago

  • 1
Photo of WA2SQQ

WA2SQQ

  • 422 Posts
  • 87 Reply Likes
FLDigi's audio input is from a DAX source, while your PC's speaker needs to point to your PC's sound card. Following the upgrade to Win 10, 1803 my PC speakers stopped working. Took me a few minutes to check and found out that an unused DAX channel was feeding them. Reselected the PC's audio card and all was back where it should be.