PC Audio Button in SmartSDR 2.1.30, 6300 MAC Address

  • 1
  • Question
  • Updated 8 months ago
  • Answered
  • (Edited)
I notice that the blue "PC Audio" button does not alternate between "Remote" and "PC Audio".  It seems to function properly but I can't tell by looking at the button which mode it's in.  Was this the Plan?  Why?  Did I miss something in the notes?

Also, it would appear that my 6300 MAC address didn't update as the Release Notes suggest.  Not a problem but I'm curious what isn't coming together here.

It doesn't look as though the IP Fragmentation issue was addressed in this release.  I'm really missing use of my Maestro when remote at my daughter's home.

I really like the single click to tune.   Now I don't get confused when I alternate between SSDR and HDSDR.  Best update in the 2.1.30 package for me.

Thanks in advance for answering the questions, Tim!
Photo of Bob - W7KWS -

Bob - W7KWS -

  • 270 Posts
  • 37 Reply Likes

Posted 8 months ago

  • 1
Photo of WX7Y

WX7Y

  • 536 Posts
  • 98 Reply Likes
check and make sure your default Windows sound device is correct in your Audio device manager

Did you power off the radio and power it back on for the mac to cange

Bret
WX7Y
Photo of Bob - W7KWS -

Bob - W7KWS -

  • 270 Posts
  • 37 Reply Likes
Chuck,

You must have misunderstood my question. As I mentioned above, the button functions correctly, it's just that the label on the button face of SSDR doesn't change. I'm pretty sure that the Windows "Audio Manager" nor the radio would impact the labeling of this button. Thanks however for taking your time to respond.

I think I need an answer that comes from the source of the change at Flex.
(Edited)
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 579 Posts
  • 120 Reply Likes
The label, "Remote" was changed to "PC Audio" in V2.1.x.  If it's not blue, i.e., not selected, then the audio is coming from the radio's output jacks.  If it's selected (and therefore lighted) , then it will be coming from whatever speakers or headphone you have hooked to your PC.

Rick, W0FG
Photo of Bob - W7KWS -

Bob - W7KWS -

  • 270 Posts
  • 37 Reply Likes
Thanks Rick!
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
Also, it would appear that my 6300 MAC address didn't update as the Release Notes suggest.  Not a problem but I'm curious what isn't coming together here.

How have you come to this conclusion?
Photo of Bob - W7KWS -

Bob - W7KWS -

  • 270 Posts
  • 37 Reply Likes
My router reserves an IP address based on the MAC address. The reservation is still valid.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
But is it active?  Reservations are static in nature.  Do you have a device on your network that has an OUI of 00:1c:2d ?

If you open Settings->Radio Setup and click on the Network tab, it will show you the IP and MAC address of the radio.
Photo of Bob - W7KWS -

Bob - W7KWS -

  • 270 Posts
  • 37 Reply Likes
Tim, this doesn't make sense to me but while you were writing your response I installed 2.1.30 on my PC. It showed the radio needed an update which, of course, I didn't expect.

All I can figure is that the 6300 update during the previous Maestro update failed. I should have tested the combination first but I went to the router and got distracted by the MAC address settings.

With the 2nd 6300 update, it's too late for me to determine what happened. If you have any other thoughts I'm all ears, but everything appears normal now. I'll let you know if that changes.

Thanks for your suggestions.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
Understood.  All's well that ends well, I always say.