Over and over: Firmware update required

  • 1
  • Problem
  • Updated 3 years ago
  • Acknowledged
Help, please! My Flex 5000 suddenly won't work.

PowerSDR 2.7.2 crashed when I specified a higher sample rate (a rate supported by my soundcard). After that, every time I start PowerSDR it tells me that a firmware update is required. I tell it okay. It verifies my radio is a Flex 5000 and says it does an update. (But I don't think so because it works the same if the Flex 5000 is powered off.) After it says the update is done it tells me to restart PowerSDR and it shuts down. But when I restart PowerSDR it again tells me a firmware update is needed! So I'm stuck.

I have no idea why a firmware update would be needed since I've been using PowerSDR 2.7.2 just fine.

I captured screen shots of the dialog boxes as a matter of diligence but they're not especially interesting or informative:





Help, please, because I can't use the radio at all.

Thanks for any help.
Photo of Bill McCarty

Bill McCarty

  • 4 Posts
  • 0 Reply Likes
  • sad, worried, confused

Posted 3 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3467 Reply Likes
Official Response
This problem is indicative of your PC and the radio hardware not communicating properly. I have converted this topic to a support HelpDesk ticket (http://helpdesk.flexradio.com) for expedited issue resolution.  If anyone else is experiencing an issue similar to this one, please submit a HelpDesk support ticket for issue resolution.