Not sensing KPA500/KAT500 - (6400 v2 Settings-->USB Cables...)

  • 1
  • Problem
  • Updated 2 months ago
Have official Elecraft USB cables and null modem adapter from Elecraft for FLEX 6000. Both tuner and amp have the latest software, and are set up according to FLEX instructions.

Both USB cables are autosensed by the computer and work fine with Win10 to check the software versions in both tuner and amp.

But when trying to complete the Tuner/Amp install into SmartSDR v2 the USB Cables are not to be found under Settings-->USB Cables...

Ideas please?  TNX Dave.

Photo of Dave - W6OVP

Dave - W6OVP

  • 306 Posts
  • 96 Reply Likes

Posted 2 months ago

  • 1
Photo of Michael Walker

Michael Walker, Official Rep

  • 826 Posts
  • 232 Reply Likes
Hi Dave

The USB cables for the back of the Flex radio must have the FTDI chipset.  Is it possible that the Elecraft cables are not FTDI?  

If you don't see them in Settings, but might be something to consider.  

You can test this by installing those same cable in a PC, then go into the Device Manager and then inspect the cables to make sure they are not the Prolific chip set.

That is the first thing I would look into.

Mike 
Photo of Pat - WH6HI

Pat - WH6HI

  • 367 Posts
  • 71 Reply Likes
The first cables shipped with very early Elecraft products were prolific ones, later they switched to FDDI.
(Edited)
Photo of Dave - W6OVP

Dave - W6OVP

  • 306 Posts
  • 96 Reply Likes
TNX Mike. Yes, these USB cables are FTDI. They did work fine as noted in checking the tuner and amp separately.

Elecraft has this 'kit' specifically to hook their Tuner/Amp to the FLEX 6000 series. (It is an xlnt combo btw. I have used it earlier without this auto-tune cable upgrade.)  -Dave

Photo of Lawrence Gray

Lawrence Gray

  • 159 Posts
  • 80 Reply Likes
I have the KAT/KPA combination used with a 6500. The Elecraft cables are plugged into the 6500 USB ports, baud rate set to 38000, and it works perfectly.
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1652 Posts
  • 600 Reply Likes
I've used the same combination without issue. There are menu settings on the KPA that must be changed from defaults. I'm not near a manual, but pretty sure they're in there.

Honestly, though, I stuck with the PC connection for the remote software. Both the KPA and KAT do a fine job without direct integration to the Flex. 
Photo of Dave - W6OVP

Dave - W6OVP

  • 306 Posts
  • 96 Reply Likes
I ran RF sensing mode for over and year but did not have a high enough confidence that it always worked right, so did not run remote with it. Now I feel confident enough to go out and work WAS (Worked All Starbucks) with the amp on. <g>.
Photo of Michael Walker

Michael Walker, Official Rep

  • 824 Posts
  • 232 Reply Likes
Make sure you post pictures
Photo of Lawrence Gray

Lawrence Gray

  • 159 Posts
  • 80 Reply Likes
Photo of Dave - W6OVP

Dave - W6OVP

  • 306 Posts
  • 96 Reply Likes

The system may in fact be working as designed, simply not as I anticipated based on instructions. The bands do change with changes in SmartSDR if:

1) The TUNE button is pressed, and
2) The TUNE power setting is larger than 0.

But that is no different than before without the extra cables.

ELECRAFT document E740349 rev C, part of what I used for the install says "As you tune your transceiver, the KAT500 will follow and automatically select the correct ATU tuning solution, EVEN BEFORE TRANSMITTING."

Does TUNE above mean to change frequency or bands, or to apply RF power? I had presumed the former. Tuning with any amount of power is called TRANSMITTING.

As of now actual RF based TUNING is still required to change bands. I had assumed the amp would track the 6000 'automatically' and without manual intervention but that isn't happening.

Finally: The Elecraft Cables (which work perfectly when used individually with the amp and tuner) do NOT show up in Smart SDR v2 and Win10 latest.

This is where I am stuck...



Photo of Michael Walker

Michael Walker, Official Rep

  • 824 Posts
  • 232 Reply Likes
Hi Dave

Do you have any other FTDI USB cables that you can use to test with on the radio. We want to make sure that the USB port on the radio is functional.   When you go to Settings/USB you will see them if they are working.  If you don't see them, then, of course, the radio cannot be configured to send RS232 data to the amp.

Based on what you are seeing, the Amp is tracking just fine on RF Sensing.  

I also use the KPA500 with the USB output from the radio it does work once the radio can actually see the cables plugged into the back of the radio (not the computer... just to be sure).

Mike 
Photo of Dave - W6OVP

Dave - W6OVP

  • 306 Posts
  • 96 Reply Likes

Ahhh uhmmm... Radio? Radio?? As in the back of the 6400???

   BINGO!!!

Occam's Razor strikes again. Aaaagghhh! I was plugged into the computer.

This one flew right over my head. Presumed the software controlled all directly from the computer.

TNX to all who helped. It seems to work fine now. (Pretty slick!)

73 Dave


On 5/14/2019 9:49 AM, FlexRadio wrote:

... the cables plugged into the back of the radio (not the computer... just to be sure).

Photo of Michael Walker

Michael Walker, Official Rep

  • 824 Posts
  • 232 Reply Likes
I'm not just another pretty face!!! 

I'm glad we got that sorted out.  :)
Photo of Dave - W6OVP

Dave - W6OVP

  • 306 Posts
  • 96 Reply Likes
Have had three 6000s in past years and NEVER plugged anything into those USB ports. Forgot they even existed.
Photo of Lawrence Gray

Lawrence Gray

  • 159 Posts
  • 80 Reply Likes
Are you using the XCVR connector on the KPA500?  Did you "train" the KAT500 as described in the KAT500 manual, so that it has stored values for regular intervals on each band?

I run the KAT500 in MAN (Manual) as recommended.  As I tune the 6500, the tuner follows and can be heard changing the tuning, without transmitting.   The KPA500 changes bands when I change bands on the 6500.  I am using the Elecraft supplied cables and the null modem adapter for the KPA500

Here is a screenshot of the Flex USB cable settings for the KAT500.  The KPA is essentially the same.




Photo of Pat - WH6HI

Pat - WH6HI

  • 359 Posts
  • 69 Reply Likes
Nice thing about the KAT500 is that the tuner follows the frequency of the radio. If the tuner senses that the swr is to high it will tune and it will remember that turning. Training is fine for initial use, but the tuner will always follow and tune as necessary. Make sure you have set up the keying cables from radio to tuner then to amp. This will protect the tuner from trying to tune at full power, which would be harmful to the tuner. A very handy thing to do is to select the USB set up which you did previously and highlight KTA500 and select logging and you will see the actual cat commands going between the radio and the tuner. As you tune the radio you will see the frequency being passed to the tuner. If at this point the tuner is trained, you will hear the tuner change tuning while your running which is very fast in a tuned tuner working off its memory with frequency changes.
(Edited)
Photo of Dave - W6OVP

Dave - W6OVP

  • 306 Posts
  • 96 Reply Likes
TNX Pat.
Photo of Dave - W6OVP

Dave - W6OVP

  • 306 Posts
  • 96 Reply Likes
NOTE TO FLEX: The 2 USB jacks and Ethernet jack on the back of the 6400 are spaced unnecesarily close. One of the Elecraft FDTI connectors is thick, making the fit too tight and an add-on USB hub necessary to reduce stress.

There is no shortage of real estate on the back of the 6400 so why not use a connector package with more spacing on future products?  -Dave.
Photo of David Warnberg

David Warnberg

  • 671 Posts
  • 82 Reply Likes
powered USB hub works great.. FYI... specially when you have more then 2 USB devices to plug in... just a thought.
Photo of Dave - W6OVP

Dave - W6OVP

  • 306 Posts
  • 96 Reply Likes
I’m using an old unpowered 2.0 hub right now and it works fine for this app.