no TX from WSJT-X FT8

  • 3
  • Problem
  • Updated 3 months ago
  • In Progress
I have been using WSJT-X v 2.1.2 with modes FT8 & FT4 successfully on my Flex 6400 SSDR v3.1.8 for some time.  I normally start WSJT-X when I start my radio and just leave it run monitoring the band. It works fine for a while, but if I leave SSDR & WSJT-X just sit there running for a couple of hours, when I come back to it and try to transmit (eg: call CQ). WSJt-X keys the radio but there is noting transmitted (no RF output).  If I close and restart WSJT-X it works fin again ... for a while.

I have WSJT-X radio rig set to FlexRadio 6xxxx and the rest of the settings work fine.  Test CAT works fine and PTT is set to CAT.

Has anyone encountered this problem?  Is there a fix?

Michael -- KM6LHD
Photo of Michael Wheatley

Michael Wheatley

  • 27 Posts
  • 20 Reply Likes

Posted 4 months ago

  • 3
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2332 Posts
  • 971 Reply Likes
Official Response
This is a long-standing bug in WSJT-X
Photo of Michael Wheatley

Michael Wheatley

  • 27 Posts
  • 20 Reply Likes
Official Response
There are two different problems being discussed in this topic:

1.  No TX from WSJT-X:  No audio is being produced by WSJT-X when it keys the radio (eg: call CQ).
2.  WSJT-X stops decoding:  No audio is being received by WSJT-X.

The problem I am having, and the reason I started this topic is #1 above.  This problem occurs after the computer monitor is turned off by the screen sleep function in Windows (Windows Settings-System-Power-&Sleep-Screen: When plugged in turn off after X minutes). 

This problem can be reproduced reliably on my PC by:

1. Start SSDR and WSJT-X.  Call CQ to verify that audio is being sent to and received by SSDR.  If it is, the DAX window will show TX steaming .  
2. Set the screen sleep timer in Windows settings to 1 minute.
3. Wait for the monitor to turn off.  Wait a few more seconds and then wiggle the mouse to turn the monitor back on.
4.  Call CQ again.  When WSJT-X keys the radio the DAX window will show nothing being streamed .

WSJT-X can be restored to its correct state by closing the program and restarting it.  No other remediation restores WSJT-X to its correct state.

Other fixes has been suggested here:

-- erase wsjt-x.ini in %appdata%/local/WSJT-x and recreate it by reconfiguring WSJT-X
-- change the DAX channel, perhaps to an odd number
-- toggle DAX RX or DAX TX off and on
-- restart DAX

None of this work for me.  The only remediation is to restart WSJT-X and then it works correctly until the monitor turns off again as a result of the Windows sleep timer.  Note that powering off and on the monitor using its power button does not cause the problem or remediate it.

I believe the problem is in WSJT-X because the problem does not occur with FLDigi or HRD Digital  Master 780 in which I have CAT and DAX configured identically to WSJT-X.  Some users in the WSJT-X forum on Groups.IO report that this is a known problem in WSJT-X that its developers have not been able to find.  Now that I have a reliable way to reproduce the problem, I will continue to discuss it on the WSJT-X forum.

In the meanwhile, the only way I can find to avoid this problem is to set the screen sleep timer in Windows settings to "never" and power on an off my monitors manually.


Michael -- KM6LHD