No Panadapter Signals. But WSJT-X and MixW2 see DAX info just fine.

  • 1
  • Problem
  • Updated 2 weeks ago
Suddenly, today, I have no signals on my Panadapter.  Well, that's mostly true and is the main problem.  I miss my panadapter functionality.

I am reasonably sure it is in the SmartSDR only, or possibly the firmware, not in the hardware.  Why do I think this?

1.  WSJT-X works normally.  I see its version of a panadapter just fine.
2.  MixW2 works normally.  I see its version of a panadater just fine.
3.  The various information displays on the DAX panel looks normal.
4.  Audio sounds normal, including monitoring of transmitted signals.
5.  I can work stations in FT8 at minimum.
6.  The "flag" portions of the display work normally.  I can change frequencies, move TX between my slices, adjust filters, etc.  The filter size is correct also on the display.  The mouse wheel works normally.
7.  Clicking on the panadapter display is weird and inconsistent.  Sometimes, it moves the slice frequency normally.  Sometimes, it has no effect at all.  Once, it only moved the frequency if I clicked on the portion that was "showing" the filter.
8.  The panadapter _briefly_ functioned normally when I upgraded for 2.1.33 (I do not upgrade very much) to 2.3.9.  It did this the first time I invoked the new version only.
9.  Unfortunately, all the "obvious" resets (starting restarting Windows, DAX, CAT and SmartSDR proper) have no effect.
10.  The "move the slice from outside the adapter to "here" in the adapter does work.
11.  The waterfall part of the display is entirely black, without exception.
12.  When the transmit is running (and it appears to be transmitting normally) its wave form doesn't appear on the panadapter either.
13.  Rig seems to behave the same whether I am sitting next to it or operating it remotely from 20 miles away.  All of the above was observed at the remote site, not just at home.
14.  Conditions do not seem great today, less DX on the bands I checked, but on 20m, I was hearing Hungary and Lebanon on FT8 when I should have been.  So, that seems normal.

Configuration information of importance:

SmartSDR is now 2.3.9
"Display" settings  AVG 51    FPS  8    Fill 0 (White)   Weighted Avg:  Off
      GAIN 30   Black 1 (AUTO)    RATE 80

I have used these kind of display settings for years (I run a lot of old-fashioned remote).  Changing them randomly had no effect.

S/N  0418-7824-6400-0421
HW Version:  2.3.9.112
Options:  None
Model:  6400

I also have an Expert 2K amp running and yes, the USB interface between them is enabled (and, as far as I can tell, working brilliantly).  The Expert rig shows the expected SWR and wattage values on transmit when I should be (and am) transmitting.

I also have RemoteRig hooked up, though I doubt if the 6400 can actually detect this.  The microphone runs without bias.  The CW key is set non-iambic because of this.
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 198 Posts
  • 23 Reply Likes

Posted 2 weeks ago

  • 1
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2961 Posts
  • 642 Reply Likes
You have not mentioned what you have done so far to fix this. Maybe do a cold restart, shut down the radio and unplug the power cord for 10 seconds,,re connect and start up.
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 198 Posts
  • 23 Reply Likes
I did mention.  I did all of that.  Turned things off component-wise to an entire reboot.  Even upgraded Smart SDR from an earlier version which (briefly) corrected it.
Photo of K1UO - Larry

K1UO - Larry

  • 803 Posts
  • 128 Reply Likes
Router or Computer at the Remote need rebooting?     My remote Router caused something similar before on my 6600.    JTOL...
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 198 Posts
  • 23 Reply Likes
The one thing I did not try was resetting the router.  I'd have to drive out to try that now.  Maybe I will later on if nothing else turns up.

The dilemma with that suggestion is that it doesn't really explain how the panadapter is "blank" but things like MixW2 and WSJT-X are still seeing what has to be the same data.

Why are _they_ working and the panadapter not if it is a networking issue?
(Edited)
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 198 Posts
  • 23 Reply Likes
OK, weirder and weirder.  I _was_ able to remotely reboot the router (everything reestablishes itself so I can do it without the drive).

At the moment, the panadapter is back.  But, it was back once before.  We will see if this is a more "permanent" cure.

I still don't get why any sort of networking problem was specific to SmartSDR and not the other software.  But, again, I will wait a while before declaring "victory" on this.

Anyway, thanks for the suggestions.  At least it didn't take an ice cold boot of the router to get this far.
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 198 Posts
  • 23 Reply Likes
OK, I came back later, fired up the rig and _again_ there is no panadapter.  So, rebooting the router worked precisely once.

There is something going on here that will not admit to trivial explanations.  Rebooting for every power on cycle for the 6400, even if that works, is not exactly a real answer for this.

There is also new behavior just now.  If I take down SmartSDR, it now takes down DAX.  I don't believe it behaved that way before.  Don't know if that matters.  When I bringt SmartSDR back up, it brings up DAX with it anyway.

The reboot is suggestive of what I saw when I first invoked 2.3.9 -- it works occasionally, maybe only in some sort of initial conditions scenario.

Restoring whatever those "conditions" are is really a pretty crude workaround even if I can figure out what it is.
Photo of John - AI4FR

John - AI4FR

  • 64 Posts
  • 20 Reply Likes
Larry I don't know if this will help much, but I like to have back-ups. What I mean by that is if it was me, I'd try running SSDR on another device and see what happens.
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 198 Posts
  • 23 Reply Likes
Well, when I powered up this morning, the panadapter is there.

So, maybe there is a "cold start" component to it.  Maybe I have to have the rig off for a while.  Or, maybe it is just some sort of timing problem where I see it sometimes and not others.  The computer was left on overnight.  So, if there is a "cold start" it comes from the rig side.

We will see if it fails again later today.

I could try SSDR from another machine.  I have one, it just isn't currently deployed.  I have all my COM type devices on the current machine, but it is no big deal to run both computers, so maybe I could try that.
Photo of Dudley - WA5QPZ

Dudley - WA5QPZ, Elmer

  • 69 Posts
  • 9 Reply Likes
How do you have your radio connected to your network?   Also could the router need to updated?  If it is older than 3 or 4 years old,  you may need to replace it so that it can handle all the traffic from the radio as the panadapter/waterfall are very network dependent .. 
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 198 Posts
  • 23 Reply Likes
OK, it has not failed for several days now.  I  am not sure what the deal is, here.  I hate it when problems show up and then just disappear, but I am also practical enough to say "thank you" and move on.

Dudley, nice suggestion on the router.  It could be reflashed (for other reasons, I have a custom Open WRT load already flashed there), but I have no plans on doing so soon.  I see little to no evidence that the router is the problem in the sense of being overloaded.  The remote site is all wired for Gigabit ethernet and I do not have any "local" traffic like TV streaming, etc.  The vast majority of the traffic is SDR and VNC sessions.

For instance, I run VPN full time.  If the router was having problems, I would be seeing degradation.  But, I have compared VPN to nonVPN traffic and the difference appears to be about a millisecond.  I am accordingly much more worried about general network latency (though that issue is strictly external to the site and would not be part of this.  I run remotely, but in the version 1 sense.  SmartSDR always runs on the local network).