NO DAX Audio TX

  • 1
  • Question
  • Updated 3 years ago
Installed 6.1.7 and all works as it should except for one small issue. I am running Winwarbler. As expected I had to change the settings on the "Soundcard" config window to the new DAX settings. No problem with the RX. On the TTX setting the dropdown box shows the various RX and IQ options, but only ""DAX Reserved TX Audio". There is no "DAX Audio TX" to select. I rebooted the program, but still no luck. Any ideas?

73

Tim VE6SH
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes

Posted 4 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3548 Reply Likes
One of two things has probably happened.  

1,) The DAX TX driver was not installed. - look in the Windows Device Manager under Sound, VIdeo and Game Controllers and look for the entry FlexRadio Systems DAX TX to verify it was installed.  And that the entry does not have a small little yellow triangle with a (!) mark indicating a driver install issue.

If #1 is verified, the the software package you are using is not completely enumerating (showing) all of the sound devices installed on your computer.  If the software will not show it, you will not be able to select it.  Make sure you are using teh latest version of third-party software too.
(Edited)
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
Thanks Tim. Yes, I checked and the driver for DAX TX is installed and shows no error. I will check on the DXSuite site as I have latest edition of WW.

73

Tim VE6SH
Photo of Albert PA0A

Albert PA0A

  • 15 Posts
  • 3 Reply Likes
Tim

No problem here, in DX Lab 2.0.0 WW shows under Soundcard: DAX Audio TX (FlexRadio Systems) 

73, Albert PA0A 
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3544 Reply Likes
That is good to know.
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
OK thanks Albert. I will investigate further. Odd as the RTTY/PSK transmit pull down only shows DAX Reserved RX 1-8 and DAX !Q 1-8 and the one instance of DAX Reserved TX (plus my on board soundcard).
Photo of Al K0VM

Al K0VM, Elmer

  • 610 Posts
  • 102 Reply Likes
Tim,
   The RTTY/PSK pull down list should show Reserved RX 1-8, Reserved I/Q 1-4 and the DAX Audio TX ( but not the Dax Reserved TX audio.  That implies to me that DAX did not get totally installed correctly or Windows is not enumberating DAX correctly.    Do you see the DAX Audio TX in the reception pull down ? ( you should see the Reserved Audio TX there.)

AL, K0VM
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
Al, no. Just Reserved TX. DAX Audio TX does show up as correctly installed in Device Manager.
Photo of Al K0VM

Al K0VM, Elmer

  • 610 Posts
  • 102 Reply Likes
Tim,
   I have WW 8.5.8 and that appears to work correctly... My WW will display at least 17 items in the nicely sorted list with DAX Audio TX at the top. So if you have less than that the number of items is not the problem.  I assume you have tried rebooting the PC since installing DAX ?   I'm outta ideas.. Anyone else ?

AL, K0VM
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
The weird thing is in the reception drop down box in the Soundcard window I do DAX Audio TX but not in the transmission drop down!
Photo of Al K0VM

Al K0VM, Elmer

  • 610 Posts
  • 102 Reply Likes
Tim,
    Open 'Manager audio devices' from the WIndows control panel.  You should find DAX Audio TX as a Playback device. 


 If that is correct then the problem may be with WW..
  If you have Fldigi, does DAX Audio show up correctly there ?

AL, K0VM
(Edited)
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
Yes it shows in th audio device manager and in the reception pull down menus and the e Soundcard window in WW. It just does not show in the transmit pull down window. I am using the latest version of WW.
Photo of Al K0VM

Al K0VM, Elmer

  • 610 Posts
  • 102 Reply Likes
Tim,
   Is it in the correct in Playback of 'Manage Audio devices' ?  Like the graphic ?    If the answer to that is yes, then Its a WW problem especially if it also correct in FLdigi or WSJT.  If not, then it is likely that DAX will need to be uninstalled and reinstalled. Or you may wish to open a Flex help desk ticket.
AL, K0VM
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
Hi Al

Yes, just like the image. I will try reloading DAX.

73

Tim
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
Well I reloaded DAX, but the same issue persists. No "DAX Audio TX" in the dropdown box in the WW Soundcards tab (snd the same issue-it shows under the reception pull down, but no the transmission pull down!). I wioll take this to the DXLab reflector and see if anyone has any ideas.

NB: DAX Audio TX shows as correctly installed on the listing of audio devices.

73

Tim VE6SH
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3548 Reply Likes
Try a different digital mode app to see if it enumerates properly there.
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
I have not had a chance to try this again until today. Still the same issue. Whether in WinWarbler, MMTTY or Fldigi "DAX Audio TX" only shows up in the "receive" menu as one of the options to select in the soundcard configuration. It does not appear in the soundcard "transmit" options (only DAX Reserved Audio TX).

I have tried installing DAX several times with the same result.

The issue seems to be DAX TX Audio appears only as an option to select in the receive soundcard  profile and not in the transmit profiles. Any ideas?

73

Tim VE6SH
Photo of EA4GLI - 8P9EH - Salvador

EA4GLI - 8P9EH - Salvador

  • 1782 Posts
  • 547 Reply Likes
FLDigi has no issue:

Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
Thank you Salvador. When I set up Fldigi "Dax Audio TX" only appears as an option in Captuere not playback. (although "DAX Reserved Audio TX" does.
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
I have exhausted ideas on this issue and will open a help desk ticket.

73

Tim VE6SH
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
Thanks to Dudley (and his response on a Sunday afternoon) this has been resolved. Dudely thought I might have some ghosted audio input/output devices so I followed the procedure to clear ghosted com ports. Turned out I had no ghosted audio devices, but I did have a number of ghosted sound video and game controllers. Deleting those ghosted devices and two reboots later fixed the problem. DAX TX Audio appeared as a selection in the transmit pull down window in WW.

73

Tim VE6SH
Photo of EA4GLI - 8P9EH - Salvador

EA4GLI - 8P9EH - Salvador

  • 1782 Posts
  • 547 Reply Likes
Awesome! On a Sunday!
Thanks for posting the solution that might help others.
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
Well after the last Win 10 upgrade this problem cropped up again (no DAX Audio TX in the soundcard transmit pulldown menu in WW). No problem. I just do what I did last time and look for hidden audio and sound devices. I had some and deleted them. Rebooted, but same issue. No DAX TX Audio in the pulldown window. I checked audio devices and DAX Audio TX appears with no issues. Working fine before the upgrade. DAX showing as working. Any thoughts?

Tim VE6SH 
Photo of Al K0VM

Al K0VM, Elmer

  • 610 Posts
  • 102 Reply Likes
As a quik try.. Uninstall SSDR  including the option to uninstall the DAX drivers.. reboot and the reinstall..

AL, K0VM
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9186 Posts
  • 3548 Reply Likes
If that doesn't work, open a HelpDesk ticket.
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
Thanks Tim and Al. I did open a ticket and Dudley gave me a few other things to check. If not, I will do a reinstall.
Photo of Tim VE6SH

Tim VE6SH

  • 286 Posts
  • 38 Reply Likes
Thanks to Dudley for the tip. After the upgrade Win 10 had changed the default to DAX Reserved Audio TX. Changing the default to DAX Audio TX fixed it and it showed up in WW as an option. Thanks to all for the advice. I gather only Win 10 Pro allows one to disable automatic updates.

Tim VE6SH