New Xfinity modem not working with SmartLink - Help!

  • 1
  • Question
  • Updated 4 months ago
Yesterday I tried to set up the new Xfinity wifi modem/router - Arris TG 1682G .   I can no longer get into my 6700 using SmartLink with my SmartSDR iOS software via the WAN.   SmartSDR iOS is still working fine within the LAN however   I tried to setup the port forwarding as suggested on the SmartLink Setup screen but no joy!    All had been fine with the previous Xfinity Modem an Arris TG 862G, which others on the forum used successfully.   Tried setting up the port forwarding through the modem portal on my computer but no luck.   Tried going through Xfinity web portal to externally set up the port forwarding but still getting the red light on SmartLink.    One option is to send the new modem back to Xfinity and stick with the old one but I am hoping that wouldn't be necessary.  Has anyone been successful with the TG 1682G?   Any advice appreciated.  Thanks
Jim NX3Z
Photo of James Eastham

James Eastham

  • 7 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Chris Tate  - N6WM

Chris Tate - N6WM, Elmer

  • 760 Posts
  • 197 Reply Likes
Photo of Charlie

Charlie

  • 23 Posts
  • 19 Reply Likes
When i changed routers and had issues, I got the following from Flex Tech Support. It worked for me.

As in the setup one rule for the UDP port 4993, Starting port 4993, ending 4993, being sent to 192.168.1.136 Protocol - UDP
Second rule for the TCP port 4994 , Starting port 4994, ending port 4994, being sent to 192.168.1.136, Protocol - TCP

Then you should have a Static IP for your radio MAC address , 192.168.1.136 If you set this in the router, when ever the radio comes up , it will be assigned this address, you should not have to actually put that address in the static address of the radio..

Once you enter this, power the radio down , remove the DC , reboot the router, and power up the radio once the router has completely booted up ..

Then open SmartSDR -> SmartLink setup -> Link Test at the bottom .. be sure to click "Save"

The IP address is the one my router assigned to the radio. Yours will be different.

KJ4AUQ
Photo of James Eastham Jr

James Eastham Jr

  • 3 Posts
  • 0 Reply Likes
Thanks for the suggestions.  I have tried everything suggested with no success.  uPnP, static ip for radio, TCP and UDP ports forwarded.   I have a help ticket into Flex so we'll see what they suggest.
NX3Z
Photo of James Eastham

James Eastham

  • 7 Posts
  • 0 Reply Likes
Well I’m still stumped, I’ve tried every possible combination including Flex tech support suggestions. UPnP or, manual port forwarding, made sure port forward was turned off when trying UPnP, forwarded 21040 and 22000 then tried 4993 and 4994 , no joy ....Ive seen postings with all these setup suggestions. Only one modem so no double NATs Always get a red test button result. Is it possible that this new Arris TG 1682 G just won’t work? Has anyone used this specific modem with success? As I said my previous modem from COMCAST Arris TG 862 G worked but it was much slower than this new one. The ONLY change I made is the modem. All port forward are the same, my Smart Ether VPN setup with SmartEther manual port forward works fine on this new modem. Smartlink works fine through the VPN. The only thing that won’t work is the Smartlink through the WAN . I guess if it ain’t broke don’t fix it is the answer here!
Photo of Mark - WS7M

Mark - WS7M

  • 954 Posts
  • 334 Reply Likes
I have the Arris TG862G which seems to be a different model.  I have mine in "bridge mode" which turns it mainly into a modem and use my IQ router to do all the important work.

No issues here.
Photo of James Eastham

James Eastham

  • 7 Posts
  • 0 Reply Likes
My TG862G worked fine with Smartlink and WAN access.
Photo of Bob - W7KWS -

Bob - W7KWS -

  • 255 Posts
  • 35 Reply Likes
James,

Could this be the issue?

https://community.flexradio.com/flexr...
Photo of Scott Russell - N1SER

Scott Russell - N1SER

  • 27 Posts
  • 4 Reply Likes
Get rid of the Xfinity modem/router and get your own equipment. Less trouble, more flexibility and won't cost you $ every month. For your average home user their stuff is fine but when you do more than just surf the web it's better to be in control of your own network.