New Installation problem

  • 1
  • Problem
  • Updated 4 months ago
  • Solved

Got my new 6600 yesterday! Had it all hooked up within about 30 minutes of getting home last night. But I am one of the unfortunate ones whose installation of the software did not go smoothly. I think it might be my problem however. I was running my F5K in W10 Pro up until just before the RTTY roundup this January. I was having some issues with the computer (old i7 w/12G w/W10) so I put in a new WD drive and a fresh copy of W7 Pro 64. But the W7 is an old copy I had laying around that I never used - like from ten years ago.

The install last night showed an error that said Windows required signed drivers but allowed the install to continue. After it completed the radio worked fine except the DAX did not. I got an error that was titled "DAX Driver Error".

I found this thread on the web site this morning:

https://community.flexradio.com/flexradio/topics/problems-with-dax-drivers-unsigned-certificates

Looks like this is probably the cause of my dilemma. New gadget - old OS.

Question: If I buy a copy of W7 Pro 64 SP1 for Amazon and install it on my computer will it solve my problem? From reading the information in the link it looks like even SP1 requires a ton of updates. Wonder how long that takes?

Photo of Mark K5XH

Mark K5XH

  • 28 Posts
  • 5 Reply Likes

Posted 7 months ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9149 Posts
  • 3467 Reply Likes
Official Response
You need to have the most up to date root certificates installed

This issue is covered in the HelpDesk
https://helpdesk.flexradio.com/hc/en-us/articles/115001862026-Resolving-Unsigned-Driver-Errors-when-...