New Fldigi RigCAT files for SO2R capability

  • 10
  • Article
  • Updated 3 years ago
  • (Edited)
If you read through the SmartSDR v1.4.0 Release Notes, you may have noticed several bug fixes for SmartSDR CAT.  These were facilitated due to the testing being done to provide additional functionality with Fldigi.

SmartSDR CAT can address and control Slice A and Slice B independently.  This allows for the possibility that you could setup an SO2R type configuration using slice A and Slice B or just operate two different digital modes on two different bands at the same time.  Fldigi has the requisite features in the RigCAT protocol to do just that.

This is just a high level description of what you will need to do to configure Fldigi for a dual digital mode operation.  As time permits, I'll write up more complete step-by step instructions in the future.

  • If you do not have it, download and install Fldigi 3.22.05.
  • You will need to use SmartSDR v1.4.0 since earlier version have defects in the slice B CAT code that may make operation unpredictable.
First off you will need two separate RigCAT files; one that controls Slice A and another that controls Slice B.  These are now available on the Fldigi XML archives page in the FlexRadio section.  The file names are SmartSDR_SliceA.xml and SmartSDR_SliceB.xml respectively.  Note SmartSDR_SliceA.xml replaces the obsolete SmartSDR.xml RigCAT file.

Second you will need to configure two instances of Fldigi that use separate config directories with the appropriate version of the RigCAT file in the ..\rigs follder.  Instruction on how to do this can be found in the Fldigi documentation under running multiple copies.

Now you need two dedicated SmartSDR CAT ports; one for each version of Fldigi.  Refer to the SmartSDR CAT manual on how to create a new dedicated CAT port.  It will create a new com port pair like com5 and 15 in addition to the com4 and com14 that is created by default.  It makes no difference which pair you use for which instance of Fldigi as long as you use the low numbered com port for the one you configure in Fldigi.  On my configuration, SliceA/Fldigi Instance A uses com4 and SliceB/Fldigi Instance B uses com5.

Now you have to configure DAX.  In the DAX Control Panel, click the TX button for both channel 1 and channel 2 so both instances of Fldigi can send data to the transmitter.

Start SmartSDR and create two panadapters with Slice A in one and Slice B in the other.  For Slice A, set the DAX channel to 1 and for Slice B, set the DAX channel to 2.  The slice modes should both be DIGU or DIGL.  Make sure the DAX button in the right hand side bar window is clicked too.

The last thing you do is set each instance of Fldigi up so that the "sound card configuration" associated with slice A is using DAX RX 1 and DAX TX1 and slice B is using DAX RX 2 and DAX TX 2 for the second instance of Fldigi. 

Make sure to save you Fldigi configurations.

Now start the slice A instance of Fldigi.  It should be reading the frequency of Slice A and showing the waterfall data for slice A as well.  I recommend getting this instance working completely before starting the second instance of Fldigi associated with Slice B.  One thing you will notice after getting the slice A instance of Fldigi working is that it will say Slice A in the Fldigi title bar so you know which instance of Fldigi is associated with Slice A.

After Fldigi instance 1 associated with Slice A is working, do the same for the second instance of Fldigi associated with Slice B.  Again, I would get the second instance of Fldigi associated with Slice B working independently of the Slice A Fldigi instance first.

To test it, transmit using the Slice A Fldigi instance.  Slice A will be the transmit slice and it should transmit.

Now using the Slice B Fldigi instance, enable transmit.  The transmit designator will automatically change to Slice B.

WARNING: since we do not have an ATU automatic mode, make sure that the antenna you are transmitting on is either resonant or tuned for the frequency you are transmitting on. 

Enjoy the new Fldigi digital mode functionality.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8691 Posts
  • 3263 Reply Likes

Posted 3 years ago

  • 10
Photo of OE3KRB

OE3KRB

  • 1 Post
  • 0 Reply Likes

Tim, works fine with me!

lg Reinhard

Photo of Jay / NO5J

Jay / NO5J

  • 1366 Posts
  • 196 Reply Likes
Wow, I'm sure some of you think I've been NutZ for a while, but this drove me NutZ, FLDigi Cat, refused to Purr. And I banged my head against the desk for several hours, until I tried a search in the Community and found my answers! Yes I saw the release notes mentioning changes in CAT, Just a little slow on the uptake I guess, Those notes apply to me. All's well that ends will I guess, Thanks Tim for the explanation, and Thanks FRS for making the explanation necessary!!!! I'd just as soon have multi-slice FLDigi.

73, Jay - NO5J

 
Photo of k3Tim

k3Tim

  • 803 Posts
  • 149 Reply Likes
Version 3.22.06 is available therefore assumption is to step-up to the latest, correct?
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8684 Posts
  • 3262 Reply Likes
Sure, why not.  The minimum version is 3.22.02
Photo of Jay / NO5J

Jay / NO5J

  • 1366 Posts
  • 196 Reply Likes
Yeah, thats what I did no noteable differences seen yet. Guess I'll go look at the release notes and see whats changed. Added 8-PSK modes and some bugfixes and a lot more.
Might as well stay up to date.
73, Jay - NO5J
(Edited)
Photo of k3Tim

k3Tim

  • 803 Posts
  • 149 Reply Likes
Thanks Jay!

k3Tim
Photo of Burt Fisher

Burt Fisher

  • 1000 Posts
  • 365 Reply Likes
I downloaded the slice files but it receives but won't transmit. CAT shows Com 4 and Fldigi shows Com 1 and 4, when I choose COM 4 and save when I look again it is back to COM 1 and 600 baud. I only care about one slice.
(Edited)
Photo of len

len

  • 19 Posts
  • 0 Reply Likes
You need to click the 'use RigCat control' box near the top of the settings menu. It is unchecked by default.
Photo of Ali - 9K2WA

Ali - 9K2WA

  • 110 Posts
  • 23 Reply Likes
i tried it 3 days ago and it is really fantastic.



I ran 2 instances of Fldigi one loaded with SliceA XML and the other with SliceB XML.
Photo of k3Tim

k3Tim

  • 803 Posts
  • 149 Reply Likes
Screen shot looks great Ali.. Congrats on bringing it up.  

I am studying how to bring up the two instances of FlDigi.  One is up but now for the 2nd one....

73's, 

_..--
 Tim
Photo of Sergey, R5AU

Sergey, R5AU

  • 795 Posts
  • 92 Reply Likes
Hi Tim, follow with http://www.w1hkj.com/FldigiHelp-3.21/html/operating_multiple_copies_page.html

you need to organize a different folders for different instance like:

c:\users\K3TIM\Fldigi VFO A
c:\users\K3TIM\Fldigi VFO B

it will be a target folders for you new instance of the Fldigi

Target directory in Properties of the appl. will looks like:

"c:\Program Files\Fldigi-3.xx.xx" --config-dir "c:\user\K3TIM\Fldigi VFO A"
and
"c:\Program Files\Fldigi-3.xx.xx" --config-dir "c:\user\K3TIM\Fldigi VFO B"
(Edited)
Photo of k3Tim

k3Tim

  • 803 Posts
  • 149 Reply Likes
Hi Sergey,

Sorry for the delayed response - I just saw this reply.  Great timing as I was struggling with making two versions work and the documentation wasn't helping.
Your guidance is very clear.

Thanks for your time and expertise!
Best Regards,

k3Tim

PS: Thanks also for the link to the Doc.  I couldn't find that for the life of me.
Was fiddling with RTTY settings  and just missed working R120RN
(Edited)
Photo of Ali - 9K2WA

Ali - 9K2WA

  • 110 Posts
  • 23 Reply Likes
I uninstalled the previous Fldigi version and made 2 installations into 2 different folders named the second Fldigi_B, and moved the SmartSDR SliceB.XML to that folder, each one was setup with a different pair of DAX channel as detailed above in Tim's write up.

WSJT-X devl. version 1.5 was still running when I did the both of the  Fldigi installations and it was still decoding, however the dreaded CAT massage pops up every time SliceA frequency was changed.  I did not try the older WSJT-X 1.3 with this environment.
Photo of Ali - 9K2WA

Ali - 9K2WA

  • 110 Posts
  • 23 Reply Likes
I trued to work with both Fldigi (3.22.05) on Slice B/DAX2 and WSJT-X (1.3) on Slice A/DAX1, but noticed a problem with Fldigi staying on Slice B frequency on the Flex-6300, if the frequency of slice B changed, Fldigi will display the correct frequency momentarily then reverts back to Slice A frequency, this will also occurs when the TX is changed between Slice A and Slice B, Fldigi still decoded from DAX2.
Now if I switched Slices, and Fldigi now on Slice A and still loaded with SmartSDR_B.XML file on Slice A all works fine.

When working with WSJT-X (1.5 Devl.) with Fldigi Slice B/DAX2, WSJT-X will pop up the Rig control error message when changing TX back and forth between Slice A & Slice B.

By the way, when working with 2 instances of Fldigi, this problem does not occur.

I think that this problem is caused by WSJT-x using OmniRig (TS-2000).

Photo of Guy G4DWV/4X1LT

Guy G4DWV/4X1LT

  • 1687 Posts
  • 387 Reply Likes
WSJT-X uses Hamlib.
Photo of Ali - 9K2WA

Ali - 9K2WA

  • 110 Posts
  • 23 Reply Likes
I selected OmniRig in the setup of WSJT-X 1.5 Devl.

I am not aware that WSJT-X 1.3 used Hamlib.

I hope one day we don't have to use either one.
Photo of Ali - 9K2WA

Ali - 9K2WA

  • 110 Posts
  • 23 Reply Likes
Problem was solved setting WSJT-X 1.5 Devl.on Slice A/DAX1 using Rig: OmniRig, PTT Method: CAT, Mode: None and Split Operation: None  in the Radio configuration menu.

Now both Fldigi loaded with SmartSDR_SliceB.xml/DAX2 and WSJT-X 1.5 are working together peacefully.
(Edited)