New CAT rejigging

  • 2
  • Question
  • Updated 3 years ago
I am slowly getting used to all the upgrades to SSDR etc and my other programs before getting on the air again.

I noticed a few changes in CAT and decided to delete my ports and re-create them. I noticed that the port allocated to CAT COM was only +10; so the pairs would be 4-14, 5-15 etc after the upgrade and I read that they should be 4-104, 5-105. That was what they were on re-creation. I do not know if the 4-14 format would have caused problems.

The other reason for re-creating them was that manually changing the CAT COM port changed the client COM port but did not change port labelled on the main CAT panel. I only have a few ports so just deleted all except a TCP port that I assume was created by the system - is that correct?

Other than the above, after which all seems to be working well, is that I have noticed that I do not have COM 5 available. Can somebody tell me why this is?

Mni tnx chaps.
Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 389 Reply Likes
  • heady with trepidation

Posted 3 years ago

  • 2
Photo of Larry - W8LLL

Larry - W8LLL

  • 466 Posts
  • 101 Reply Likes
Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 389 Reply Likes
Any ideas Tim?
(Edited)
Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 389 Reply Likes
Tim, any ideas as to why SmartCAT is grabbing port 5 and what it may be using it for? If it is not needed I would really like to be able to delete it or change the port number to get it out of sight and out of mind. It really bugs me even though there is no effect on function.

Sri fer the 'bump'. Thanks
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
It isn't just com5, it is the pair 5/15.  Ans it is probably there because of a left over registry entry from the old CAT ports
Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 389 Reply Likes
Hi Tim,

If that is all it is, I'll fire up regedit and deal with it. I am surprised that if it is left over from the old CAT ports, that it does not show up in SmartCAT for me to deal with. Surely SmartCAT should pick them all up? Isn't SmartCAT missing COM ports during the upgrade a bug or something?

UPDATE:- I deleted every* COM port registry setting I could after having deleted all the COM ports in SmartCAT and then closing it down. I could not delete any of the COM ports from HKEY_LOCAL_MACHINE\SYSTEM\ControlSet00?\Enum\FABULATECH. I am not sure of the number in place of the '?', but that is not important.

On rebooting, COM5 was still not available. Is there any way I can get it back? I do not mind delving further into the registry as I backup daily and before doing stuff like this. I have got to the point where I would like instructions just so I do not waste my time. I assume that I would have to unload/uninstall the Flex COM VSP driver to unlock the ControlSet entries?

I would be grateful if you could advise for my benefit and others how to deal with this issue.
(Edited)
Photo of DrTeeth

DrTeeth

  • 1687 Posts
  • 389 Reply Likes
Off to create a helpdesk ticket as advised elsewhere. Seems it is more than just a registry entry ;-).