New 6500: First Problem

  • 1
  • Problem
  • Updated 3 years ago
Just thought you'd like to know.  I was opening my new '6500 today, trying to savor the "out of box" experience.  All went well until I wanted to connect the DC power cord.  The red and black were reversed!  I.e. the PowerPoles would only plug in with the wrong polarity.  A simple repair got us going.  QA, guys! See photo. 

Otherwise, things are going well. Soon, we apply power.

73 de AA6E
Photo of Martin Ewing AA6E

Martin Ewing AA6E

  • 288 Posts
  • 57 Reply Likes

Posted 3 years ago

  • 1
Photo of Jim, KJ3P

Jim, KJ3P

  • 88 Posts
  • 12 Reply Likes
Hard to tell whether both "notches" are raised as they should be, but the photo looks OK to me.  is the problem more apparent looking into the open end? Or is this after the fix?
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9149 Posts
  • 3467 Reply Likes
Martin - sorry about the manufacturing snafu.  If you want a replacement power cable, let me know and I'll have one sent to you.
Photo of Joe, KQ1Q

Joe, KQ1Q

  • 79 Posts
  • 19 Reply Likes
Why doesn't FRS use permanently-bonded Powerpoles, vs the single units that must be assembled? It would be one less manufacturing step and reduce a source of error.
IOW instead of using this: http://www.powerwerx.com/anderson-powerpoles/powerpole-sets/45-amp-red-black-anderson-powerpole-sets.html

Why not use this:  http://www.powerwerx.com/anderson-powerpoles/powerpole-sets/45-amp-permanently-bonded-red-black-ande...
(Edited)
Photo of Martin Ewing AA6E

Martin Ewing AA6E

  • 288 Posts
  • 57 Reply Likes
Thanks Tim, but my repair is good enough! We'll see what other surprises come along...
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3467 Reply Likes
QSL.