Neither Automatic or Manual Port Forwarding Work

  • 2
  • Question
  • Updated 1 year ago
  • Answered
Given:
  • Win 10
  • Latest V2 Software
  • U-Verse Arris NVG589 modem 50/5 mbps configured for IP Passthrough
  • ASUS AC1900 Router
  • Registered 6300 radio


Just upgraded to V2 (2.0.17.96), registered the 6300 but cannot get the network test to work.  I've tried uPnP w/o port forwarding table entries, and manual port forwarding with uPnP turned off and ports forwarded using external TCP 4994 and UDP 4993.  No bueno.

SmartSDR dialog box shows the 6300 and below says "Configured for SmartLink".

My situation is a bit complicated because I have U-Verse (resold by DSL Extreme as TrueStream) with the Arris NVG589 modem set for IP Passthrough to an ASUS router.  Ports 4993/4994 are forwarded in the Arris modem to the Router.

The sad part is it worked for a few hours but no longer.  I must be missing something!  I double checked the radio's IP address.  I have rebooted everything, to no avail.

Any suggestions? TNX
73 Steve
Photo of Steve

Steve

  • 9 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 2
Photo of Jim Gilliam

Jim Gilliam

  • 867 Posts
  • 187 Reply Likes

Have you tried port forwarding in the Asus router? I am not familiar with port forwarding  in the modem. If the router is connected between your modem and the LAN equipment, it is the router that must be port forwarded. I have an Asus RT-AC88U and it is very easy to port forward under the WAN tab.

Jim, K6QE

(Edited)
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
Yes. Don't port forward in the modem, do it in the router, because that is what controls where everything goes. The NVG589 is only serving as a modem in pseudo bridged mode.

Btw, I assume you have the wifi on the NVG589 turned off and are using the wifi on the ASUS router? That is the way it should be anyway....
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
Btw, I am using an ATT UVerse NVG510 with an ASUS RT-AC66U router and have no problems, other than my marginal uplink speed (500-750K variable)
Photo of Danny K5CG

Danny K5CG

  • 307 Posts
  • 45 Reply Likes
Try manual port forwarding with the correct external ports mapped to their respective internal ports. It's not one to one, they are shifted. See Ria's post here.

https://community.flexradio.com/flexradio/topics/port-forwarding-service-name?topic-reply-list%5Bset...
Photo of Steve

Steve

  • 9 Posts
  • 0 Reply Likes
Jim: Yes I've tried automatic and manual forwarding in the router.  The 6300 is hardwired to the ASUS router.  I port forwarded in the modem because it has a firewall that I assume is still in use, and was following similar instructions that I had used to enable my Plex Media Server (which also stopped working so I really screwed something up)

What determines the external ports?  I used 1:1 per Tim E at https://community.flexradio.com/flexradio/topics/port-forwarding-service-name?topic-reply-list%5Bset...

I deleted the port forwarding in the modem and left the manual forwarding in the ASUS router but no go.  Gotta run but I'll experiment more this afternoon.  

Thanks all for the quick responses while I slept. :)
Photo of Danny K5CG

Danny K5CG

  • 307 Posts
  • 45 Reply Likes
You didn't read Ria's post did you. Look at the external port numbers and forward those to the internal port numbers.
Photo of Steve

Steve

  • 9 Posts
  • 0 Reply Likes
Yes I read that post! And I read Tim W4TME's post:

"The radio uses 4994/tcp and 4993/upd.  You can do a translational port forward, for example, define tcp port 21000 on the firewall to map to port 4994/tcp on the radio and define udp port 22000 on the firewall to map to port 4993/udp on the radio.

Or you can do a 1:1 translation where you define tcp port 4992 on the firewall to map to port 4992/tcp on the radio and define udp port 4993 on the firewall to map to port 4993/udp on the radio.

Do what ever your firewall allows."

I tried 21000:4994 and 22000:4993 but it didn't work.
Photo of Jay / NO5J

Jay / NO5J

  • 1577 Posts
  • 228 Reply Likes
Steve

I would have expected that the modem would/could be configured to operate in bridge mode. which would have made the modem transparent, and also would likely have eliminated any firewall or port forwarding abilities in the modem itself. Your router would/could then be used to do the firewalling and port forwarding.

I've heard in the past that "Double NAT" configurations/situations were to be avoided.

Is it possible to configure your modem to operate in bridge mode?

73 Jay / NO5J  
Photo of Mike - WB8CXO

Mike - WB8CXO

  • 60 Posts
  • 13 Reply Likes
I've been succesfully running a 1:1 translation since V2.0 was first released for alpha testing, SSDR win and SSDRiOS. Hoping it magically fixes itself as it magically broke.
Photo of Steve

Steve

  • 9 Posts
  • 0 Reply Likes
Jay this modem/gateway doesn't offer bridge mode.  Hence the use of the "IP Passthrough" mode suggested for other apps.  Don't ask me what the difference is... <G>
Photo of Steve

Steve

  • 9 Posts
  • 0 Reply Likes
I tried DMZ'ing the 6300 in the router but that didn't work either.  I get back to it again this afternoon PDT.
Photo of Steve

Steve

  • 9 Posts
  • 0 Reply Likes
PROGRESS!  I put the 1:1 port forwarding back into the AT&T modem and left the 6300 DMZ'd in the router and  IT WORKS!  Didn't have any receive audio on my iPad but that's a problem for another day.  Now I'll play with the router.  Now at least I know that the port forwarding through the modem firewall is necessary.
Photo of Steve

Steve

  • 9 Posts
  • 0 Reply Likes
HOW FRUSTRATING!  I took the 6300 off DMZ and put the 1:1 port forwarding back in on the router and now it's working!  (Fingers crossed.) All this multiple rebooting must have cleared it up, unless there was an AT&T problem but I doubt it. 

Even my Plex Media Server remote access is now working again and I didn't change ANYTHING related to it.

Mucho thanks for the help.  Hopefully this troubleshooting will help someone else down the line.

73 Steve W7SJK
(Edited)
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
Occasionally my NVG510 and ASUS router seem to loose sync.  It takes powering both of them off, then booting the NVG510 first until all the lights are normal, then booting the ASUS router to set things right.  perhaps that is what happened.  either by glitch, RFI, or just mystery problems at ATT...sometime you never know!

Glad you are back in business....