My Flex 5000A Software Stops by it self.

  • 1
  • Question
  • Updated 3 months ago
I have a Flex 5000A ruling the latest KE9NS Software and the software stops all by itself. I leave the radio running all the time sending spots when I'm not using it and it will stop all by it self, usually overnight or when I'm not here in the shack. Power to the radio stays on but the software stops. I just hit the stop Icon 2 times and the radio comes back.

Any ideas?????

Thanks much

Rick    KA1AQP
Photo of Rick

Rick

  • 8 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 2318 Posts
  • 529 Reply Likes
the software stops or is it the screen
If it is the software what does it do? sounds like a computer time out
(Edited)
Photo of Rick

Rick

  • 8 Posts
  • 0 Reply Likes
The software just stops. It acts like somebody had hit the stop button.  Everything looks normal it just stops. if you hit stop once then hit it again the radio come back on right where it stopped. I have installed this radio in 2 different locations using 2 different radios and its done it at both locations.

Rick
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 427 Posts
  • 128 Reply Likes
I have seen this on another system and I have worked to make sure its not DPCs. Windows 10, is that what you are running?
Photo of Alan W4FBI

Alan W4FBI

  • 214 Posts
  • 30 Reply Likes
DPCs ?
Photo of Rick

Rick

  • 8 Posts
  • 0 Reply Likes
Yes it is running Windows 10

Rick
Photo of Tommy Teague

Tommy Teague

  • 16 Posts
  • 3 Reply Likes
I'm not sure but here is something you can check?

What are your Power saver settings?



Also Windows updates close down program to do updates.

Photo of Rick

Rick

  • 8 Posts
  • 0 Reply Likes
All of these have already been disabled.

Rick
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9013 Posts
  • 3413 Reply Likes
Lower your sampling rate and see if the radio becomes more stable.
Photo of Rick

Rick

  • 8 Posts
  • 0 Reply Likes
I lowered the sample rate down to 48000 which gave me a very narrow Panadapter but I thought
that perhaps that did the trick but after 2 days of non stop usage it started doing it again.
Sometimes it will do it several times a day and sometimes it will go several days before it does it.

Any more ideas????

Rick    KA1AQP
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9013 Posts
  • 3413 Reply Likes
Try replacing the Firewire cable.

It is possible that a recent Windows update is adversely affecting the stability of the Firewire card.  If that is what is happening, then maybe a different firewire card might help.

The challenging dynamic here is that there are not any bus or device level diagnostics that can be run to identify exactly what is causing the connection to fail.
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 427 Posts
  • 128 Reply Likes
If this is the same as I have tried to debug on another system, I think WIn10 has provided some system update that is causing this. If you have a backup of the system from earlier than 4-6 months ago, it would be interesting to try it.

I have done all of the  usual things on this system to no success (while no DPCs are the cause). The system has a very complex configuration (7 monitors!) but it worked just fine until 3-4 months ago with no none user-initiated change. 

I have seen several of these comments, all using KE9NS. Falling back to 2.7.2 doesn't seem to fix anything however.
Photo of Rick

Rick

  • 8 Posts
  • 0 Reply Likes
This problem has happened on 2 different computers with 2 different Fire Wire Cards.
I am using the SAME Fire Wire Cable on both systems but 2 different computers. The other computer is also running Windows 10 and the KE9NS Software but it is in my Mobile Van that hasn't been used or taken any Updates from Windows or KE9NS since June.
Photo of Rick

Rick

  • 8 Posts
  • 0 Reply Likes
The last couple of days I have been running the Flexradio program which monitors the DPC's and it normally runs with DPC's of less than 500 us. Sometimes it will run fine for many hours at a time. I have found that when the radio does stop running the program will show several DPC's of between 10000 and 20000 us.

What is causing this????

Rick    KA1AQP
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9013 Posts
  • 3413 Reply Likes
There are actually two answers to this question based on how it was asked.

1.) First, remember that the FLEX-5000 with PowerSDR is a system that is processing isochronous, real-time data.  The radio stops because 20,000 uS is an eternity for this system design and during that time the Firewire interface has exhausted it's buffers of data and if the radio receives no data, then the software shuts down.

2.) The real issue here is why the 20,000 uS DPC delay.  A delay of 2000 uS is a long time, so a 20,000 uS delay is an order of magnitude greater.  There is a program that is using hardware on your system that is resulting in a blocking operation, where all new ISR and immediately turned into DPCs. You need to identify what hardware is the culprit in what hardware driver or subsystem is responsible for the delay and then try to mitigate it.  The more common ones are the network interface (especially if you are using a wireless network adapter) and the video card.  The only thing that will fix this is better hardware drivers for those devices that handle DPCs better and do not allow a single application to suspend other hardware form accessing the system.  This is usually done by updating the hardware drivers, motherboard chipset drivers and motherboard BIOS.

These HelpDesk articles should help.
https://helpdesk.flexradio.com/hc/en-us/articles/202118398-What-are-DPCs-and-why-do-they-matter-

https://helpdesk.flexradio.com/hc/en-us/articles/202118698-Using-LatencyMon-to-collect-DPC-Latency-D...
(Edited)
Photo of Wayne

Wayne

  • 483 Posts
  • 58 Reply Likes
Try it on a system that is NOT Windows 10 and I bet your problem will go away.
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 427 Posts
  • 128 Reply Likes
These spurious DPC hits can be caused by many different things, some of them not necessarily problems to be "fixed". For instance, if you do a system update, it will lock the system while updating files and you can see these big bumps. Generally when you see just 1 occurrence at a high value, I would relate it to system events rather than buggy drivers, etc.

I am installing a new Win 10 system with the exact configurations and settings that I normally use and am seeing freezes where I never did before. I really think we have some windows 10 update that has caused this.

I have tried some experimental settings to see if I can find a way around this and will let you all know if I learn something.

BTW, do not let the TI firewire chip-Intel BIOS issue cause you to run away from these cards. There was a chipset from Intel (I think it was the Z170 chipset) that was not compatible with the old TI PCI firewire cards. Upgrading to a PCIe TI-based card or using the 1394B chipset (where you have 1 firewire 800 port and 1 or 2 firewire 400 port) PCI card, everything is fine. I haven't seen any incompatibilities since the Z170 chipset was released however.
Photo of Rick

Rick

  • 8 Posts
  • 0 Reply Likes
Tim

Actually downloaded and installed that Latency Monitor Program a couple days ago and I have about 60 hours of data from it saved to a file. Where can I send the file where somebody can look at it and perhaps tell me whats going on.

Rick   KA1AQP
Photo of Richard Kenadek

Richard Kenadek

  • 1 Post
  • 0 Reply Likes
I have been running the FlexWire Device Drive Console Program for about a week or so now and have found that the Max DPC's in my Computer usually run <500. Once in a while I may get one that goes up to <1000 but the radio seems to take it OK.  Then for some reason I will get a few that shoot up <9000 or <10000 and then the software will stop. This usually happens when I'm not at the radio in the middle of the night or when I'm at work. I then have to hit the stop button a couple times to restart the software. All this time the power light on the radio stays lit but the software stops.
How can I find what program is running in the background that may be causing this ????

Rick  KA1AQP