My 6400 connection problems

  • 1
  • Problem
  • Updated 4 months ago
Well first of all let me say that I must be dumb as a stump!  I purchased a flex 6400 and hooked it up to my computer direct.  It was working fantastic.  Then I changed my anti virus software and added an Asus router.  Well after I had the router up and running and the anti virus installed my flex 6400 will no longer connect.  I have two flex 5000A radios and I know they use a different software but they work great.  I plug the flex 6400 into the lan connection and it won't recognize it.  I have switched cables and nothing.  I can hook the 6400 to the Maestro and it works great.  I also use W2IHY equipment and I can't get it to key my amp going through it either.  If I hook up the flex direct to the amp it works great.  As I said I am not the sharpest tack in the box.  I am at winding my butt and scratching my watch right now lol.  Any help would be appreciated!
Photo of Henry Gilmore Jr.

Henry Gilmore Jr.

  • 11 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Jim  KJ7S

Jim KJ7S

  • 193 Posts
  • 34 Reply Likes
If the anti virus gets it's way, you will have to make exceptions to let the SSDR/Flex stuff through, in addition to making sure you have UPNP enabled in the router, or open the necessary ports. In my experience so far, the Avast Antivirus is most often the culprit but when the exceptions are made that has fixed the problem(s).... Then there's the updates that Winblows likes to throw out that tend to hose up the drivers but that's a whole nuther conversation hihi.  GL n '73' fn.
Photo of Henry Gilmore Jr.

Henry Gilmore Jr.

  • 11 Posts
  • 0 Reply Likes
What is upnp? The flex is not going through the router. It's connected directly to the computer.
Photo of Michael N3LI

Michael N3LI

  • 240 Posts
  • 81 Reply Likes
The computer is blocking the radio. You'll need to make an exception to allow SSDR, DAX and CAT through.  The question is whether your new AV software blocked it, or something changed in your firewall. Check your Firewall rules. My money is on the new AV software. Go into your settings on that and see what is being blocked.
Photo of Henry Gilmore Jr.

Henry Gilmore Jr.

  • 11 Posts
  • 0 Reply Likes
I went into av and allowed software to go through. I am trying to check firewall and see if that caused it.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 4055 Posts
  • 979 Reply Likes
From reading your problem it sounded like you were using a router.
Start by turning off your anti virus first and try.
(Edited)
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 592 Posts
  • 208 Reply Likes
Once you verify that anti-virus is not blocking the software, check that you have your radio set for DHCP. If the direct connect worked, and now thru the router it does not, you may not be getting a compatible IP address for the radio. The router should be capable of handing out an IP address, and it can also be configured to always hand out the same one to the radio.

I know this is getting quite a bit beyond just “radio”, but the Flex is a network beast :-)
Photo of WX7Y

WX7Y

  • 852 Posts
  • 183 Reply Likes
what anti-virus programming are you running?  sounds like you have a 3rd party firewall or even windows firewall blocking you.
If you have another computer that you HAVE NOT loaded the Anti-virus on give that a try connected to the router. 

A lot of the Antivirus programs have internet security enabled by default and I have had to disable there firewall / internet security because there a real pain in the neck to allow exceptions through, good luck. 
Bret

Photo of Henry Gilmore Jr.

Henry Gilmore Jr.

  • 11 Posts
  • 0 Reply Likes
I have avg antivirus on both computers. I am not running anything through the router. I am trying to get the 6400 connected directly to the computer.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 4055 Posts
  • 979 Reply Likes
Tell us what you have tryed so far,
Photo of Henry Gilmore Jr.

Henry Gilmore Jr.

  • 11 Posts
  • 0 Reply Likes
Well i have gone into antivirus and set it to allow sdr program and i think i have firewall set to allow it. It works great off the Maestro so i have been using it that way. Although it would be better running sdr.
Photo of Henry Gilmore Jr.

Henry Gilmore Jr.

  • 11 Posts
  • 0 Reply Likes
What i am trying to get set up is to operate the 2 flex 5000a units or the 6400 off the same computer. Just be able to choose which one i want to use.
Photo of Michael N3LI

Michael N3LI

  • 240 Posts
  • 81 Reply Likes
Hi Henry, are you using an assigned IP address or a manually coded one?
Photo of Henry Gilmore Jr.

Henry Gilmore Jr.

  • 11 Posts
  • 0 Reply Likes
I was told the computer will recognize the flex if it's connected directly to the computer.
Photo of Henry Gilmore Jr.

Henry Gilmore Jr.

  • 11 Posts
  • 0 Reply Likes
The two 5000a units work great. How do i set up the flex 6400 for dhcp?
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 592 Posts
  • 208 Reply Likes
DHCP should be the default unless you change it. If it once worked direct-connected to your computer, I’d look for changes in your computer’s configuration (there are a number of network config issues, from firewalls, to permissions - but I’m a Mac guy so can’t provide specifics - although I’m sure others will step up).
Photo of Henry Gilmore Jr.

Henry Gilmore Jr.

  • 11 Posts
  • 0 Reply Likes
Thanks i appreciate you trying.
Photo of Michael N3LI

Michael N3LI

  • 240 Posts
  • 81 Reply Likes
Settings/Radio Setup/Network/advanced, and there will be the choice between DHCP and Static. If you need it, I can show pix.

Just on a whim, once you find out what your IP is, try pinging it. 

Mine is 192.168.0.8, DHCP, and if I ping it, it gives me 4 perfect pings to the radio.
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 592 Posts
  • 208 Reply Likes
The radio will have a “169.” address if it is direct connected. The computer’s interface should also have a “169.” address if both are set to DHCP as would be the norm.
Photo of Andy

Andy

  • 88 Posts
  • 3 Reply Likes
Tim, helped me with my issue and it was determined that it was my PAID AVG. I removed AVG and all is well.
Photo of Henry Gilmore Jr.

Henry Gilmore Jr.

  • 11 Posts
  • 0 Reply Likes
I kind of figure that is my problem too. Thanks and i know i just purchased avg for 3 years. I am considering replacing the computer since it is 10 years old.
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 4055 Posts
  • 979 Reply Likes
My first comment was for you to turn off AVG and try it...a day ago..  good things are working now...