MOX, FootSwtich, PTT ignored while CW, switching into QSK after first character send

  • 3
  • Question
  • Updated 2 years ago
  • Answered
Hi Team !

I need you advise before ticket open, so any switch to continuously TX  ignored by radio:

PTT via COM CAT
manual MOX
by FootSwitch


after 1st CW character radio will switched into QSK mode (or disable requested PTT) automatically with release PTT signal

Radio F6700
tested with SSDR ver 1.10 and 2.0
Logger N1MM +

Test conditions :  
SSDR :  CW Delay = 0 (or low values)
PTT port configured in N1MM

results are the same with WinKey emulation or with int. keyer

BR
Sergey
Photo of Sergey, R5AU

Sergey, R5AU

  • 862 Posts
  • 117 Reply Likes

Posted 3 years ago

  • 3
Photo of Douglas Maxwell

Douglas Maxwell

  • 153 Posts
  • 45 Reply Likes
Hi Sergey, I have the same problem. I have reported it twice here and each time been told that it is fixed. I want no break-in, just solid ptt when commanded by the app. This means that you should have nothing but side tone going on and off in the headphones during sending. I get rx hiss popping in and out when I use winkey emulator and N1MM+, Very annoying and a deal breaker during a 24hr CQ contest. However, I am not sure if the radio really unkeys as the hiss is as if no antenna is connected and my amp doesn't unkey?
Photo of Sergey, R5AU

Sergey, R5AU

  • 862 Posts
  • 117 Reply Likes
Hi Doug!

I am with you, as I said in the Head of the Post, independently of usage - FootSwitch, push MOX button or PTT via COM port, after first character send, radio automatically release PTT and auctioning further with QSK algorithm , BTW SSDR have button QSK in CWX window, but this function ignored.

So, reasonable question why do we need that:

well, even during contest some time are necessary to use several macros or use 
internal Keyer or even to use CWX live to talk. 

Today, with with mentioned above operator F6000 disoriented by switching to RX in pauses. However, I support the situation when both modes should be available as well - as now and as we want to see, the button of the QSK should perform its functions

Some rus contesters like RL5A(F6700), RV3FF(F6300) confirmed as well necessity of QSK manage. I don`t think that require extremely hard effort behind for implementation.


"However, I am not sure if the radio really unkeys as the hiss is as if no antenna is connected and my amp doesn't unkey?" Douglas, you can follow with MOX button/ TX indicator or ext. Amp RX/TX relay as well
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9289 Posts
  • 3605 Reply Likes
I have entered this problem report into our bug tracker as issue #5111 for additional investigation. Thank you for the defect report.
Photo of Norm - W7CK

Norm - W7CK

  • 763 Posts
  • 164 Reply Likes
Tim,  

When operating on 2m FM, I've noticed that if I key the system using the MOX botton, it keys but no audio goes out over the air.  Just a solid carrier.

I've checked and have made sure DAX was not being used.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9289 Posts
  • 3605 Reply Likes
I just did a test on 146.52 and it worked for me.  I suspect a configuration issue.
Photo of Sergey, R5AU

Sergey, R5AU

  • 862 Posts
  • 117 Reply Likes
Thank you  Tim !

I hope it will bring more pretty minutes with hobby ;-) 
Photo of Norm - W7CK

Norm - W7CK

  • 763 Posts
  • 164 Reply Likes
Tim.  

What sort of configuration issue could it be?   I have a PR-40 connected to the BAL input, I've selected a 2m FM slice as active and TX.  I press the PTT and it transmits audio.  If I press the MOX button on SmartSDR, the transmitter goes into transmit mode but no audio gets transmitted.

Once more, what sort of configuration issue could it be?  I can even bring up a repeater but they just hear a dead carrier, no audio.

Norm - W7CK
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9289 Posts
  • 3605 Reply Likes
Does the repeater use a PL tone to open it?
Photo of Norm - W7CK

Norm - W7CK

  • 763 Posts
  • 164 Reply Likes
Yes and I believe that works fine.  Just no voice audio while on the repeater or on a simplex frequency when using MOX.  The PTT works fine.

Flex staff is the greatest but Its late at night Tim.   Get a good rest.....

Norm - W7CK
Photo of Игорь Михеев

Игорь Михеев

  • 2 Posts
  • 0 Reply Likes
I confirm the existence of this problem.

Igor RL5A
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9289 Posts
  • 3605 Reply Likes
Thank you.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9289 Posts
  • 3605 Reply Likes
Official Response
RRR.  Sleep?  I have forgotten what that is.

I will test this tomorrow, but I went ahead and put this in as a defect, #5117 just in case I fall asleep ;-)
Photo of w7pp

w7pp

  • 6 Posts
  • 1 Reply Like
Has this been fixed? I use macros from software to send cw.... I get QSK type cw, which would be OK for an QSK amp....no joy here.  So has anyone got a N1MM+ setup to eliminate this problem, or it still a Flex problem. (Flex6500, V2.0.19, N1MM+) Tim, what did your test reveal, and what action was indicated???
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9289 Posts
  • 3605 Reply Likes
Issue #5111 is in an open state.  It has not been assigned yet. 
Photo of Dick Hale

Dick Hale

  • 6 Posts
  • 0 Reply Likes
So... I only use my amp on phone, or use a manual switch to key my amp on CW. This really seams like a rather poor "Customer Experience" and a lack of "Management" of the problem. Four months seems like a long time to test. Is the problem that it has two different numbers, 5111 and 5117, or is that a good thing? If so, please add a couple more to help it bubble up to "assignment"....! thanks.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9289 Posts
  • 3605 Reply Likes
5117 was a typo.  There is only one defect for this and it is 5111.
Photo of Douglas Maxwell

Douglas Maxwell

  • 153 Posts
  • 45 Reply Likes
I'm just getting ready for the RSGB DX contest tomorrow and couldn't believe my eyes and ears...The PTT in CW issue is now fixed! MOX now lights up blue when N1MM+ sends PTT! This was my top dislike of SSDR. Thanks to all the engineers in Flex who worked on this.
Photo of Sergey, R5AU

Sergey, R5AU

  • 862 Posts
  • 117 Reply Likes
Hi Douglas! 

thank you for you report however I can declare following:   
F6700, ver 2.0.19.98, Delay=0
1. by FootSwitch - all OK, not ignored any more
2. manually with MOX and PTT via COM - much better and I can see just additional Tail compensation are inserted but after a bit long break with manipulation Radio released PTT in any way, but again, right now much better !
3. QSK button  working properly right now!
4. With N1MM I can`t see any more ability to regulate Tail (WinKey menu) ?, probably N1MM issue - under investigation
Photo of Dick Hale

Dick Hale

  • 6 Posts
  • 0 Reply Likes
Doug, do you hear a relay clicking during your cw? I have an Non-QSY amp. The mox light stays on, but the keying line to the amp turns on and off between CW characters. I know the relay in the amp is rated for 400,000+ cycles, but at 28 WPM cw that 400k is being ate up when it shouldn't be. It would be great if the MOX light would indicate a closure of the PTT line out. I don't care that it's on during CW, but the relays still follow the on and off of the CW characters.... and pushing a switch to key the amp is a PITA ! Seems to me that software that turns on the MOX light should also hold in the TX relay....if the delay is above 1...
Photo of Douglas Maxwell

Douglas Maxwell

  • 153 Posts
  • 45 Reply Likes
V2.0 is working ok for me. Mox lights and no breakin audible using N1MM+ and ptt com port via cat. Using SSDR winkey emulator, the only problem is that it’s a bit slow to unkey when working through pileup in cqww cw as MM3T. Missing 2 out of 10 prefixes due to this problem. Light years better than it was though. Using kpa500 amp and no clicking or problems. Amp stays keyed during over at any speed. Doing 30wpm mostly.
(Edited)
Photo of Dick Hale

Dick Hale

  • 6 Posts
  • 0 Reply Likes
Thanks for the reply... When I setup N1mm+ and Winkey, as soon as I send a character, the 6500 and the amp, tx the character by closing the relay as each dot and dash are sent. so a contest contact could use over 100 relay cycles. The amp is hot switching the antenna relay... In other words, I CAN'T USE THIS RIG/AMP FOR CW! When I use the mouse to "push" the MOX button, it closes the relay until I click the MOX button again, just as it should... I would think Flex would want to fix this! How many CW fans would buy a rig that can't SIMPLY close a relay when asked by software? I don't think this is a N1MM+ problem because it (N1mm+)  works just fine with my Icom 756.  I guess I'm just upset that a $4000+ radio can't seem to work with an non-qsk amp...(P.S. my flex5K worked just fine!).  Must be time to buy a $5000 amp so I can work CW!!! (Down off my soapbox!)
Photo of Douglas Maxwell

Douglas Maxwell

  • 153 Posts
  • 45 Reply Likes
I don’t see this behaviour on my setup. Which SSDR version are you using? Have you set up a PTT port on CAT and connected it with N1MM+? On my setup, N1MM+ asserts MOX solidly for the entire over, then de-asserts at end of sending. I do not use QSK as I contest quite a bit. If you are on V2 of SSDR, this has nothing to do with your flex or amp and everything about your settings in ssdr and N1MM+..
Photo of Dick Hale

Dick Hale

  • 6 Posts
  • 0 Reply Likes
Doug: I use V2.0.19 of SSDR, N1mm+ V1.0.6903. I have N1MM+ set for Flex Radio on Comm 4 Cat without the CW/Other checked, it follows the radio freq and mode... etc, and Winkey with CW/Other checked on Comm5. On SDRCAT I have a box with "C" and one with "W" that both show N1MM+ as the process used. I have the delay set at 30 (have tried 0 to 2000) in SSDR and Iambic button. As far as the MOX button, yes it comes on and stays on, but the output of TX relay number one follows the CW characters dot and dash. Sending my call activates the TX relay 16 times as it sends my call (W7PP) I wish I knew why??? Any ideas?
Photo of Douglas Maxwell

Douglas Maxwell

  • 153 Posts
  • 45 Reply Likes
I have a “P” com port for PTT setup in Ssdr cat. Maybe you need to do this too?
Photo of Dick Hale

Dick Hale

  • 6 Posts
  • 0 Reply Likes
Do you have the "P" port in N1MM+ checked for CW\Other? Do you use the winkey port, and is it checked for CQ\Other....?
Photo of Douglas Maxwell

Douglas Maxwell

  • 153 Posts
  • 45 Reply Likes
I use port 14 for the winkey emulator and port 8 for the ptt. Port 8 has cw/other ticked in N1MM+ rts(pin7) set to ptt. Port 14 has cw/other ticked in N1MM + rts(pin 7) set to always off and Winkey box ticked
Photo of Douglas Maxwell

Douglas Maxwell

  • 153 Posts
  • 45 Reply Likes
In ssdr cat I have port 8 set as “P” with the RTS button selected (blue) polarity active low
Photo of Douglas Maxwell

Douglas Maxwell

  • 153 Posts
  • 45 Reply Likes
Just completed cqww with these settings. The kpa500 linear shows an asterisk in the lcd representing ptt which stays on solid (not qsk) and sidetone only heard in headphones. Works fb.
Photo of Dick Hale

Dick Hale

  • 6 Posts
  • 0 Reply Likes
Thanks, I'll give the "P" a try! 73 de Dick, W7PP