MMTTY won't transmit until I press the TUNE button

  • 2
  • Problem
  • Updated 3 years ago
When I start SmartSDR version 1.4.3 and MMTTY, MMTTY will not transmit until I press the TUNE button on and off. Then MMTTY works fine for the rest of the session. Is this a bug or do I have something configured wrong? Same problem on two different computers, Win7 and 8.1.
Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes

Posted 3 years ago

  • 2
Photo of Jason Whiteaker

Jason Whiteaker

  • 13 Posts
  • 1 Reply Like
Hi Bill,

I think it's a bug, and it's been there since before v1.3.8 code. I see it with WSJT-X, but the symptom is exactly the same: hit "Tune" or TX in the application, transmitter won't key through the app until you hit the "Tune" button once in SmartSDR. After that, application control of the transmitter is fine.

I'll be watching this one with you, sir! :-)

73,

-Jason, NK9B
Photo of Jim K4JAF

Jim K4JAF

  • 312 Posts
  • 74 Reply Likes

Works fine here but must be some sort of "bug" since more than one user have the problem.

73s Jim K4JAF

Photo of Duane, AC5AA

Duane, AC5AA

  • 386 Posts
  • 84 Reply Likes
Same problem here - with "fldigi" running any mode.  It only happens the first time I try to transmit in an digital operating session.  I have it set to use VOX, but *always* it will fail to transmit the first time in a digital mode operating session until I force transmit (either Tune button or hitting the PTT footswitch connected to the front panel mic plug).  This can happen after already working CW for several QSO's, so it's not necessarily the first time to transmit since starting a session on the radio.  After transmit has happened once in the digital mode, it will continue to work.  And, likewise, it has been happening at least since 1.3, meaning ever since I've had the radio (6500 bought last May.)

73, Duane  AC5AA
(Edited)
Photo of Bill W2PKY

Bill W2PKY

  • 448 Posts
  • 78 Reply Likes
I have this with JT-65 when changing slices. Have reported the issue. The problem is when changing slices the radio does not connect the newly selected slice to DAX until TUNE or ATU or maybe VOX is clicked. If watching the DAX control panel the digital data is exiting DAX but the radio does not receive the data stream. 
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9130 Posts
  • 3454 Reply Likes
I have never had that problem with any digital mode program using CAT (not the PTT port) to key the radio.  Please provide more detailed information about how your system is set up and how to reproduce the issue as only the symptom has been described.
Photo of Bill W2PKY

Bill W2PKY

  • 448 Posts
  • 78 Reply Likes
Hello Tim-

I do not use CAT since JT software is not aware of multiple VFOs. [always have multiple JT-65 sessions active on multiple slices using the -rig-program command line option VOX to trigger transmit]. 
Anytime I switch slices manually, either the TUNE or ATU must be clicked for the radio to synchronize with the new DAX channel. If either of those buttons are not clicked the radio will not transmit, however, can see digital output on the DAX control panel.

So say I'm on 15M [JT-65 DAX 1] making contacts and see some DX on 10M [JT-65 DAX 2]. If clicking the TX ICON on the 10M slice only and clicking TUNE on JT-65 software nothing happens. But DAX control panel shows data going out. If clicking TUNE on radio panel or ATU and then TUNE on JT-65 software the radio will transmit.

Hope this helps.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9130 Posts
  • 3453 Reply Likes
How do you "switch slices"?

Please define "not transmitting"

Is the radio actually keying up?
Is there audio shown on the panadapter when transmitting, but no RF output?
Do you see the TX meter moving in the DAX Control panel?
Photo of Bill W2PKY

Bill W2PKY

  • 448 Posts
  • 78 Reply Likes
Hi Tim-

NO, the radio is not keyed-up, stays in receive mode.
Yes, on the TX meter in DAX
(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9130 Posts
  • 3453 Reply Likes
I presume you are in DIGU mode?
Photo of Bill W2PKY

Bill W2PKY

  • 448 Posts
  • 78 Reply Likes
Yes
Photo of Dudley - WA5QPZ

Dudley - WA5QPZ

  • 212 Posts
  • 45 Reply Likes
MMTTY just needs a PTT Com port to send to,  you do have to create a PTT port in SmartCAT,  (rts to transmit)   assign that port in TX tab of MMTTY..   

SmartCAT for rig control/data

DAX for audio 



Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes

That fixed the problem, thank you!!  Although I do consider it a work-around, not a real fix since SmartSDR should respond to a VOX audio tone in the first place. Never the less, I am a happy camper.  :-)


73, Bill W6WRT


Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9130 Posts
  • 3453 Reply Likes
Bill - WSJT modes are timing specific, so anything you can do to reduce latency is a benefit. Keying by VOX is higher latency than using a CAT-PTT port.  Also, you do not have to worry about changing VOX threshold levels either.  it is a cleaner and all around better way to key the radio.