Missing DAX Drivers After upgrade

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Usual problems after upgrading to 1.9.7.  Went in through Control Panel and deleted all Flex devices and drivers.  Restarted machine and reinstalled package, got start up messaging saying error occurred while trying to open a DAX sound device.  Lists three conditions, the first one is probably the problem,  DAX driver not properly installed.  Looking in Control Panel there is no devices listed for DAX.  Reinstalled several times and no drivers installed.  Any idea where I can download these drivers?
Photo of Nick


  • 48 Posts
  • 2 Reply Likes

Posted 3 years ago

  • 1
Photo of Terry K8EET

Terry K8EET

  • 125 Posts
  • 15 Reply Likes
Official Response
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9268 Posts
  • 3595 Reply Likes
The reason you are having the "usual" problems is because of unnecessarily removing drivers that should not be removed.

Never manually uninstall the DAX drivers or the FlexVSP drivers unless you are explicitly instructed to do so.  There is only one way to uninstall the DAX drivers correctly and that is by using the SmartSDR uninstaller or manually (which is referenced in Terry's post above)

This step is totally unnecessary for most software upgrades and will result in issues like this.

I have uninstalled literally thousands of versions of SmartSDR and I NEVER uninstall the DAX driver or FlexVSP.  Never.  Ever.  I recommend everyone follow the same best practice for the most optimal new software installation experience.
Photo of Joe WD5Y

Joe WD5Y

  • 176 Posts
  • 24 Reply Likes
I totally agree on this as I removed everything as you did Nick and worked two days on problems. Dax and cat errors. The manual re-installs on both Dax and cat will resolve the errors if needed on one or both.


This conversation is no longer open for comments or replies.