Memory useage with 1.2.1

  • 1
  • Question
  • Updated 4 years ago
  • Answered
My memory used has doubled from 1.1.3! I suspect the panafall running continuously. Is there a way to disable the panafall to verify pc memory usage?
Photo of K4EAR

K4EAR

  • 138 Posts
  • 17 Reply Likes

Posted 4 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9052 Posts
  • 3435 Reply Likes
Yes, the panafall is the consumer of the additional memory.  Minimizing the waterfall will reduce the memory usage.
Photo of K4EAR

K4EAR

  • 138 Posts
  • 17 Reply Likes
I do not see a reduction with the panafall minimized :-(
Photo of Stan - VA7NF

Stan - VA7NF

  • 401 Posts
  • 86 Reply Likes
Reducing the rate is also effective.  On an old laptop I can run 6 concurrent band maps (all of 40/20/15/10/6/2M) through use of the 2 panafall rate sliders.
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1529 Posts
  • 542 Reply Likes
The FPS rate is particularly effective in reducing CPU usage.

Photo of W0QKL

W0QKL

  • 50 Posts
  • 7 Reply Likes
It would be nice if you could enable and disable the waterfall , for CPU and memory usage. I have noticed some major slowdowns in the panadapter due to memory and CPU high usage under this release.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9052 Posts
  • 3435 Reply Likes
With every release, we perform optimizations on the code for better performance and resource utilization.  We did a lot of optimization on the waterfall as part of its development and I am sure we will work on it some more for future releases.