Meinberg Time Error

  • 1
  • Question
  • Updated 4 months ago
New PC, clean install of Win 10 Pro (1709 / 1803) Meinberg installed, time checked using time.is web site. On my other PC (Intel i5 NUC) consistent "your time is exact" response. On the new PC (Dell Optiplex i7 32GB 250 GB SSD) I'm getting a consistent "your PC is 0.6 seconds slow. I don't think that 0.6 seconds will have any impact on FT8 or JT65, but why the error? Would switching to "D4" be a better choice?
Photo of WA2SQQ

WA2SQQ

  • 420 Posts
  • 87 Reply Likes

Posted 6 months ago

  • 1
Photo of Greg - N8GD

Greg - N8GD

  • 213 Posts
  • 79 Reply Likes
Stay with Meinberg.  It's much more acurate than Dimension4, which is not bad in its own right, but Meinberg updates continually (every 10 seconds, by default, whereas D4 is more like every 15 or 30 minutes.

If you don't have the Meinberg monitor installed, go here and install it to check on Meinberg's status:

https://www.meinbergglobal.com/english/sw/ntp-server-monitor.htm

Once you open the Monitor, click on the "NTP Status" tab (second from  the left) and look at the "Current local NTP status" line..There you will find the IP address of the NTP server used and the current offset in milliseconds.

A couple of things you might check: Open Windows Services and make sure the service named "Network Time Protocol Daemon" is enabled and running (this is the Meinberg service).  Second, make sure that the "Windows Time" service is stopped AND disabled.  The last item can interfere with Meinberg.  Normally Meinberg disables the Windows Time service, but in the process of updating to Version 1803, it may have been turned back on and is interfering with Meinberg.  Meinberg survived my 1803 update and Windows Time service is still disabled after tht as well.

Just a few things to check.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3471 Reply Likes
Darn, Greg beat me to it.  I agree with everything Greg said.
Photo of WA2SQQ

WA2SQQ

  • 420 Posts
  • 87 Reply Likes
I'll check these things thanks very much but what's interesting is that I had the exact same error using Windows 10 1709 before the upgrade the 1803. I even tried uninstalling and then reinstalling it. Wasn't aware of the monitor I'll try that
Photo of Greg - N8GD

Greg - N8GD

  • 213 Posts
  • 79 Reply Likes
Especially check the two services I mentioned.  Make sure that Windows Time service is disabled and Network Time Protocol Daemon is enabled and running.  I've seen many time settings programs fail to turn off Windows Time service and it overrides the one you've installed!
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2263 Posts
  • 890 Reply Likes
Meinberg doesn’t update periodically. Instead it skews the clock by speeding up or slowing down. It’s a smoother way to sync. Dimension 4 simply abruptly steps your clock. Frankly I think most who get it, get it for the cool name and not functionality.
Photo of Greg - N8GD

Greg - N8GD

  • 213 Posts
  • 79 Reply Likes
That's correct.  Meinberg's operation is a completely different process from other time setting apps.  It's also more difficult to understand its operation and configuration.  Basically, just install it and enjoy its accuracy.
Photo of sky

sky

  • 35 Posts
  • 5 Reply Likes
Greg: Followed all you clear instructions to the letter ( using Windows 7). However, the NTP service will not start. ("Network Time Protocol Daemon" shows as 'enabled' in Windows Services and Windows Time is disabled and stopped).

In NTP Time Server Monitor, "Service Status" shows "Stopped" in red and on the next line, "Service Start Type: Automatically" 
I have  NTP Time Server Monitor and ntp-4.2p11-win32-setup.exe installed.Any suggestions to solve this NTP service problem? Thank you!
UPDATE: Figured out that perhaps the earlier installed Dimension4 might be interferring. I went into Services and disabled it.  I then went into NTP Time Server and clicked on 'start NTP service.' After giving it some gas, it started! My computer can now provide very accurate time. Thank for setting me on the path of solution.
(Edited)
Photo of WA2SQQ

WA2SQQ

  • 420 Posts
  • 87 Reply Likes
Totally baffled. No matter what I've tried I'm getting a consistent .9-1.0 second behind the correct time error. My other PC's are dead on using time.is web site. Even tried uninstalling and reinstalling. This has been consistent using either Win 10 1709 or 1803
Photo of WA2SQQ

WA2SQQ

  • 420 Posts
  • 87 Reply Likes
Tim, this might be a clue ... Using the NTP Time Server Monitor, selecting NTP Status, it updates once every second. It shows, "No Association ID"
Photo of Bill W2PKY

Bill W2PKY

  • 453 Posts
  • 79 Reply Likes
On the Meinberg Monitor click NTP Status to see the servers. Make sure the service is started on the main panel. May need to start as Administrator.
Photo of WA2SQQ

WA2SQQ

  • 420 Posts
  • 87 Reply Likes
OK, it's working! I think they made a change in the setup file. In the 3rd screen it asks if you want to make a configuration file, I selected YES. On the older version it had a default selection - on the latest version in addition to selecting YES, you need to select a config (location). Selected US and it's now showing Time is Exact.
Photo of WA2SQQ

WA2SQQ

  • 420 Posts
  • 87 Reply Likes
Just an observation that may be of interest to some. I've noticed that checking the time about 20 seconds after the PC boots up, I'm occasionally seeing an error of +/- .5 seconds. If I check it again in say 15 minutes, it seems to correct to the exact time.  In the end, even the .5 seconds is no big deal.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3471 Reply Likes
This behavior would be expected.  PC RTCs (real-time clocks) are notorious for drifting.  Being off .5s is not unusual.  When NTP starts up it will use the drift file to do the initial clock correction and then once it finds a good NTP server, it will make the final clock correction over a period of time until it is very accurate.