Maestro won't turn on

  • 1
  • Problem
  • Updated 3 years ago
  • In Progress
Maestro won't turn on. The AC adapter has been plugged for several days. There is no USB battery.
Photo of Rory - KN5D

Rory - KN5D

  • 0 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Martin Ewing AA6E

Martin Ewing AA6E

  • 337 Posts
  • 81 Reply Likes
Have you had it working before?

Did you press the power button and hold for ~5 seconds?  You should feel a little "click" when the button is fully engaged.  You might need to press harder.

73 Martin AA6E
Photo of Jay / NO5J

Jay / NO5J

  • 1685 Posts
  • 266 Reply Likes

Echoing Martin:

Press the power button down for @ 5 seconds. You should first see the screen go from blackest black to a nearly identical but imperceptibly brighter shade of black, (you can release the power button when you see this change) it's the touchscreen powering up. Next, the Maestro begins it's boot up sequence, Wait a while and you "may" see the Maestro splash screen momentarily along the way to the radio selection or wireless selection screens. Mine often goes straight to connected and already running, all by itself now, after the most recent software upgrades. 

My guess is your not holding down the power button long enough.

You would likely already be aware of all this if it had ever worked for you before.

I think it's intentionally designed this way to avoid accidental power ups when stored in things like backpacks, go boxes, etc. It would be a shame to hike it in 5 miles uphill, only to find out the battery was being drained while you were bouncing along. 

If it worked fine in the past, and you already know all this, sorry for wasting your time.

73, Jay - NO5J

Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9395 Posts
  • 3637 Reply Likes
Official Response
I have converted this topic to a support HelpDesk ticket ( for expedited issue resolution.  Please respond using the HelpDesk ticket for issue resolution.