Maestro no Mic 2 audio on transmit

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
Just received Maestro today!  Was very impressed and having great fun... until I tried to transmit - no audio.

I first tried an iPhone compatible headphone with mic - no luck.  So I went to Best Buy and bought a cheap Logitech gamer headset with separate 3.5 mm TRS headphone and mic plugs.  Headphone works perfectly - no Mic 2 audio on transmit.

Next I tried a brand new Insignia mic (NS-DLMIC10P) into Mic 2.  No audio.

I have searched hi and low, in both this forum and throughout the Maestro menu system. Don't find a way to choose audio input device.

Frustrated, I switched back to my PC running SmartSDR and found my audio settings had changed (apparently they're sharing the same profile), so created a new profile for Maestro (not apparent at first).

Not sure if I'm doing something wrong or got a 'lemon' whose audio no worky.

Recommendations on how to troubleshoot this or next steps?

Rick
W5FCX
Photo of Rick - W5FCX

Rick - W5FCX

  • 287 Posts
  • 77 Reply Likes

Posted 3 years ago

  • 1
Photo of Rick - W5FCX

Rick - W5FCX

  • 287 Posts
  • 77 Reply Likes
Official Response
Okay.  Figured it out.  There's a hidden pop-up menu that isn't accessible using the main MENU function.  It's the Mic Menu that others have alluded to but wasn't obvious at first.  To access it, you depress the Mic button and magically the Mic Menu appears!  (see attached)

From there, it's easy to select the Mic input and adjust as needed.

Recommend adding that as an example and screenshot in the Quick Start guide so others who are learning how to transmit will find it a bit more quickly than I did.