Maestro MIC2 audio AC noise

  • 1
  • Problem
  • Updated 6 months ago

Hello.


 I have a problem with Maestro MIC2, not its possible transmit without high noise, such AC power, I tested dynamic microphone, electret capsule, Trust quasar headset, Heil Sound Proset Elite, Heil Sound Pro7, with and without BIAS all with same result. Also I removed the AC switched power supply using a linear power supply. It is possible that I have a hardware problem on Maestro?

 https://vocaroo.com/i/s15MsA7A5DbR I attach audio sample of noise.


Thanks in advantage, Miguel EA5GF

Photo of Miguel

Miguel

  • 20 Posts
  • 3 Reply Likes

Posted 7 months ago

  • 1
Photo of Michael Walker

Michael Walker, Employee

  • 862 Posts
  • 251 Reply Likes
Hi Miguel

Please open a support case.

Mike
Photo of Steven Linley

Steven Linley

  • 383 Posts
  • 67 Reply Likes
It might be because of the mic jack plug wiring. The mic plug must have a TRS plug (Tip Ring Sleeve).
Photo of Howard AE3T

Howard AE3T

  • 5 Posts
  • 0 Reply Likes
I have exactly the same noise problem using any mic plugged into the Maestro. It is worse with the flex FHM-2 mic. Any suggestions?
Howard AE3T
Photo of Miguel

Miguel

  • 20 Posts
  • 3 Reply Likes
Try change Power supply by another.
Photo of Miguel

Miguel

  • 20 Posts
  • 3 Reply Likes
Hello.

I send finally to Flex EU service, after change the display and back to my home have the same problem:-(  Arrived from factory with this problem, tested with two Flex radios and MIC1 input. I will ask the seller to return the money or change it for a new one, It is a manufacturing defect and I could not use my new Maestro after two months.


Photo of WW1SS - Steve

WW1SS - Steve

  • 785 Posts
  • 263 Reply Likes
Sounds like either a wiring issue or bias maybe on when it needs to be off or visa versa. My RS 55 headset works fine here
Photo of Miguel

Miguel

  • 20 Posts
  • 3 Reply Likes
Wow tested with power bank without any PSU and no more noise! :-)