Maestro MIC 2 connect has no BIAS

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I just received my Maestro today and I have a headset to use that needs mic bias.  However mic bias does not seem to be working in Maestro.  If I use it connected directly to my 6300 it works fine.  Any ideas?  Is this a bug?  I have tried selecting MIC2 in the TX menu as well along with other combinations. 
Photo of N3NER

N3NER

  • 186 Posts
  • 24 Reply Likes

Posted 2 years ago

  • 1
Photo of Bob Wright, N7ZO

Bob Wright, N7ZO

  • 268 Posts
  • 66 Reply Likes
Official Response
W2NER,

Steven is correct.  It has to be enabled in the Phone/CW menu.  I tested mine with a voltmeter and am getting 2.5 Vdc on the tip on MIC2.

See section 25.8 in the current Maestro manual.  (There the manual says 5 Vdc, which seems to be a documentation error since section 4.4.6 says 2.5 Vdc.  Tim?)

73, Bob, N7ZO
(Edited)