Maestro keeps downgrading my 6500 back to v.1.7.30 from V.1.8.30

  • 1
  • Problem
  • Updated 3 years ago
  • Not a Problem
Every time I update to new 1.8.3 Smart SDR on the 6500, when I turn on Maestro, the only way it will run is to run the V 1.7.30 update on Maestro which takes the 6500 backwards. UGH.  The 1.8.30 file to download on Maestro won't download as it has serious bugs in it.  So why won't Flex send all Maestro owners an email to tell them of this problem?
So now I have to run the 6500 on version 1.7.30 if I want to use Maestro.
Photo of Rob Laws

Rob Laws

  • 22 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Rob Laws

Rob Laws

  • 22 Posts
  • 0 Reply Likes
Official Response
Latest reply from Flex:

We have removed the ability to download SmartSDR v1.8.3 for Maestro due to a software defect that can possibly render your Maestro inoperable and require it to be returned to FlexRadio in order to correct the issue. We placed a message to this effect on our Community (https://community.flexradio.com/flexradio/topics/issue-with-maestro-v1-8-update)

Therefore, the behavior you are experiencing is not a problem, per se. We are working on a fix and will be releasing a new version of SmartSDR for Windows and SmartSDR for Maestro once we have the Maestro defect corrected. This is our highest priority issue to address. So for the time being, you will have to downgrade the radio's firmware when using the Maestro. We apologize for the temporary inconvenience.

Tim Ellison, W4TME: