MAESTRO + FLEX 6500 + POWER GENIUS XL + STEPPIR DB-18E = HIGH SWR READINGS

  • 1
  • Question
  • Updated 1 week ago

Problem: When using the Maestro + Flex 6500 + Steppir DB-18e with SDA 100 controller, all bands have been configured with LOW SWR Readings, All is FINE.  Now when I wire up the Power Genius XL and take it from STAND-BY to OPERATE, All Bands show High SWR with exception of 40 Meters in the 180 degree mode on the DB18-E. I can run 1200 Watts on 40 Meters. All the Front Panel readings on the Power Genius XL are Correct with every band I chose. Any Ideas, or do I have to invest in a High Power Antenna Tuner?
Photo of N4ZAX - PAT

N4ZAX - PAT

  • 3 Posts
  • 0 Reply Likes

Posted 2 weeks ago

  • 1
Photo of Mack McCormick

Mack McCormick, Elmer

  • 521 Posts
  • 179 Reply Likes
Pat,

I run an almost identical configuration on two different SteppIRs. No issues. Let's start by connecting the amp to a high power dummy load. Run the test again. 

That will definitively let us narrow down the issue. I never use a high power antenna tuner except in the phone band for 160M since my antenna is cut for the CW portion of the band.

73,

Mack
W4AX
Alpha Team
Photo of Erika - KØDD

Erika - KØDD

  • 33 Posts
  • 15 Reply Likes
Good Morning Pat,

That definitely is not correct. I don't have a PGXL YET someone send me one, I would be grateful. However it's my understanding the radio gets power and reflected indications FROM the PGXL when its on. That should be what's actually happening at the output of the amp. It's going to be interesting where this problem really is..  EXPECT RF getting into Somewhere it doesn't belong.

As Mack indicated you need to isolate sections.
If you have access to another FWD/REF POWER meter stick it into the circuit right after the amp. That would most likely be your quickest test...  That takes the power and reflected indications out of the radio combos hands...  It will tell you quickly if there's an issue with the antenna doing something it shouldn't be doing.

The first two things I'd suspect is grounding issues, loops or RF hot grounds.  IF your Steppir takes off during High power ops THAT could be an issue.

We had a weird issue back in the 80's the station was Built Quickly during a field day. The "GUYS" showed up with a moving van and a radio station...  We moved to the farm built a tower and installed a 2 elm triband quad.  The coax was too short one of the OPS FOUND in the coax supply the perfect length hunk of coax.  It turned out a year later the issue was figured out a 15 meter phasing line.  (One side of a 15 meter harness) The Quad had major SWR on 15 and I never  suspected the jumper from the rig was a 15 mtr phasing line. The other two bands were great.

Hanging a dummy load is one test, but that will only prove the radio and amp put out RF.  You have an issue either causing the antenna controller to flake out or something silly to interfere with the proper indication of the antenna's operation. Like a piece of coax, wink.

You don't need a High Power TUNA...  Your antenna is already its own tuner. Jus Sayin.

Erika DD


Photo of lz2be

lz2be

  • 4 Posts
  • 0 Reply Likes

Hi Pat,

I have similar setup 6600+Acom2000A+DB18E.
I would suggest you first to check if all coax connections are tight. If some of them is loose it is possible to have arching at high power.
Then I would move DB18E to 6500 output to see if SWR is OK at low power.
If all is OK move DB18E back to PGXL out and check SWR first at low power and then increase power out to max. If SWR change it mean there is probably a loose connection in middle EHU or 3way coax switch of the antenna.
DB18E driven element is middle element for 30-6m bands, while on 40m it uses front or rear element.

73 Boyan