Maestro and V.2.1.33 upgrade

  • 1
  • Problem
  • Updated 8 months ago
I'm trying to upgrade to 2.1.33 and I was able to do it to radio and now it works with ssdr on windows but still unable to login from maestro.
What I did with maestro I clicked version> and selcted v2.1.33 and update. It did update but still unable to login. Station is remote so radio is updated via remote PC on site. Does maestro have to visit on remote site to be really upgared or what to do?
Photo of Niko Halminen

Niko Halminen

  • 6 Posts
  • 0 Reply Likes

Posted 8 months ago

  • 1
Photo of Jim Gilliam

Jim Gilliam

  • 858 Posts
  • 183 Reply Likes

Can you log in with a PC? You can test the connection in Smartlink settings pressing the blue test button. Several times, my test failed. However, I can remotely remove power from the radio as well as turn it off. When I do both, the radio grabs the attention of the router and, after booting, the test passes and all is well.

Jim, K6QE

(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
I just tested it here on the 2 different Maestro models and connected to several different radios, so I do not think this is a systemic issue (defect).
Photo of Matt (K0KB)

Matt (K0KB)

  • 78 Posts
  • 20 Reply Likes
I'll respectfully disagree about it not being a defect.
Photo of Matt (K0KB)

Matt (K0KB)

  • 78 Posts
  • 20 Reply Likes
My maestro won’t login to smartlink. Updated radio and maestro to .33 and and maestro at my office (remote) won’t log in.

Same symptoms as yesterday fyi.
Photo of Henning

Henning

  • 14 Posts
  • 2 Reply Likes
Hi,

the same with me, Maestro does not login into SmartLink. It accepts credentials and returns to the same state as before, logout of SmartLink.
SmartSDR on Windows works as expected. All devices are updated to 2.1.33

73 Henning
Photo of WX7Y

WX7Y

  • 564 Posts
  • 102 Reply Likes
Just tested mine on my Verizon MiFI and it worked just fine with the Maestro. 
If you can reboot the radio remotely maybe that will help. 
I always power down my radio and power it back up after a update so maybe that is the difference, 
Hope you find the issue soon.

73's
Bret
WX7Y
Photo of Niko Halminen

Niko Halminen

  • 6 Posts
  • 0 Reply Likes
Nice to hear that others are getting it work. I hope you really are trying it remotely. I believe that it's no problem locally. Radio reset didn't help. Thing is that I can't login with maestro so smartlink is not showing me my radios. Symptoms as same as before update.
Photo of WX7Y

WX7Y

  • 562 Posts
  • 102 Reply Likes
Yes running through Verizon wireless is about as remote as you can get. 
73
Bret
WX7Y
Photo of Niko Halminen

Niko Halminen

  • 6 Posts
  • 0 Reply Likes
Now I got it working. What I did was I drove 500 km to my site, I dig through my way 200 meters in 1m deep of snow to machine room and plugged my Maestro direclty to LAN. When I was once connected to radio directly Smartlink login started to work. Maestro did not do any upgrade posedure on thins poin. It was done day before. So it lookslike you have to be able to connect your radio to make effect after upgrade. Now  I'm back home and everyting is up and running. fingers crossed hoping it won't break during weekend's RDXC.
Photo of Abed - AB5ED

Abed - AB5ED, Employee

  • 22 Posts
  • 4 Reply Likes
Niko,

Yes, the Maestro will need to run v2.1.33 once with the radio before the SmartLink login issue is fixed.  Unfortunately this means that you will have to run Maestro local to your radio one time in your case.

This is the nature of how the update process works today.  We understand how this process does not work well for users that operate 100% remote.  I have added this issue to be discussed with our development team (#6121).
Photo of Niko Halminen

Niko Halminen

  • 6 Posts
  • 0 Reply Likes
It felt like it was upgraded because on radio selection screen you can see version tap on upper right corner. By pressing than you was able to see V2.1.33 and it did some kind procedures. But you know best and I'm happy if you are looking on it! Have nice weekend!

-OH2GEK (100% remote :)
Photo of NK9E

NK9E

  • 6 Posts
  • 2 Reply Likes
Just to clarify the comment by Abed of Flex.  ANY Flex radio with 2.1.33 will "fix" your Maestro so it will work with SmartLink again.  It does NOT have to be the Flex radio you desire to operate remotely with your Maestro.  At least that worked for me!

See my topic of yesterday:  Current Fix For Maestro That Will Not Work With SmartLink

Gene  NK9E