Lost connection through smartlink tethered to smartphone

  • 1
  • Question
  • Updated 3 months ago
I tried for the first time to tether my smartphone to my laptop and use smartlink  to my Flex 6600 V2.3.9  ... I can connect to the radio but it will not stay connected very long (lost Connection) I tried reconnecting with (low BW connect) and I stay connected longer , say 2 minutes ! I did a speed test on my smartphone , it was 11mb down and 6mb up .. Is this not enuf BW ? I changed the connection on the laptop to the home router , I stayed connected no problem .  When I bring the radio up on the laptop I'm only using one slice , trying to minimize data usage .

Like I say this is my first time to try this so I must me missing something ? 

Ed N5DG 
Photo of Ed Stallman

Ed Stallman

  • 47 Posts
  • 5 Reply Likes

Posted 3 months ago

  • 1
Photo of Winston VK7WH

Winston VK7WH

  • 308 Posts
  • 71 Reply Likes
I had a similar problem when SmartLink first came our. I was losing connection at precisely 2 minutes each time. My service provider was kicking me out, presumably because of the nature of the data being used. After moving to another provider, the problem was solved. Maybe you could first check to see if your disconnection is at precisely the same time or not


Good luck


Winston VK7WH
(Edited)
Photo of Bob - W7KWS -

Bob - W7KWS -

  • 321 Posts
  • 52 Reply Likes
I've had the best luck with Verizon & T-Mobile and difficulty with AT&T here in the Seattle area. Things can be very different in other areas.
Photo of Bob - W7KWS -

Bob - W7KWS -

  • 321 Posts
  • 52 Reply Likes
If your cell plan is a low priority such as a prepaid plan and/or there is heavy traffic on the tower, there may be large gaps of slower data causing the disconnects. Your speed test is an agregate over time of fast and slow periods.
Slowing down the "FPS" to 1 and the "Rate" to 60 might help.
Other remote options such as RemoteRig, Icom's RS-BA1 and RCForb include settings to adjust the buffering to help overcome these gaps. I've not found this type of buffering adjustment in SmartSDR so I assume it's not there. Hopefully it can be added in the future.


73
(Edited)
Photo of bahillen

bahillen

  • 126 Posts
  • 43 Reply Likes
Be sure to turn off the 4 IQ DAX channels. Check your bandwidth using computers Task Manager. Performance > Ethernet.
DAX buttons not used should be black. One Slice should be 0.5 Mbps. Only 1 panadapter should be opened. This should give you a very low bandwidth channel. Make sure your not using WiFi as it can be unpredictable. If you find it works ok then you can start adding things back in and measure the bandwidth use as you go.

I got a good improvement in reliability when I connected the radio to my computer through a ethernet switch instead of going through the modem/router connections. The added switch is plugged into the router/modem.

It maybe a problem with the computer CPU or memory, because the operating system is having CPU interrupts that cause loss of connection. CW Skimmer, Chrome, video monitors and open apps can use a lot of resource on the computer causing it to write to hard disk.

Last issue is your ISP could be causing disruption to your internet routing. If others are live-streaming others could cause you problems some times of day.

Just some ideas that may help.

73
Bill W9JJB
Photo of Ed Stallman

Ed Stallman

  • 47 Posts
  • 5 Reply Likes
Winston thanks reply, By you saying you moved to another provider , are you saying I should try another cel phone provider ? I stay connected on my home router ! 

When I lose connection , this message pops up (84.sub-174-235-9.myvzw.com) 

I tried to time the drop connection but it stayed connected this time using (low BW connect) also I'm staying connected using (connect) ... On the network Diagnostics i'm seeing 3 bars ! 

I'll keep playing with it and see how it go's 

Ed N5DG
Photo of Ed Stallman

Ed Stallman

  • 47 Posts
  • 5 Reply Likes
Thanks Winston, Bob and Bill , I dropped the FRS down and one slice , I seam to be staying connected now through the Verizon Cel phone  . I'll check with verizon , maybe I can get a better data plan . What I'm trying to do is work remote this summer on vacation while my wife is driving ! I've used the 6600 for close to a year now at the house with no issues other then the learning curve .
I've stayed connected for 30 mins now , I'll plug in a headset to see if I can talk with someone .

Thanks Ed N5DG
Photo of Winston VK7WH

Winston VK7WH

  • 308 Posts
  • 71 Reply Likes
Ed, my situation may be a little different to yours. At the time I had the problem my 6700 was at my remote site where I only had access ro a 4G service. Again, in my case, the loss of connection occurred precisely 2 minutes after connecting each and every time..

The problem was confirmed by my service provider as normal for a retail service and the only way to fix it was to move to a business account with a new business APN. I did this as a temporary fix and the disconnections stopped.

To reduce the exorbitant charges I was paying, I have since ditched this provider and installed a three hop wifi bridge back to a Fibre connection at the nearest town about 10 Klm away.

On the iPad/iOS end, I can’t recall ever have a problem with disconnects. Sometimes it requires reducing the refresh rate and the panadaptor scroll speed.

As I mentioned, my setup may be different to yours. Unless your disconnects are precisely the same lengths as each other, I think my solution may have no bearing on your problem.

Please let me know if I can help in any way.

Winston.
Photo of Winston VK7WH

Winston VK7WH

  • 308 Posts
  • 71 Reply Likes
Ed, that’s great news. Sorry I hadn’t seen your reply before I responded.

Best 73

Winston
Photo of Bob - W7KWS -

Bob - W7KWS -

  • 321 Posts
  • 52 Reply Likes
Ed,

You might want to try a cell phone booster as well. The WeBoost sleek will help if you're going to be driving in rural areas away from the Interstate highhways. I use the original sleek with Verizon & it's a big help. The current version is easier to use than my old one. Look here and at a couple of independant YouTube reviews:

https://www.amazon.com/weBoost-Drive-...

Bob
(Edited)