LAN connections problem with 6300

  • 2
  • Question
  • Updated 3 years ago
  • Answered
6300 and SmartSDR (latest) never connect on first start of the Radio.

Setup:  6300 and SmartSDR PC are hard-wired to same access point on the LAN.  Following sequence is always followed to get radio to connect to SmartSDR.

1.        SmartSDR can be started either before or after start of radio.  Events in 2. below are not affected.

2.       Radio is started and indicates as "available" on SmartSDR “Radio Startup” screen left-hand window.  Selecting Radio tab always indicates radio’s IP address is 169.254.7.35 which will not connect in the LAN where all addresses are in the range 192.168.XX.XX.  Pressing CONNECT at this point fails.  Stopping the radio and restarting always returns a suitable address assigned by the DHCP server in the correct 192.168.XX.XX range.

3.        Why does SmartSDR even show the Radio as "available" when the Radio tab always shows it to be out of range on the first start of the Radio?

4.       Seems like very strange behavior.  No other device on the LAN has trouble getting an address from the DHCP server.  Network reports as "excellent" in SmartSDR - no noise.

Thoughts?  Do I need to gut my network components and start over?

George K7GRJ

Photo of George K7GRJ

George K7GRJ

  • 5 Posts
  • 2 Reply Likes

Posted 3 years ago

  • 2
Photo of James Madden

James Madden

  • 187 Posts
  • 11 Reply Likes
I experience the same things on my 6300 and my upgrade to my 6700. I must power cycle the radio twice to solve the problem> jim WD7W
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1612 Posts
  • 570 Reply Likes
Recommend setting a DHCP reservation for your rig. Should get you going every time.
Photo of Mark - WS7M

Mark - WS7M

  • 1145 Posts
  • 400 Reply Likes
I have not experienced this problem with my 6300 and later my 6500.  However I think your analysis is correct.  For whatever reason on the first power up the radio is not successfully getting a DHCP address.

I think the easiest fix, (because you could spend a ton of time trying to figure out the root cause), is George's suggestion.  Take the MAC address of your radio and in your router make a DHCP reservation and give it a known address.
Photo of Frank  WA3NHK

Frank WA3NHK

  • 67 Posts
  • 13 Reply Likes
Agree with the suspicion of a DHCP issue.  The 169.254.x.y subnet is special.  Your radio is generating what is called a "self-assigned address", which is always drawn from the 169.254.x.y subnet.  Most likely the radio is either not happy with the reply from your router's DHCP server or isn't even seeing it for reasons unknown.  (Probably some sort of corner condition in your router's DHCP implementation.)  Apparently SSDR is seeing the broadcast packets from the radio and that's why you see it in the window.  But your PC can't connect to it because it isn't on the 102.168.x.y subnet.  Weird, I know.
Photo of Gary Wise

Gary Wise

  • 77 Posts
  • 19 Reply Likes
I have the same issue with my 6500. By any chance, do you have AT&T UVerse, using a Motorola DSL/Router?

I believe there is an issue with this router and Linux based devices that requires the double start.

I don't know the fix, but would love to learn it.

73,

Gary W4EEY
Photo of Joe WD5Y

Joe WD5Y

  • 176 Posts
  • 24 Reply Likes
I have the same issue with a nitehawk r7000 router and ex6200 extender. The flex and PC are both direct connected to the extender (2nd extender tried by the way). The PC gets IP address with no problem, the flex has to be powered up and down multiple times to get IP address. I did go further and set up another router that was dd-wrt firmware flashed and set up as client bridge in place of the ex6200 extender, the PC and flex get ip addresses on first power up. The difference being that the bridge has its own dhcp server enabled. I plan on flashing the ex6200 with dd-wrt firmware and configuring as client bridge, I want want the ex6200 in place because of better speed. I believe There is something going on with the flex and ip retries with regards to dhcp.
Photo of Philip KA4KOE

Philip KA4KOE

  • 174 Posts
  • 22 Reply Likes
Did this work for you?
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9153 Posts
  • 3496 Reply Likes
So here is what I suspect is happening.  You stated that both the 6300 and the PC are hard-wired to same access point on the LAN.  Since you said access point rather than wireless router, I am going to assume that the device both are plugged into is not the router which is providing DHCP services.  If the DHCP server is accessed over a wifi link (like WD5Y using a wifi extender), then what I suspect is happening is that the wireless bridge connection to the DHCP server is not fully established at the time when the 6300 sends the DHCP DISCOVER packet resulting in it never reaching the DHCP server.  If the DHCP server never receives a DISCOVER packet, the IP address allocation process fails and the fall-back APIPA IP address (link-local) one is allocated.  This all boils down to an initialization timing issue.
Photo of Philip KA4KOE

Philip KA4KOE

  • 174 Posts
  • 22 Reply Likes
Joe....how did you do the dd-wrt firmware update? I have the exact same router as you. Thanks.

Philip
Photo of Joe WD5Y

Joe WD5Y

  • 176 Posts
  • 24 Reply Likes
Hello Philip,
You will need to go to the dd-wrt site and join by setting up your account, very easy. There will be a listing of the model number to select the update with instructions. You will perform a few steps before the download. It has been some time since I did this. When I loaded mine the model number was close to the top of the list. After you load, you will need to setup as a bridge. I am very happy with how mine works now. The site is listed under "myopenrouter".
73's
Joe
WD5Y
(Edited)
Photo of Corey/ KC0YNS

Corey/ KC0YNS

  • 106 Posts
  • 9 Reply Likes
That's what I'm using for mine...Works great no issues...Had it working for about two weeks now!!!  
Photo of Philip KA4KOE

Philip KA4KOE

  • 174 Posts
  • 22 Reply Likes
Could we solve this issue by installing a second Ethernet 1GB wireless card in the computer? One cord goes to the radio. The other cord goes to the wireless extender.
(Edited)
Photo of Walt

Walt

  • 236 Posts
  • 75 Reply Likes
I switched back to 1.6.21 since 1.7 keeps disconnecting from the computer, and I am connected directly from the 6500 to the computer.  1.6.21 ran all the time for months  24/7 without a problem.   I do not have a maestro.  I got an error code once and sent that to the helpdesk in case it would help them troubleshoot.

Tim mentioned this in a similar post . .

'This issue has been previously reported and entered into the bug tracker as defect #3597 and classified as a critical issue.'

Good Luck !
Photo of Simon Lewis

Simon Lewis

  • 495 Posts
  • 117 Reply Likes
since 1.7.30 desktop SSDR connects also drop or suffer packet loss - this NEVER happened before 1.7 on my setup and nothing changed apart from 1.7.30!

same with Maestro - a direct cabled flex to maestro suffers from packet loss! my direct cabled mini PC to flex never missed a beat before 1.7 - so what gives.  Suddenly a cabled maestro or PC starts reporting poor network performance on a direct cable - so bad it suddenly looses connection.

there for sure is something odd happening in 1.7.30 around network connectivity - I know the devs have 2 defects open on wired and wifi - something wacky is occuring for sure
Photo of Philip KA4KOE

Philip KA4KOE

  • 174 Posts
  • 22 Reply Likes
This appears to be an issue others have posted going back at least 4 months given the postings here after a little bit of searching. Let's hope this is something that can be addressed via a future software modification as it is on the list of critical issues. But hey, I finished school back when Fortran 77 was being taught as well as Intel 8080/8085 architecture, so what do I know?
(Edited)

This conversation is no longer open for comments or replies.