KNB_FlexControl Tuning knob I/O conflict

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I purchased a Tknob that has its own mind, where and what port it would occupy. The knob insists in using port 5 which is the port for my BobSmeter. I move the meter to a different port and yes you guessed it; the knob insists on taking that port too etc... I have changed the port of the knob in device management, but it does not make any difference. It parks itself anywhere it wants!
I had it working last night in conjunction with the meter. I turned the radio, computer, and all the accessories off. This morning I turned all components on, and again; the darn knob did the usual port hijacking. I unplugged the knob in order to avoid all the problems it causes; such as disabling WSJT9, SmartSDR, BobSmeter, etc...
Using: Win7/64 - i7 Quad core, 8GB memory - Flex-6700 - SmartSDR, CAT, DAX, (up to date versions, old v. deleted) - HRD - WSJT9 etc...
Radio works flawless until the knob is introduced: It's now resting on the desk occupying space and useless!
Photo of Ernest - W4EG

Ernest - W4EG

  • 583 Posts
  • 113 Reply Likes
  • confused and loving my DAX

Posted 4 years ago

  • 1
Photo of Stu Phillips - K6TU

Stu Phillips - K6TU, Elmer

  • 642 Posts
  • 256 Reply Likes
Ernest,

The subject says FlexControl but your text says TKnob? Is this the Woodbox Radio Tmate or the FlexControl from FlexRadio?

If its FlexControl, I can probably help.
Stu K6TU
Photo of Ernest - W4EG

Ernest - W4EG

  • 583 Posts
  • 113 Reply Likes
Hi Stu,
It is FlexControl by K6TD/K6TU. Thank you for the offer Stu... I am in San Diego and I can call you or you me?
I will be happy to get this going! First time using your knob after KF2T encouraged me to buy one.
Photo of Stu Phillips - K6TU

Stu Phillips - K6TU, Elmer

  • 642 Posts
  • 256 Reply Likes
Ernest,

Lets try this... first open up SmartCAT and delete any ports your have created. Quit SmartCAT and reboot your PC with the FlexControl unplugged. After the OS has rebooted make sure that SMARTCat is NOT running and then plug the FlexControl into the USB port you want to use. After the OS has gone through the device discovery (USB "bong" plus installing driver), pull up the device manager and find the FlexControl under the COM ports.

Right click and open the properties menu.... on one of the tabs, there is an Advanced option that lets you set the COM port you want to use. Click on Apply and enough OK's to get back to device manager.

Now start SmartCAT and assign the ports you want for the different programs...

Your original post didn't say whether you are using a virtual serial port emulator OTHER than the one in SmartCAT - so I'm assuming that you are creating ports in SmartCAT to handle the other functions includes Bob's Smeter etc.

You should now be ok and the FlexControl should remain in a fixed location when you reboot the machine so long as its plugged into the same COM port.

Windows has a mind of its own when assigning USB COM ports in a system that also have virtual serial port drivers like the one in SmartCAT.

Try this and let me now. If this doesn't work, email via my email address in QRZ.COM and we can schedule a call.

Stu K6TU
Photo of Dudley - WA5QPZ

Dudley - WA5QPZ

  • 212 Posts
  • 45 Reply Likes
Ernest,

There can be some com port conflicts with ghosted virtual port, one easy way to get around it is to assign a very high com port , 50 or higher just stay away from the conflicts. Go to Windows Device manager => Ports => FlexControl => Properties => Advanced , change the Com port to 50 or higher.

Save and you may have to reboot for it to be functional.
Photo of Ernest - W4EG

Ernest - W4EG

  • 583 Posts
  • 113 Reply Likes
Stu & Dudley,
As the worldly world said "you are the man"
Stu
Followed the instructions (a few more buttons needed to be click, than those listed.) However, IT IS WORKING!
Question; would your knob recognized USB3.0 ports (USB45.)
Dudley
I will re-do the knob after I get the answer from Stu about USB3 usage.
And I will set it to a higher I/O port.
Photo of Stu Phillips - K6TU

Stu Phillips - K6TU, Elmer

  • 642 Posts
  • 256 Reply Likes
Awesome! FlexControl works fine with a USB 3.0 port - they are backward compatible with earlier versions of the "standard".

Glad everything is working and happy tuning around!
Stu K6TU
Photo of Don - kx9q

Don - kx9q

  • 388 Posts
  • 16 Reply Likes
USB ports are supposed to be downward compatible so a USB 3.0 will recognize and work with a device using USB 1.2 (FlexControl) or 2.0, etc.

Don
Photo of Don - kx9q

Don - kx9q

  • 388 Posts
  • 16 Reply Likes
I have used my FlexControl on a USB 3.0 port.
Photo of Ernest - W4EG

Ernest - W4EG

  • 583 Posts
  • 113 Reply Likes
Thank you Don. I will give it a try ... I have heard the bong sound when I plug it.
This site is quite a learning site too.
Photo of Ernest - W4EG

Ernest - W4EG

  • 583 Posts
  • 113 Reply Likes
Step by Step installation for the tuning knob

KNB-FlexControl USB Controlled Tuning Knob
Creating ports to prevent conflicts when using T-knob and Smart CAT

1. Open Smart CAT and delete any/all ports your have created.
2. Quit Smart CAT
3. Turn off the radio (Flex-6x000)
4. Reboot your PC with the FlexControl unplugged.
5. After the OS has rebooted make sure that SMART CAT is NOT running
6. Plug the FlexControl into the USB port◊ you want to use.
7. After the OS has gone through the device discovery (USB "bong" plus installing driver.)
8. Pull up the device manager♦ *see notes
9. Find the FlexControl under the Com Ports.
10. Right click and open the properties menu.
11. Click on the "Advanced" option that let you set the Com Port♣ you want to use.
12. Click on Apply and enough OK's to get back to device manager.
13. Start Smart CAT and assign the ports you want for the different programs.
14. Turn the computer off.
15. Turn computer on.
16. Turn on the radio and the other devices you use.
17. Check CAT and go to Port Map, click Refresh; all your devices port will appear labeled.

Notes:

• ◊You should now be okay and the FlexControl should remain in a fixed location when you reboot the computer; as long as it's plugged into the same COM Port.
• ♦Go to Windows==>Control Panel==>System==>Device manager =>Ports => FlexControl =>Properties =>Advanced; change the Com port to 30 or higher.
• ♣There can be some com port conflicts with ghosted virtual port; one easy way to get around it is to assign a very high com port, i.e. 30 or higher just to stay away from the conflicts.
• USB ports are supposed to be downward compatible so a USB 3.0 will recognize and work with a device using USB 1.2 (FlexControl) or 2.0, etc.
Compiled information received from Stu_K6TU - Dudley_WA5QPZ - George_KF2T & Don_KX9Q

Page 1 of 1 29-Dec-13
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9043 Posts
  • 3434 Reply Likes
This is a great conversation that's separate from the main topic, so I created a new topic to continue the discussion. Please reference the new topic here: How to change the FlexControl com port number to eliminate conflicts with CAT
Photo of Ernest - W4EG

Ernest - W4EG

  • 583 Posts
  • 113 Reply Likes
I was thinking on the same line just several minutes ago... You beat me to it.
And like always; you are right. Thanks.

This conversation is no longer open for comments or replies.