JT65 + JT9 simultaneous decode prob

  • 1
  • Problem
  • Updated 3 years ago
  • Solved

I have been mostly working JT modes since getting my Flex a couple of months ago. I have been using WSJT-X 1.3. Tx and Rx filters set 0-4000Hz.

It had always puzzled me that I had never decoded a JT9 signal when in JT65 + JT9 mode. A few days ago I saw a stonkingly strong (to use an English colloquialism) JT9 signal and still did not decode it.

After running some tests, I can only seem to decode JT9 signals when WSJT-X is in JT9 exclusive mode and my receive bandwidth is reduced to 2KHz and placed in the JT9 sub-band.

The signal I mentioned above got a signal report of +1 when I managed to decode it. The DAX Rx levels and those in WSJT-X were not changed at all during my tests.

What am I doing wrong? At the moment I don't know if this is related to WSJT-X or the way I have got the Flex set up.

Mni tnx.
Photo of Guy G4DWV/4X1LT


  • 1687 Posts
  • 387 Reply Likes

Posted 3 years ago

  • 1
Photo of Greg - K5GJ

Greg - K5GJ, Elmer

  • 79 Posts
  • 37 Reply Likes
Official Response
Hi folks - We've been doing some significant testing here in the shack with WSJT-X and while I don't have the White Paper ready to go, I'd like to throw out a few hints and see if anyone has better luck decoding JT9 in "BOTH" mode:

2. Set the Slice Passband to 5.1kHz.  This will cause the radio to optimize for digital modes with lower latency.
3. If you set the filter > 5.1kHz, it's not necessary to uncheck the "FLATTEN" in WSJT-X.  You will need to uncheck if you want to run a narrow filter.  Here is a note from "JT" himself regarding FLATTEN:

WA3CAS wrote:
> If you’re a TS-590S owner you may be interested in knowing that when
> I first used the new Flatten option I observed a severe distortion
> of the waterfall. I had the bandwidth was set to 100–4000 Hz, which
> worked perfectly with the old Slope control.

For those who'd like to know what is going on:

The *Slope* control allowed the user to apply a straight-line 
("straight" in dB) adjustment to the passband shape. The correct slope 
had to be determined by trial-and-error.

The *Flatten* algorithm automatically fits and removes a second-order 
polynomial to the lower envelope of the averaged spectrum. The active 
region for this fitting presently extends from 200 Hz above the lowest 
displayed frequency to the highest displayed frequency. If your filter 
cuts off well above 200 Hz, or well below the highest displayed 
frequency, *Flatten* (in its present form) will cause the "distortion" 
you observe.

You have two possible solutions: use wider filter in your receiver, or 
reduce the highest displayed frequency in your waterfall. YOu can do 
this by reducing Bins/Pixel or reducing the width of the Wide Graph.

> At first I thought Flatten was useless, but changed my mind when
> I increased the DSP high cut to 5000 Hz. When I did that, the
> waterfall became perfectly flat (and I do mean flat) with no signs
> of distortion. Wonderful, wonderful, wonderful.
> The only problem with using Flatten with the 590S is that I can’t
> narrow up the bandwidth or use the radio's Data filter without
> encountering distortion. If I deselect Flatten, the Waterfall
> baseline drops and disappears. I need to do a considerable amount
> of tweaking of the Zero and Gain controls to produce a useful but
> not ideal Waterfall. Also, by deselecting Flatten there’s no way
> to flatten the response unless I change the 590’s RX audio response.
> For me, deselecting Flatten is NOT an option.
> If this were a perfect world, I would have the option of selecting
> either Slope or Flatten. But until then, its 100–5000 Hz forever.

What's the disadvantage in using the wide filter? With my TS-2000, I do 
almost exactly what you are doing. (I use Lo Cut=200, Hi Cut=5000 Hz.) 
Unless you have an extremely strong signal in the 4000-5000 Hz range 
-- enough to cause Rx blocking or undesirable AGC pumping -- WSJT-X will 
just filter that range out, and you'll never know anything was there.

Finally -- it's surely possible to do a better job with the *Flatten* 
algorithm. I just made it work well with my system, with a few 
different test filter widths. If you have a system in which it does not 
seem to work well, send me a *.wav file and your wsjtx.ini file as an 
example. Ideally your example *.wav file should have only a few (or no) 
signals present.

-- 73, Joe, K1JT

4. Set AGC-T to 45-50 and use SLOW.  You can adjust the level if you need to.  I suspect you'll have plenty of excess gain to play with.

5. Use the DAX Control panel RX slider and the WSJT-X slider to set the RX level in WSJT-X to about -30dB with NO SIGNALS present.  The best thing to do is try to catch the quiet period at the end of each minute.  Joe's manual suggests that you try to keep his slider as close to center as possible.  I bumped it down some so I could keep the DAX slider sort of in the middle as well.

6. For JT9 transmit, you'll need to set the TX BANDWIDTH "HIGH CUT" to 4.5kHz or so.  It's a very sharp cutoff above that.

Once we got everything set well, we've had excellent results pulling signals out of the deep noise.   Please try some/all/none of the above and give feedback on what works and doesn't.  

73, Greg - K5GJ