is it just me?

  • 2
  • Problem
  • Updated 2 years ago
  • Solved
I've paid for v2, but can't get the radio to register.  I've tried all the tips listed here and opened a help desk ticket to no avail.  My network and internet connection are not the problem. Additionally, my Maestro won't boot, opened a ticket for that too, tried the reset routine, nothing works! 
Photo of John Week

John Week

  • 5 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9153 Posts
  • 3503 Reply Likes
Sorry for the delay in getting back to you John.  Please try your registration again.
Photo of Mike - W8MM

Mike - W8MM

  • 201 Posts
  • 43 Reply Likes
I have 3 6700's, one Limited Edition and two others. The LE and one of the later 6700's registered with no problem. Easy peasy.

The third wouldn't register.

I opened a help desk ticket and the problem was solved within hours!

Great work Flex and Tim!!!
Photo of W3EX -- Tom

W3EX -- Tom

  • 68 Posts
  • 14 Reply Likes

You are not alone. I am currently working with the help desk with the same issue. So far no resolution. I think my account may be corrupted. Waiting for a call back.


Photo of John Week

John Week

  • 5 Posts
  • 0 Reply Likes
Official Response
Tim did his magic - it's working and my Maestro decided to boot up as well!

Thanks!

This conversation is no longer open for comments or replies.