iOS stuttering

  • 1
  • Problem
  • Updated 6 months ago
  • (Edited)
iOS app seems to be having bandwidth issus even locally. I love the iOS app and it was one of the primary factors in my purchasing a flex. I have all the latest firmware and software installed both on the radio and my iOS devices. I have a new iPad 9.7 and an iPhone 6. Radio is plugged into 0100 MB port on my router in my Wi-Fi speed or greater than 25 MB. Even running in the low band with mode both my iOS devices seem to have bandwidth issues. Every few seconds or so the audio and pan adapter stutters and breaks up. I have no band with issues on any Windows device connected either locally or remotely. I’m sure it is something with the set up of the iOS app but can’t find anything. Thanks for your help
Photo of Ken, K2KXK

Ken, K2KXK

  • 44 Posts
  • 9 Reply Likes
  • hopeful

Posted 1 year ago

  • 1
Photo of Ronald / W4RJF

Ronald / W4RJF

  • 60 Posts
  • 3 Reply Likes
Photo of Pat Hamp

Pat Hamp

  • 37 Posts
  • 8 Reply Likes
Did you just do the most recent update? When I was on the prior version no problem, did the update and it now stutters.
Photo of Ron W4RDM

Ron W4RDM

  • 43 Posts
  • 10 Reply Likes
All my ios devices  stutter on my 2.4ghz, and work perfect on the 5ghz WIFI local connection.
Photo of Ken, K2KXK

Ken, K2KXK

  • 44 Posts
  • 9 Reply Likes
Larry's post at https://community.flexradio.com/flexradio/topics/smartsdr-for-ios-cutting-in-and-out  seems to have resolved my problem.  Basically turning off Mixed Mode.  Don't know why but it seems to have worked on both the 2.4 and 5 ghz bands.  Thanks so much for all the help.
Photo of Ken, K2KXK

Ken, K2KXK

  • 44 Posts
  • 9 Reply Likes
OK, so I thought my problem was solved but it's not.  I now know what's causing the ios app to stutter but don't know how to fix it.  It seems that ios (running 11.4) searches for wifi networks in range about every 10 seconds.  If you watch the wifi screen in ios setup, you can see the little circle spinning about every 10 seconds.  This corresponds exactly to the stuttering of the ios app - circle spinning, app stutters.  Circle stops, app is fine.  It's exactly the same on my iPad and iPhone.  HOWEVER, if I turn wifi off on my iPhone and connect via the cell network - no problems.  So it's definitely the device searching for wifi networks.  I have searched for ways to turn this off in ios but apparently it can't be done.  Turning off the Ask to Join Networks function doesn't help.  It still keeps searching.  Anyone have a "fix" for this?
Photo of Pat Hamp

Pat Hamp

  • 37 Posts
  • 8 Reply Likes
You can turn the hardware off, and that should do it.
Photo of Pat Hamp

Pat Hamp

  • 37 Posts
  • 8 Reply Likes
If you are running a Mac laptop. If you are running cellular then you should be able to shut of the seeking by turning off location and wifi.
Photo of Ken, K2KXK

Ken, K2KXK

  • 44 Posts
  • 9 Reply Likes
It seems that turning off location services stops iOS from searching for WiFi networks. Initial testing shows this greatly improves the stuttering problem. Not a great solution as some apps really need location services.
Photo of Ken, K2KXK

Ken, K2KXK

  • 44 Posts
  • 9 Reply Likes
Pat, which hardware are you referring too? Thanks.
Photo of Craig Williams

Craig Williams

  • 234 Posts
  • 72 Reply Likes
Looked at all the posts and tried all the solutions. Still lots of "stuttering" on the IOS app under every condition. Even direct to the ATT cell site running 100M down and 50M up, on an iPhone 6+, stuttering. Does NOT do this remote running Flex SDR on a Windows 10 laptop using my ATT access point router. Stutters within the home wireless net where I can stream HD movies on 2 devices at the same time with no buffering. Something is wrong with this app and it's not us.
Photo of Dave - W6OVP

Dave - W6OVP

  • 317 Posts
  • 100 Reply Likes
>Something is wrong with this app and it's not us.

Yes.

I swap an old Mini and a newer iPad back and forth between a 6300v1 and a 6400v2. Causes no end of problems with both iPads when making the switches. Including freezing of displays and loss of waterfall, and inability to QSY.

But both SDRs work fine when swapping between various desktops and ordinary laptops running remote.
Photo of Dudley - WA5QPZ

Dudley - WA5QPZ, Elmer

  • 230 Posts
  • 37 Reply Likes
Craig and others,

First on my iPhone 6 plus,  I have to close all the background apps ( double click the home button, close all other programs running there in the background)   I also have to turn OFF the WIFI Assist ,  ( Settings -> Cellular -> scroll to the bottom, switch to "Off"  ) 

I have the WIFI modes in the router set to 20 MHz channel,  instead of "Mixed" or "Auto"  .  

If your router is older than 3 years old,  might think about an update too,  to make sure you have at least a 802.11ac  protocols. 

If you have a lot of neighbors on WIFI,  this can mess up the continuous data pouring onto the WIFI network,  as your phone is constantly searching for the strongest WIFI signal,  Also unless you need it,  turn off   Bluetooth discovery .     

In the IOS app under "Settings"   I can use "Discover"   in the LAN Mode when on the same local subnet as the radio,  but usually "Scan "   works better when away from home QTH  or on the Cell network. 


Just a few things I have found that matters,  maybe this helps,

Dudley
WA5QPZ 
Photo of Craig Williams

Craig Williams

  • 234 Posts
  • 72 Reply Likes
Thanks for your input. The problem to me is, If I can use other 2 way programs like Facetime and Skype without re-configuring my entire phone what's up with the Flex IOS app?
Photo of Manfred HB9FLU

Manfred HB9FLU

  • 27 Posts
  • 2 Reply Likes
I gave it up with Ios app. I bought 2 new Ipads and 2 new Iphones - nothing helped.I have ultra fast internet connection and the latest neworking tools. I'm very dsiappointed. Now I use my Flex with a Maesro.

73 de Manfred