Interface between FLDIGI and 6500 still problem

  • 1
  • Problem
  • Updated 1 year ago
I have followed the YouTube tutorials to interface FLDIGI and SDR-6500.  It works BUT...
1) The SDR and FLDIGI frequencies don't sync.

More importantly, I need to turn VOX on to transmit from FLDIGI.  

With VOX off, I still see on the DAX control panel that TX is streaming, but no TX output from the 6500.

My RigCat card has smartSDR_SliceA, COM5 (Verified correct on the CAT interface), 115200, cat command for PTT and VSP enable ticked.

Any help would be appreciated...
Photo of Victor Gavron

Victor Gavron

  • 18 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of k3Tim

k3Tim

  • 849 Posts
  • 166 Reply Likes
Did you check the "CAT command for PTT" on the RagGAT setup screen?
Photo of Victor Gavron

Victor Gavron

  • 18 Posts
  • 0 Reply Likes
Yes...
Photo of Victor Gavron

Victor Gavron

  • 18 Posts
  • 0 Reply Likes
Please note that DAX control is showing that there is a transmitted signal.  I need to click either VOX or MOX for the 6500 to transmit.  Is that normal?  And i still can't sync frequencies.
Photo of k3Tim

k3Tim

  • 849 Posts
  • 166 Reply Likes
On my setup, VSP Enable is NOT-Checked.
Baud Rate is 9600

If you can't control Freq - it's game over.
If you change the settings above, best to restart FLDIGI.
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
Hi Victor:

In my setup I have the baud rate set to 38400. Everything else looks about the same. I use COM4 which is a serial port set up for slice A. When you are running FLDIGI open SmartSDR CAT. Does it show Process: fldigi beside COM5?

73,
Kev K4VD
Photo of k3Tim

k3Tim

  • 849 Posts
  • 166 Reply Likes
VSP - Serial Port is a Virtual device. 

It looks like I should have it checked but works without that.  Stooped so low as to actually read the manual.
Photo of Victor Gavron

Victor Gavron

  • 18 Posts
  • 0 Reply Likes
No, it shows "Process (none)"
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
This is probably where the control problem is then. You need a COM port set up for slice A in SmartCAT. Then you need to point fldigi to that port for control. Maybe a couple of screenshots of your SmartCAT setup would help. Both the main window and then click on the port you are using, select edit and show a screenshot of that.

Process: (None) means that flidgi is not connecting to the serial port. You don't also see "Slice Not Present" do you?

(Edited)
Photo of Victor Gavron

Victor Gavron

  • 18 Posts
  • 0 Reply Likes
My CAT configuration looks the same but without the process.  I guess something must be wrong with my FLDIGI setup (?).  Both TX and RX streams are showing that the information is being transferred, so presumably that means that some minor issue must still exist in FLDIGI.  Any suggestions would be appreciated!
Photo of Kevin K4VD, Elroy

Kevin K4VD, Elroy

  • 775 Posts
  • 171 Reply Likes
This part looks good to me. In Fldigi/Rig/RigCAT my settings are:



I think in your case everything would be the same except Device: COM5.

Also... are you certain you have the latest .xml file for SliceA? There was older versions floating around for a while. See this article for a link to the latest.

Kev
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
What version of Fldigi are you using?  v4.0.7 and possibly v4.0.8 had a bug in RigCAT 
https://community.flexradio.com/flexradio/topics/fldigi-set-up-cat
Photo of Victor Gavron

Victor Gavron

  • 18 Posts
  • 0 Reply Likes
I switched to 4.11 and it started working.  No obvious reason.  I had also tried 4.11 yesterday, with no success...