I just got m new FLEX-6600, and I am at a lost of why I can't get it in to Transmit.

  • 1
  • Question
  • Updated 3 days ago
  • (Edited)
I just got a brand new Flex-6600M Radio. It powers up and I can receive stations fine. I can't seem to get it to transmit. I have set the RF power, and can key the red light when I push my PTT Foot Pedal, but I do not see any transmit single. Do I have to change something in the Mic and TX Profiles, so it will know I am using a Balanced Audio Input for my HEIL PR-40 Mic? Also I need help getting my HF Amplifier set up.

Thank You.

Julie

KC0TMD
Photo of Julieber1

Julieber1

  • 8 Posts
  • 0 Reply Likes

Posted 3 days ago

  • 1
Photo of KF4HR

KF4HR

  • 543 Posts
  • 157 Reply Likes
Hi Julie.  Congratulations on your new 6600.  A few things to check:

* Select the mic input you want on the right side of the screen where it indicates "MIC" with a down arrow.  MIC is your front mic connection, BAL or LINE connections are your rear mic connections. 
* Make sure you have your Mic and Power levels turned up
* Ensure your mode is properly set (on Frequency Flag)
* Set your Antenna selections properly (ANT1, ANT2, etc), also on the Frequency Flag   


Photo of Julieber1

Julieber1

  • 8 Posts
  • 0 Reply Likes
Can any one call me at 636-578-1990 to help me get my Mic settings and Amp working with my Radio.

Thank You.

Julie.

KC0TMD.


Photo of AH0U

AH0U

  • 264 Posts
  • 32 Reply Likes
I have a 6700 so I’m not totally sure of your rig but before I’d do anything I’d check the TUNE button and slider to see if I had output then the RF slider to see if it is set at zero
Photo of Julieber1

Julieber1

  • 8 Posts
  • 0 Reply Likes
Can someone please call me at 636-578-1990 to help me get my Mic and Amp to work with my Flex-6600M.

Thank You.

Julie.

KC0TMD

Photo of Gayle Lawson

Gayle Lawson

  • 37 Posts
  • 15 Reply Likes
As KF4HR said, It sounds as if you do not have the balanced input selected.  I'm  using a Maestro to go though the menus, I think the 6600 M in close to what I have. 

On the right side of the front panel press the Mic/Speed knob, this will bring up a menu.  On the left side  of the screen select "BAL".  Next tocuh the Menu  at the meddle top of the screen.  On the left side of that menu touch "Phone/CW'".  In the microphone section select +20 dB (this turns on the mic preamp).  Also select level meter in RX.  touch "EXIT" to go back to the operation screen.  Now in the main screen, Tough one of the meters indicators until you see one with -40 to 0 on the top and the S meter on the bottom.  Speak into the mic, you should see the level indicator vary as you talk.  this tells that you have audio into the radio.   If all of the above condition's are correct you should be able to get RF power out when you key the radio

Hope this helps
Gayle K0FLY

Photo of Julieber1

Julieber1

  • 8 Posts
  • 0 Reply Likes
Gayle, Can you please call me at 636-578-1990.