I have 2.49 installed on my 6500 do I pay for version 3

  • 2
  • Question
  • Updated 5 months ago
I have version 2.49 on my 6500 do I have to pay for version 3
Photo of Tony Hateley

Tony Hateley

  • 305 Posts
  • 25 Reply Likes

Posted 5 months ago

  • 2
Photo of Mark WS7M

Mark WS7M

  • 505 Posts
  • 152 Reply Likes
When did you buy your 6500?   When you purchased it, if it was eligible for upgrades you would have been told that your upgrade to 3.x was included in the purchase.
Photo of Abed - AB5ED

Abed - AB5ED, Alum

  • 49 Posts
  • 15 Reply Likes
If you purchased your radio or SmartSDR v2 on or after Oct. 1, 2018 no additional payment is required. If you purchased a FLEX-6000 series radio prior to Oct. 1, 2018 there is a $199 fee (U.S.) to upgrade to this latest major version release. All subsequent point releases (v3.x) are available at no additional expense.
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 559 Posts
  • 190 Reply Likes
Tony

Download the new v3 smartsdr software and install it. When you start it up, it will see you need a license and present a dialog box that will initiate the purchase process (if that was your question!)

Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 887 Posts
  • 339 Reply Likes
This and many other related questions are covered in the SmartSDR FAQ here: https://www.flexradio.com/faq-smartsdr/.