I am trying to get my new 6600 working with WSJT-X RX works CAT does't

  • 2
  • Problem
  • Updated 1 year ago
  • Solved
I am setting up wsjt-x with my new 6600. Not clear what to put in the box for network. latest SRD and SRD CAT software. I have put in the Radio as Flex 6xxx and tried a number of Network Servers names. I have set up a com port and also set up a TCP port 60001 as discussed in some of the community postings. Tried the Kenwood 2000 Rig to no avail. The receive side of WSJT-X is working fine and decoding. Using Slice A. In the wsjt-x settings when i Test CAT is turns Red and get a message Rig Failure Hamlib error: Protocol error while opening connection to rig 
Or Hamlib error: Invalid configuration while opening connection to rigRig. 

Any suggestions would be appreciated. The inputs in the community seem to be different for different radios and different software versions. Maybe I missed something in the documentation. WSJT-X ver 1.8.0 K1JT . Has been working great with my FT1000MP MarkV. Flex 6600 also works will with HRD. 

73
Bill
W9JJB
Photo of bahillen

bahillen

  • 126 Posts
  • 43 Reply Likes

Posted 1 year ago

  • 2
Photo of NX6D Dave

NX6D Dave

  • 308 Posts
  • 94 Reply Likes
Pictures are worth thousands of words.  Here's how I have my CAT port set up:


 
and here is how I have my WSJT-X configured:



Here is the audio configuration:



And here is the radio configuration:



Select the DAX channel (1 in my case) in the slice receiver so that sound from the radio will go to DAX RX channel 1.  Select DAX as the transmitter input (blue button at the left).  Set the TX and RX passbands to your liking, mine are usually wide open, 0 to 5000 Hz.  Slice mode should be DIGU.

Set the TX power to 100% and control the TX level with the DAX TX control:



Make sure the RX and TX channels are turned on in the DAX control panel.

That should do it.

Dave / NX6D
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1339 Posts
  • 284 Reply Likes
Official Response
WSJT-X 1.80 release version on their site does not have an updated Hamlib library in it to support the new models of Flex radios (6400/6600). I have contacted the Hamlib developers and their current version of Hamlib is now updated.

I am in contact with the WSJT-X development team to have them update the Hamlib library in the official version on their site.

I have compiled Hamlib and WSJT-X with the changes. This is the same current version of WSJT-X (1.80) but includes the updated Hamlib to support the 6400/6600 radios.

Here is a link to download it from my Dropbox. 
https://www.dropbox.com/s/9qucywqxybjng0d/wsjtx-1.8.0-win32.zip?dl=0 

Just unzip, then install. You do not have to uninstall the 1.80 version you already installed.

As per previous instructions you need to create a TCP CAT port (which you did) and then choose Flex 6xxx for radio type and enter the IP 127.0.0.1:5004 (5004 is the TCP port I created, substitute the port number for whatever you created.

73
Dave wo2x
Photo of NX6D Dave

NX6D Dave

  • 308 Posts
  • 94 Reply Likes
Yep, I've been using the patched WSJT-X for so long I have more or less forgotten that it is a special version.

I have a full installer for WSJT-X 1.8.0 that contains the changes necessary for the 6400 and 6600 to be recognized, if you, or anyone needs it.

Since Bill said he couldn't get WSJT-X working using Kenwood TS2000, I included all of the configuration stuff above.

Here's my system running on TS2000:



Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1339 Posts
  • 284 Reply Likes
Both TS-2000 and Flex 6xxx do not work with 6400 or 6600 in the public release of WSJT-X 1.80. My post above has a link to the patched version on Dropbox if anyone needs it. 

For the tech heads - both the Kenwood.c and Flex.c files need to be updated with the new model Flex radios with the new radio IDs. That is the modification I've done to Hamlib.

I am working to get the authors of WSJT-X to update the Hamlib code and release a version with 6400/6600 support and to ensure future version of WSJT-X support all the Flex radios.

Note for Bill, if you are not using JT Alert, you should download and install the latest version. It fully supports logging to HRD.

Dave wo2x
(Edited)
Photo of Dale - K4DG

Dale - K4DG

  • 17 Posts
  • 3 Reply Likes
Dave:  Thanks for the tips and the updated/fixed version of WSJT-X. I had just installed my new 6600 and encountered this same problem as others when trying to run WSJT-X 1.8.0. Loading the modified WSJT-X file did the trick and now I can work FT-8 again! The Flex users community comes through again.

73 de Dale K4DG
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1339 Posts
  • 284 Reply Likes
You are welcome!

The upcoming WSJT-X 1.9 will have proper support for the new models. It is using the latest Hamlib library.

Dave wo2x
Photo of bahillen

bahillen

  • 126 Posts
  • 43 Reply Likes
David WO2X,

The WSJT-X zip file was just what the doctor ordered. This is what everyone using the new Flex6XXX will need. Dave NX6Ds configuration works first time after the new WSJT-X was updated for the 6400 and 6600 models.

I do use JTAlert-x all the time. Just started it up and it works fine.logged a contact.

Thanks for eveyones help. 
73
Bill W9JJB
Photo of NX6D Dave

NX6D Dave

  • 308 Posts
  • 94 Reply Likes
Here's a link to a full installer for WSJT-X, version 1.8.0, that contains the patches so that the FLEX-6400 and FLEX-6600 will be recognized as radios that the program can operate.

https://1drv.ms/u/s!AgvdqNf7I04lgd1993iFUQAMa-S8dg

I built this installer using the published source for 1.8.0 and the standard toolset used to build the program.  The modification is to simply add the device codes for the 6400 and 6600 to the list of Flex radios the program recognizes.  Since all of the radio models run the same SmartSDR program, they all are driven by a program like WSJT-X in the same way, as long as the program recognizes the radio as a Flex.

Credit where it is due, Dave Decoons, WO2X, worked with the Hamlib developers to create the patches.  I simply copied them into my copy of the WSJT-X 1.8.0 source code and turned the crank.
(Edited)
Photo of Dan -- KC4GO

Dan -- KC4GO

  • 339 Posts
  • 70 Reply Likes
I have my 6600 running as shown by Dave NX6D first set of pictures at the top of this link  with the modified version of WSJT-X running as FLEX-6xxx with no problem the only difference I'm using  used port 60000.  localhost:60000 (not the 6600)
Photo of bahillen

bahillen

  • 126 Posts
  • 43 Reply Likes
I got 4 instances of WSJT-X and 4 JTAlert working on 4 different bands on my Flex6600.  Check out my new Posting under All Ideas section. 
https://community.flexradio.com/flexradio/topics/new-flex6600-and-wsjt-x-multiple-instances-and-mult...

Thanks to David and Dave for providing the software patch and Pictures.

73
Bill W9JJB
(Edited)
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1338 Posts
  • 284 Reply Likes
You are welcome!

Dave wo2x
Photo of Paul W5PF

Paul W5PF

  • 48 Posts
  • 4 Reply Likes
I would like to see hoe you didi it, but can't find the "All Ideas" Section.

Paul W5PF
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1338 Posts
  • 284 Reply Likes
Paul

I believe you can create batch files to start multiple instances of WSJT-X. Maybe DanKC4GO can chime in, I think he does it all the time.

Also try a Google search

73
Dave wo2x
Photo of bahillen

bahillen

  • 126 Posts
  • 43 Reply Likes
At the top of the web page it is Ideas not All Ideas.
https://community.flexradio.com/flexradio/topics/new-flex6600-and-wsjt-x-multiple-instances-and-mult...

I wrote what I did and how but it is not a manual like documentation. You may have to get familial with some of the documentation for the various applications but It was my route to get to a working situation. some of the screenshots above also help with showing the popups for setting up the ports.

73 Bill W9JJB QRZ email is good for me.
(Edited)
Photo of Paul W5PF

Paul W5PF

  • 48 Posts
  • 4 Reply Likes
Thanks Bill and Dave. I found Bill,s post under ideas. Don't have my 6600 yet but doing something similar on the 6500.

Paul W5PF
Photo of bahillen

bahillen

  • 126 Posts
  • 43 Reply Likes
Title is 
New Flex6600 and WSJT-X multiple instances and multi Instances JTAlertX on SmartSDR
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1338 Posts
  • 284 Reply Likes
Paul

WSJT-X 1.8.0 doesn’t support the 6400 or 6600 since they weren’t released when v 1.8.0 came out. Further up I posted a link to a recompiled version of WSJT-X 1.8.0 with updated Hamlib to add the new models. If you get the radio before WSJT-X 1.9.0 is released you will need my recompiled version.

Just a heads up so you will be prepared.

Dave wo2x
Photo of bahillen

bahillen

  • 126 Posts
  • 43 Reply Likes
Dave,

Do you have any observations on stability with multiple instances? I takes a lots of things hooked together. There has been some comments / postings that Multiple Instances are not supported by the owner / code teams. 

For now I am happy. Great radio.

73
Bill W9JJB
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1338 Posts
  • 284 Reply Likes
I don’tbut Ibelieve Dan KC4GO does. Hopefully he sees this.

I may give it a shot tomorrow after work.

Dave
Photo of K3SF

K3SF

  • 259 Posts
  • 74 Reply Likes
Has any one recompiled the mac version of wsjtx for the 6400/6600?

TIA
Paul K3SF
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1338 Posts
  • 284 Reply Likes
Paul

I have not. If anyone wants to compile it, I have the two files available that need to be modified in the Hamlib source code.

Contact me direct.

Dave wo2x
Photo of Mario - DL3LSM

Mario - DL3LSM

  • 66 Posts
  • 24 Reply Likes
Hi Paul,

if you are using xCAT I have released a new version today (https://dl3lsm.blogspot.de/) where you can use a mask function so that the radio identifies as a Flex-6500 to WSJT-X (or other apps which are using Hamlib).

73, Mario DL3LSM
Photo of K3SF

K3SF

  • 259 Posts
  • 74 Reply Likes
hey mario

thanks for the update..

i dont have my 6600M in hand yet

expecting to here about it shipping any day now

i  will report how it works when it arrives

Paul K3SF
Photo of Steve Moore

Steve Moore

  • 6 Posts
  • 1 Reply Like
This is for Dave WO2X, I used the install file associated to your link and it's working perfect on my new 6600M.  Thanks for the help/info.   

Steve 
WB0AOD
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1334 Posts
  • 284 Reply Likes
You are welcome. The latest beta of WSJT-X, 1.90 rc3 as of this writing, now supports the new Flex radios.

Dave wo2x
Photo of Scott-ka0jwc

Scott-ka0jwc

  • 7 Posts
  • 0 Reply Likes
I have my 6600 set up with WSJT-X ver 1.8.0. Im receiving and decoding FT8 fine. When I transmit, the radio keys up, but I get no audio out. TX is turned on in DAX. It says its streaming.. CAT is using COM4
what am I missing?
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1334 Posts
  • 284 Reply Likes
Make sure that DAX is enabled on right side panel.

Dave
(Edited)
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1334 Posts
  • 284 Reply Likes
Photo of Scott-ka0jwc

Scott-ka0jwc

  • 7 Posts
  • 0 Reply Likes
yes, it is
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1334 Posts
  • 284 Reply Likes
OK, lets take it step by step.

When you click on TUNE in WSJT-X, does the radio key up? (You stated it does)

Open DAX control panel and make sure TX stream is enabled and blue.

Next, when clicking TUNE in WSJT-X see if the level bar for TX stream in DAX control panel shows output level. My setting is at 42 for the slider.

If that shows level then check the level in the right side P/CW panel in SmartSDR. 

Dave wo2x
Photo of Scott-ka0jwc

Scott-ka0jwc

  • 7 Posts
  • 0 Reply Likes
Yes, the radio keys up

In DAX, the TX stream is enabled and blue. It says its transmitting. I have slid the level back and forth but am leaving it at 52 for the moment. It shows no audio

I see nothing in the P/CW panel for audio output
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1334 Posts
  • 284 Reply Likes
OK, you are not getting audio from WSJT-X to DAX.

In WSJT-X setup/audio tab make sure you have it set like this

Dave wo2x

Photo of Scott-ka0jwc

Scott-ka0jwc

  • 7 Posts
  • 0 Reply Likes
Yes, thats how I have it
Photo of Scott-ka0jwc

Scott-ka0jwc

  • 7 Posts
  • 0 Reply Likes
im using the Kenwood TS 2000 radio as the rig in settings. If I try and use the Flex setting, it doesnt allow me to use a ser port of CAT. Not sure if that had anything to do with it
Photo of Bill -VA3WTB

Bill -VA3WTB

  • 3666 Posts
  • 888 Reply Likes
Scott, must still be something missing,, Dave is about the best there is on this stuff. Maybe go back over all your settings and follow as Dave shows.
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1328 Posts
  • 281 Reply Likes
Which version WSJT-X are you using? The official 1.80 does not work with radio set to Flex or TS-2000. You either need to use the 1.80 version I modified or download the WSJT-X 1.90 rc3 from https://physics.princeton.edu/pulsar/k1jt/wsjtx-1.9.0-rc3-win32.exe 

Then set it up as outlined above. You need to create a TCP com port in CAT.

Dave wo2x
Photo of K1DBO

K1DBO

  • 530 Posts
  • 111 Reply Likes
Scott,

Slice Master 6000 works with both the official 1.80 as well as the 1.90rc3 release of WSJT-X.  It will correct any problems it finds in your WSJT-X configuration and if asked to do so, will automatically launch WSJT-X anytime you switch the slice into DIGU mode.  Let Slice Master configure and launch WSJT-X for you and just ignore both the Radio and Audio tabs in the WSJT-X Setting dialog.

In SmartSDR, you'll still have to choose a DAX audio channel for your slice, and in the DAX Control Panel you'll still have to make sure that channel and the TX channel are enabled (blue).  But really, there's not much else to worry about.

Using Slice Master is not for everyone though.  It really takes all the fun out of configuring third party applications to work with your radio.

--Don
Photo of Scott-ka0jwc

Scott-ka0jwc

  • 7 Posts
  • 0 Reply Likes
I think I may have fixed the problem. After doing a restart of the PC and all the apps, I was getting an DAX error. Long story short, I un installed smart sdr and then reinstalled. After another PC re start, it seems to be working. Still not sure what happened. So ill blame it on Windows 10 ;-)

Thanks for all the help. Ive been fighting this for a few days and was getting a little frustrated.
Photo of Pat N6PAT

Pat N6PAT

  • 481 Posts
  • 191 Reply Likes
I miss XP. IMO the best version of Windows. Rock solid. Maybe that's why they dumped it because no one wanted to buy an upgrade.

This conversation is no longer open for comments or replies.