HRD DM 780 hangs if "call sign lookup" is used

  • 1
  • Problem
  • Updated 7 months ago
  • Solved
  • (Edited)

This is a workaround I developed for what seems to be a rare problem I had mid 2014. Recently another ham ran into the same situation and contacted me. I passed on my findings to him, which he successfully implemented.  I wanted to post the info here incase anyone else ran into this issue:

"In DM-780 when a station's call is displayed in the receive window and I right click on the station's call sign and then select "callsign lookup" from the dropdown, DM-780 hangs with the waterfall frozen."

The original description is midway down the comments in the following post:

However, I did not post the workaround there. So I will include the workaround in this separate posting. I had also described this problem in a problem Ticket with HRD - we discussed the problem but ultimately they had no clue.

My Setup: PSK31 mode, HRD rig control, Logbook and DM-780 running (all
Radio: FLEX 6500 with SmartSRD, SSRD CAT and DAX ( all
PC: Two monitors with NVIDIA GeForce GTX 650 adapter. Four core Asus 64bit with Win 8.1

================ The workaround ===================

In HRD Logbook, click configure, go down the list and click Radio Pane.

In the Radio Pane Configuration window (click Connection Tab).  The following settings have been used to correct the problem:

Address is "localhost" (selected with the button on left), no other entries in Address.

Port: 7809

Check Boxes:  neither of the boxes are checked (all unchecked) - this is the change that I made to correct the problem. In other words we want to prevent the logbook from connecting to the rig control program. (See Note #1 below for further detail)

Update Speed: Normal

...and of course one would not click on the "connect" button.

Once I set all this as above, I closed the HRD programs and reopened them. The problem went away.

Note #1:   In other words we want to prevent Logbook from connecting to Rig Control. Clicking Callsign Lookup or entering even just one character in the Callsign Lookup pane apparently attempts to communicate with HRD Rig Control or Logbook via the local host connection. Through experimentation I found the problem could be avoided by not having the Logbook program automatically connect to HRD Rig Control via localhost, and just let DM auto connect to localhost (default configuration for DM).

It seemed in my configuration, if both DM and logbook, which use localhost and the same port #, are communicating with rig control, DM and the other programs hang when HRD rig control is connected to the FLEX via the FLEX SmartCAT prog virtual port.

Photo of Ed - NZ1Q

Ed - NZ1Q

  • 79 Posts
  • 6 Reply Likes

Posted 5 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9478 Posts
  • 3666 Reply Likes
If you haven't done so, make sure you share this with HRD development.  Sometimes a workaround provide insight into the root cause of a problem.
Photo of Ed - NZ1Q

Ed - NZ1Q

  • 79 Posts
  • 6 Reply Likes
Thanks Tim - yes, I've included this info in my problem ticket with HRD. HNY!
Photo of Bryan


  • 1 Post
  • 0 Reply Likes
I had a similar issue.  For me the problem was DM 780 (Digital Master 780) would freeze if I right clicked the callsign.  Even if I hovered over the callsign the program would freeze for about 60 seconds.  It only happened when Logbook was opened and my radio was connected.

For me the solution was the following:

1. In DM780 go to program options>QSO>Receive tab.  Unclick "Show 'callsign worked status' popups".
2.  In HRD Logbook, go to Configure>Callsign Lookup> Enable tag.  Remove Subscription.

Close all HRD programs and restart them.

If this doesn't work, then you may have to go to Configure>Callsign Lookup> QRZ tag and delete the username and password.  Also check the local sources tab and make sure everything looks ok there.

This solution is definitely a work around.  When you need to use the QRZ subscription you can always add it back in at the Enable tag.

Hope this helps.
Photo of Michael Walker

Michael Walker, Employee

  • 1371 Posts
  • 407 Reply Likes
This is an HRD bug and they have confirmed it.  Please follow it on their site.