How do I turn on/off APF in V1.13

  • 1
  • Question
  • Updated 5 years ago
  • Answered
I am looking for documentation concerning the APF. Where do I turn it on or off, or set it's width?
Photo of W5UN_Dave

W5UN_Dave

  • 315 Posts
  • 30 Reply Likes

Posted 5 years ago

  • 1
Photo of Stu Phillips - K6TU

Stu Phillips - K6TU, Elmer

  • 642 Posts
  • 256 Reply Likes
Dave,

The control is only accessible in CW slices...

It replaces ANF in the DSP controls both in the Slice detail panel at the side and the flag panel.  The flag panel has a slider where the APF gain can be adjusted.

Stu K6TU

Photo of Robert -- N5IKD

Robert -- N5IKD, Elmer

  • 488 Posts
  • 152 Reply Likes
Here is a picture.
Photo of Ernest - W4EG

Ernest - W4EG

  • 594 Posts
  • 116 Reply Likes


Robert - N5IKD,

I love your answers!

The photos are worth a thousand words.  Please keep them coming...

Photo of Robert -- N5IKD

Robert -- N5IKD, Elmer

  • 488 Posts
  • 152 Reply Likes
I do like pictures and videos, they can tell a lot more than the author originally intends. 

I also understand Dave's question, as I had the same question when I first looked for the APF in 1.1.3.
Photo of Dale W4AEJ

Dale W4AEJ

  • 4 Posts
  • 2 Reply Likes


Flex 6500 with SmartSDR 1.1.3, Win7 Pro 64 bit.  

On my setup the APF slider does not appear to adjust the gain of the APF, but instead varies the bandwidth. 

I can verify this by watching the audio spectrum in MixW.  As I move the slider to the right the bandwidth decreases.  When I do that I also note that CW signals start to ring quite a bit.  The audio peak does not change.

I have done a cold boot of the radio to ensure everything has been re-initialized. 

Is my setup operating differently than intended?

Thank you and 73

Dale W4AEJ


Photo of Al / NN4ZZ

Al / NN4ZZ

  • 1733 Posts
  • 590 Reply Likes
Dale,
The slider adjusts the APF bandwidth in this version but changes are coming.  

Check out this link, details there, it also addresses the ringing. 

https://community.flexradio.com/flexradio/topics/apf_in_v1_1_2_does_not_seem_as_good

Regards, Al / NN4ZZ  
al (at) nn4zz (dot) com
Photo of W5UN_Dave

W5UN_Dave

  • 315 Posts
  • 30 Reply Likes
Go back to the previous version of APF. This new one is awful. The previous version of APF worked nicely. (don't fix it if it ain't broke)
Photo of Dale W4AEJ

Dale W4AEJ

  • 4 Posts
  • 2 Reply Likes

Flex 6500, SmartSDR 1.1.3.42, Win 7 Pro 64 Bit

While I normally use DAX, I still have the rear panel audio connected to my computer.   Today I switched my audio source from DAX audio to the rear panel audio (pin 2 on the 15 pin connector), and was surprised to see that, when running in USB mode, the CW APF still appears to be active.

I can move the peak around by switching to CW mode, changing the CW pitch, then switching back to USB mode.

Here is a view, in USB mode, with the CW pitch set to 2,000 Hz:


Here is the same view, also in USB mode, with the CW pitch set to 800 Hz:

I do not see these peaks when using DAX.

APF operates normally when in CW mode.

The release notes for 1.1.3 indicate that APF is no longer active in SSB modes. 

This is not really an issue as I normally use DAX, but an observation.  Is this unique to my setup, or has anyone else noted this?  I haven't seen anyone else bring this up for this version, unless my search missed it.

Thank you and 73,

Dale

W4AEJ




Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
You need to clear your persistence database, as APF was probably on when you had SSB selected prior to the v1.1.3 upgrade and now that the controls are CW specific, there is no way to turn it off.

To clear the persistence DB, power off the radio.  Press and hold the OK button while momentarily pressing the power button to turn on the radio.  Continue holding the OK button until the console display counts down to 1 and the "Calibrating..." message is displayed on the front console, then release.

This conversation is no longer open for comments or replies.