how to use a single ethernet cable connected directly to computer?

  • 1
  • Question
  • Updated 1 month ago
I can eventually get my Flex to connect using a ethernet  switch or direct to computer using only 1 ethernet cable going from radio to ethernet port on computer....I said eventually and once I do it works great.

SO What steps are the correct ones?

I reboot computer and radio multiple times and it eventually works but I see no rhyme or reason when it eventually does.
Photo of K5ROX

K5ROX

  • 128 Posts
  • 30 Reply Likes

Posted 1 month ago

  • 1
Photo of Ken Hansen

Ken Hansen

  • 332 Posts
  • 110 Reply Likes
I've not done this, but the issue likely involves ensuring the NIC on the PC has not residual settings from previous connection. The direct connect relies on something called 'auto-ip', which is when the computer has no settings set (no IP address), and there is no DHCP server to issue an IP address. This lack of configuration results in the computer NIC inventing an IP address in a pre-defined, standardized range (169.254.0.1-169.254.255.254).

To reliably connect a Flex radio to a computer directly, rather than rely on fail-safes and default settings, you could set both devices to two IP addresses in the private, non-reputable ranges (10.0.0.1 and 10.0.0.2, for example), and set the netmask to 255.255.255.0, don't worry about DNS and gateway settings. With these static IP settings the computer will find the radio no problem.
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 573 Posts
  • 203 Reply Likes
For self-assigned IP address allocation to work, both sides of the cable need to have DHCP (auto IP assignment) enabled, and no DHCP server available to do IP address assignment.

Further, some implementations will simply use the last stored / allocated IP address unless they either get a kick, which may or may not be delivered by disconnecting and reconnecting the Ethernet cable. Safest thing to do to hasten the process of self-IP assignment is to do a “DHCP renew” on the PC (how varies with O/S), and reset (soft power off / on) the radio, then wait for the DHCP assignment process to time out (since there is no DHCP server).
(Edited)
Photo of Danny K5CG

Danny K5CG

  • 361 Posts
  • 60 Reply Likes
If the PC and Flex are set to use DHCP and there is no DHCP server, both will get a default address in the 169.254.0.0/16 subnet and the PC will find the Flex. This is by design.
(Edited)
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 573 Posts
  • 203 Reply Likes
Well, yeah - isn’t that what I said, with some caveats? No one really cares that the IP address is in the 169. Range :-)
Photo of Danny K5CG

Danny K5CG

  • 361 Posts
  • 60 Reply Likes
"both sides of the cable" wasn't clear to me that you were talking about the PC and the Flex being the "sides", but yes we're talking about the same thing.
Photo of bahillen

bahillen

  • 156 Posts
  • 57 Reply Likes
Make sure you don’t have a bad or marginal Ethernet cable.
Photo of Dave Garber

Dave Garber

  • 15 Posts
  • 0 Reply Likes
did you push and hold the power switch on the flex.  it should go white light, untill it finds you assigned ip number from computer ethernet port  ( if it finds it)   make sure your ethernet port is active in device manager

Photo of K5ROX

K5ROX

  • 128 Posts
  • 30 Reply Likes
done reset, hold power till white.