How to enable "PC" on audio input menu?

  • 1
  • Question
  • Updated 3 years ago
When I open the audio input menu it shows MIC, ACC and PC, but PC also says "disabled" next to it. How do I enable it? I have tried many different settings on the Playback menu but no luck. What am I missing?  Running Win10 and N1MM Logger. I have Logger sound card enabled and have tried every playback option. Thanks, W6WRT
Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes

Posted 3 years ago

  • 1
Photo of Sergey, R5AU

Sergey, R5AU

  • 855 Posts
  • 116 Reply Likes
Bill, all in detailes described in SSDR UM in section "16 HOW TO OPERATE LAN REMOTE"
all works fine, probably you PlayBack Windows Audio Device are not configured properly
Photo of Rick - W5FCX

Rick - W5FCX

  • 259 Posts
  • 64 Reply Likes
Right click on speaker icon in Windows system tray (bottom right), choose Recording devices, then scroll through the list of devices and choose PC Microphone, USB Headset or your actual desired audio recording device. Choose Set Default.

Once a valid recording device is set, you can choose PC as the MIC device should be enabled.

I found after installing SmartSDR that it sets my default playback device to one of the DAC devices - very annoying.

Rick
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
I found after installing SmartSDR that it sets my default playback device to one of the DAC devices - very annoying. 

SmartSDR does not set you default audio device to a DAX driver.  This is a function of Windows.

If you do not remove the DAX drivers before installing a new version of SmartSDR for Windows, this behavior should not occur.  Uninstalling DAX and FlexVSP com drivers is never recommended before an upgrade. 
(Edited)
Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes

I'm confused. You are recommending a change in the Recording Device, but my problem is Playback. Also, neither of the recording devices you listed are available options. Again, I am trying to use N1MM Logger+ to send a .wav file when I press F1. What playback device or sound card to you have selected in the Logger sound card setup menu?

W6WRT

Photo of Craig - KØCF

Craig - KØCF

  • 181 Posts
  • 61 Reply Likes

In Logger, you select "DAX Audio TX" as the sound device. This plays the output of N1MM directly into the Flex radio transmitter. You must also enable DAX on the transmit control panel. It works like a charm!

73,
Craig, KØCF

Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes

That is exactly what I did and it does not work. Thanks anyway.

73, Bill W6WRT


Photo of Jay / NO5J

Jay / NO5J

  • 1649 Posts
  • 252 Reply Likes
Bill

Do you have a mic plugged into the PCs mic jack?
Windows has a habit of disabling unused Sound Card jacks.  
Just a guess.

 SDRgadgets

73, Jay - NO5J

Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes
No, there is no mike plugged into the PC mike jack. I will try that and see what happens. I'm starting to think there is something basic wrong with either Windows or SSDR. I'm going to try a complete removal and reinstall on a fresh copy of Windows 10. Desperate, as you can tell. :-) 
Photo of Craig - KØCF

Craig - KØCF

  • 181 Posts
  • 61 Reply Likes

You are looking for the wrong thing. You do NOT use the mic selector to use audio from the PC. There is a button on the right side of this panel labeled "DAX". You must click this to enable it (it turns blue when enabled). Now in the DAX control panel you will find that the TX stream is enabled. From N1MM+ you select DAX Audio TX as the device to send the wave files to. Try it... I promise you that it works. You are just trying to do the wrong thing to get this going.

Note that you can interleave audio from DAX (N1MM+) and the microphone. When DAX is not transmitting, you can speak into the mic to transmit (assuming your mic is plugged into either the front-panel Mic jack or the back-panel Balanced input).

The document by K9CT that you were referred to in the N1MM+ group Is excellent.

73,
Craig, KØCF

Photo of Bill Turner

Bill Turner

  • 73 Posts
  • 6 Reply Likes
I have followed the steps you outlined above and it did NOT work. In fact, I tried it three separate times. On a hunch, I did a total uninstall and reinstall of both SSDR and N1MM Logger+...and it WORKED, almost.  I still can not monitor the outgoing signal. The MON button is greyed out. Apparently I am supposed to use the PC's own speakers for monitoring, but I haven't figured that out yet. I'm sure it has to do with settings in Windows. Suggestions are welcome. Thanks to all who replied.  W6WRT