How do I permanently correct my 6500 frequency calibration?

  • 2
  • Question
  • Updated 4 years ago
My 6500 frequency display indicates 20Hz higher than the true frequency.  I can go into Radio Setup - Receive and perform a calibration against WWV which will fix it until I power off my 6500 and then it's off again next time I power up.  Is there any way to permanently set the calibration?  In PowerSDR there was a Calibration - Correction Factor that was permanently stored.

Thanks, Barry N1EU
Photo of Barry N1EU

Barry N1EU

  • 495 Posts
  • 124 Reply Likes

Posted 4 years ago

  • 2
Photo of Ken - NM9P

Ken - NM9P

  • 4239 Posts
  • 1351 Reply Likes
Is this parameter stored in the Global Profiles?  I don't have that list in front of me.
You can run a test and see by calibrating and then saving a global profile.  After powering down and back up, reload the profile and see if it reloaded the calibration numbers.

Ken - NM9P
Photo of Jim Gilliam

Jim Gilliam

  • 944 Posts
  • 218 Reply Likes

Yes it is save in the Global Profiles. I noticed the same thing and it retained the information once I stored it. It seems because this applies to all modes, etc. it is something that should be saved automatically without replicating the setting in all saved profiles.


Jim, K6QE

(Edited)
Photo of Roy - W5TKZ

Roy - W5TKZ

  • 141 Posts
  • 17 Reply Likes
Barry,

All the Flex radios have a drift in frequency related to the temperature of the master oscillator. Some are worse than others. You must let your radio warm up before attempting a calibration.

Having said that, you may find your calibration has drifted after you have used your radio in transmit for a while. This increases the drift from where you calibrated it.

I had this problem with my 6300 and being a stickler for being on frequency, I decided to upgrade to a 6500 with the GPSDO installed. That's the only way to assure that you are calibrated all the time.

I do not know what you are using to display your beat frequency with WWV but if you are using Fldigi, be aware that there is a dead band of +/- 10 cycles in the fldigi digital display. In other words, you can be tuned 10 cycles high or low on your radio and the fldigi digital display will show you spot on.

So if you want to be very accurate with your frequency, invest in the GPSDO and never be adrift again.

Good luck,

Roy - W5TKZ  
Photo of Barry N1EU

Barry N1EU

  • 495 Posts
  • 124 Reply Likes
I calibrated and had an offset of about -700 ppb.  I saved the Global Profile.  I shut down SSDR and cycled the power and opened SSDR.  The Offset was lost, it was now 0.  I restored the Global Profile that I had saved and the Offset is still 0.  What am I missing?
Photo of Mike Hoing

Mike Hoing

  • 281 Posts
  • 43 Reply Likes
This is from Tim 4 weeks ago

4 weeks ago
Photo of Tim - W4TME
Tim - W4TME, Customer Experience Manager
4287 Posts 1324 Reply Likes
Official Response
Your radio believes it has a GPSDO installed which is why the offset is reverting back to 0.

To fix, do the following:

Start SmartSDR and connect to your radio.
From the Settings menu, select the Radio Setup->GPS tab.
Click on the Uninstall button.
Close SmartSDR
Power cycle the radio
Start SmartSDR and connect to your radio.
From the Settings menu, select the Radio Setup->Receive tab
Run a frequency calibration
Close SmartSDR
Power cycle the radio
Start SmartSDR and connect to your radio.
From the Settings menu, select the Radio Setup->Receive tab

You should see the previous offset value now.
(Edited)

Mike
N9DFD
Photo of Barry N1EU

Barry N1EU

  • 495 Posts
  • 124 Reply Likes
Thanks Mike, THAT did it!
(Edited)