Here we go again!

  • 2
  • Problem
  • Updated 3 months ago
  • Acknowledged
This is getting ridiculous!

I sent my radio in to Flex for a frequency stability issue that was preventing FT8 decode. They got the radio on 5/13/19. They tell me I would hear from a tech within 10 business days. After no one contacts me after 10 business days I request an update.

The response was an apology but not update. Another week goes by and I ask for an update again. I also leave a voice mail but no one ever calls me back

I am told that there is an issue with the SWR bridge and that it is not related to the frequency problem that I send the radio in for. I am also told that at least three techs are working on it and they are swapping out components. No one ever asked me if I wanted it worked on. They did it without my authorization. That was not what I sent the radio in for.

Then I am told that the issue with the SWR bridge is actually merely a symptom of the original freq problem that I  sent the radio in for.

Then I am told that once again they believe the SWR bridge problem is separate from the freq problem.  Then I'm told the rig must go to an outside lab for chip repair. They x-ray the chip and all looks well.

Then I am told  it was generating spurs all over the place. Well I had many QSO's just prior to sending the rig in without a single comment or complain from anyone on the air.

Then I am told that they cannot diagnose the problem so they ended up replacing the entire transceiver board.

Then I am told that they have over $4,000 invested in this repair but will only charge me the 1.5 hours for replacing the XO and the cost of the XO plus return shipping - total of $257.58

Now today 7/1/2019 I finally get my radio back that Flex had since 5/13/2019. I fire it up and after having to reset a lot of things because it was rest to factory specs I get on the air.

I manage to make a few FT8 contacts and 2 SSB contacts. Then I just monitored FT8 for a few hours. Then I notice that nothing is decoding anymore - exactly the reason I sent it in to Flex.

I check the waterfall and it looks like a bunch of snakes just like it did before (see attached video).

So after all that it is exactly as it was when I first sent it in! A 2 year old $7,000 radio that does not work right!

All that time and money wasted because the problem still exists even after I was told by Gerald that they took care of the frequency issue

Is Flex not able to diagnose and fix their own radios? Gerald told me they could not find the cause of the problem. How can that be when they designed the radio?  Something to think about when you're plunking down $7K for those long sought after PGXL amps. Will they be able to fix those?

So here we go again. I now have to open up another ticket and only God knows when I will get the radio back this time! Thanksgiving? Christmas?

How will the cheerleaders put a positive spin on this?

Enjoy the video!



Photo of Pat N6PAT

Pat N6PAT

  • 844 Posts
  • 268 Reply Likes
  • very very frustrated!

Posted 3 months ago

  • 2
Photo of Eric - KE5DTO

Eric - KE5DTO, Official Rep

  • 913 Posts
  • 343 Reply Likes
Official Response
Pat,

We can appreciate your frustration with the situation.  Dan will be working with you per his comments above.